WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Black screen after GRUB TinyCorePure64-12.0  (Read 1920 times)

Offline Jip-Hop

  • Newbie
  • *
  • Posts: 10
Black screen after GRUB TinyCorePure64-12.0
« on: May 21, 2021, 12:31:15 AM »
I flashed TinyCorePure64-12.0.iso to a USB stick and I'm trying to boot from it on my PC (Fujitsu D3644-B motherboard, CPU Intel G5420). This motherboard can only boot via UEFI (no legacy support). After the GRUB menu, I no longer get any output on the screen (it stays black). I've tried connecting the screen on all of the available ports (2x Display Port and 1x DVI). But this didn't make any difference.

I verified the boot completes successfully by adding the superuser boot code to the corew option in the GRUB menu. I wait a little while, looking at the black screen, and then enter poweroff with the keyboard. The PC now powers off. So I know the system has booted successfully, I just don't get any display output.

The display, cable and ports work obviously. I can boot with an Ubuntu ISO without issues.

I also tried a couple of different values for vga=7xx but without effect. Any idea how I could debug this?

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9826
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #1 on: May 21, 2021, 05:31:03 AM »
Hi Jip-Hop
A search turned up this possibility:
Quote
This turned out to be a hidden BIOS option that needed to be disabled on the Fujitsu 3644-B motherboard. Go into PCI settings and disable "Above 4G decoding" and it works like expected.

Offline Jip-Hop

  • Newbie
  • *
  • Posts: 10
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #2 on: May 21, 2021, 08:31:06 AM »
Holy smokes that worked! Thanks :)

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9826
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #3 on: May 21, 2021, 08:34:29 AM »
Hi Jip-Hop
You are welcome. Thank you for confirming it worked. :)

Offline Jip-Hop

  • Newbie
  • *
  • Posts: 10
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #4 on: May 21, 2021, 09:49:27 AM »
I'm curious as to why Above 4G decoding needs to be disabled for TinyCorePure64. Do you have an idea? I didn't need to disable it for Ubuntu for example. Is there a way to make TinyCorePure64 work with Above 4G decoding?

I don't think I need it myself but my project is based on TinyCorePure64: https://github.com/Jip-Hop/sedunlocksrv-pba. Maybe others will need it.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9826
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #5 on: May 21, 2021, 12:03:38 PM »
Hi Jip-Hop
I'm curious as to why Above 4G decoding needs to be disabled for TinyCorePure64. Do you have an idea? ...
Sorry, I don't. All I can tell you is I found that answer here:
https://forum.proxmox.com/threads/installer-gives-black-screen-after-grub.48148/

Offline Jip-Hop

  • Newbie
  • *
  • Posts: 10
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #6 on: May 21, 2021, 02:13:22 PM »
Thank you. Maybe good to know is that with dCore-focal64 there's no black screen issue so no need to disable Above 4G decoding.

Offline gadget42

  • Full Member
  • ***
  • Posts: 103
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #7 on: June 26, 2021, 01:07:09 AM »
did some searching and reading on these topics to further our personal knowledge.

perhaps these links might save a few precious moments for others:

https://www.reddit.com/r/VFIO/comments/n90lsd/windows_10_vm_will_not_boot_if_above_4g_decoding/

https://www.guru3d.com/articles-pages/pcie-resizable-bar-performance-amd-and-nvidia-benchmarks,1.html

.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9826
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #8 on: June 26, 2021, 07:01:27 AM »
Hi gadget42
Welcome to the forum.

Thanks for the links. The reddit one suggests that Jip-Hop might be able to leave  Above 4G decoding  enabled and
disable  Resizable BAR  instead.

Offline PDP-8

  • Hero Member
  • *****
  • Posts: 884
Re: Black screen after GRUB TinyCorePure64-12.0
« Reply #9 on: November 09, 2021, 05:49:10 PM »

I also tried a couple of different values for vga=7xx but without effect. Any idea how I could debug this?

Yes.  Since we're using Xfbdev in TinyCorePure64, the vga=7xx option has no effect whatsoever if you change it.  It is a dummy option on 64bit Xfbdev, but *something* has to be there regardless - this has caught me a few times myself.

The quick solution is to modify your grub.cfg (permanently, or by doing it manually at first boot menu) and add a line to your boot stanza just prior to the kernel and init lines.

Ie, for 1024x768  use

Code: [Select]
set gfxpayload=1024x768
I use it often with temporary Ventoy installs when the grub menu appears.  I'll usually edit the "tcw" (TC usbWait) stanza with this just preceding it before I start it with F10

Some may not realize when temporarily editing the grub boot menu manually at boot, that they can actually ADD lines to it, such as the gfxpayload line - although naturally editing is limited to moving the cursor around, but no a big deal.

But yeah, sometimes I'll forget that since we're using Xfbdev with 64-bit (at least initially), that vga=xxx option has no effect, but it HAS to be there. :)
« Last Edit: November 09, 2021, 05:55:23 PM by PDP-8 »
That's a UNIX book! - cool  -- Garth