WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: DisplayLink  (Read 1236 times)

Offline Rabie

  • Full Member
  • ***
  • Posts: 108
Re: DisplayLink
« Reply #15 on: September 29, 2021, 08:39:30 AM »
Hi Rich,
Hi Rabie
Does  /var/log/Xorg.0.log  make any mention of your DisplayLink device?

Just an observation, but I see there is also a frame buffer driver (udlfb)  loaded for your DisplayLink device.

i think it says that FBTURBO is loaded and can't recognize any Monitor thats why it say also:
Code: [Select]
FBTURBO(0): Virtual size is 720x480 (pitch 720)could you find anything ?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13331
Re: DisplayLink
« Reply #16 on: September 29, 2021, 09:06:42 AM »
The piCore default is:
Code: [Select]
$ cat /mnt/mmcblk0p1/cmdline.txt
zswap.compressor=lz4 zswap.zpool=z3fold console=tty1 root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed

..you appear to be using:
Code: [Select]
coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=720 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  zswap.compressor=lz4 zswap.zpool=z3fold console=/dev/null root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed lang=de_DE.UTF-8 kmap=de waitusb=5 logo.nologo=1 vga=795
I would suggest using xf86-video-fbdev instead of xf86-video-fbturbo, remove bcm2708_fb.fbwidth=720, bcm2708_fb.fbheight=480, bcm2708_fb.fbswap=1, vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 and vga=795 and try again.

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 752
Re: DisplayLink
« Reply #17 on: September 29, 2021, 01:51:05 PM »
The rpi firmware is injecting that extra stuff into the command line based on what it is detecting (or not detecting)

The fbwidth and fbheight can be overridden in the config.txt using the

 framebuffer_width and framebuffer_height directives.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13331
Re: DisplayLink
« Reply #18 on: September 30, 2021, 01:01:00 AM »
Ah - so it is, I learnt something there  :)

Offline Rabie

  • Full Member
  • ***
  • Posts: 108
Re: DisplayLink
« Reply #19 on: October 03, 2021, 06:35:11 AM »
Hi Juanito,

The piCore default is:
Code: [Select]
$ cat /mnt/mmcblk0p1/cmdline.txt
zswap.compressor=lz4 zswap.zpool=z3fold console=tty1 root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed

..you appear to be using:
Code: [Select]
coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=720 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  zswap.compressor=lz4 zswap.zpool=z3fold console=/dev/null root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed lang=de_DE.UTF-8 kmap=de waitusb=5 logo.nologo=1 vga=795
I would suggest using xf86-video-fbdev instead of xf86-video-fbturbo, remove bcm2708_fb.fbwidth=720, bcm2708_fb.fbheight=480, bcm2708_fb.fbswap=1, vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 and vga=795 and try again.

this is my cmdline:
Code: [Select]
cat /mnt/mmcblk0p1/cmdline.txt
zswap.compressor=lz4 zswap.zpool=z3fold console=/dev/null root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed lang=de_DE.UTF-8 kmap=de waitusb=5 logo.nologo=1 vga=795

so i tried switching to xf86-video-fbdev.tcz but i am getting the same "green screen"
[/code]

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9573
Re: DisplayLink
« Reply #20 on: October 03, 2021, 07:23:40 AM »
Hi Rabie
I don't think the  vga=  boot code is valid for Raspberry pi.

I also noticed this in your log file:
Code: [Select]
[    47.806] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

Offline Rabie

  • Full Member
  • ***
  • Posts: 108
Re: DisplayLink
« Reply #21 on: October 03, 2021, 08:18:17 AM »
Hi Rich,

Hi Rabie
I don't think the  vga=  boot code is valid for Raspberry pi.
ok i just removed the VGA Code

Quote
I also noticed this in your log file:
Code: [Select]
[    47.806] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

but i haven't connect the second Monitor yet. i just connected the first one with the displaylink to get this work  :-\



Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13331
Re: DisplayLink
« Reply #22 on: October 03, 2021, 09:21:49 AM »
That (WW) indicates the message is a warning rather than an error.

It appears that the green screen indicates udl is loaded and the displaylink has been found - what does:
Code: [Select]
$ xrandr —listproviders ..give?

See also archwiki displaylink.

Offline Rabie

  • Full Member
  • ***
  • Posts: 108
Re: DisplayLink
« Reply #23 on: October 03, 2021, 11:19:06 AM »
Hi Juanito,
That (WW) indicates the message is a warning rather than an error.

It appears that the green screen indicates udl is loaded and the displaylink has been found - what does:
Code: [Select]
$ xrandr —listproviders ..give?

See also archwiki displaylink.

this:
Code: [Select]
xrandr --listproviders
Providers: number : 0