WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?  (Read 1545 times)

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9587
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #15 on: September 14, 2021, 11:18:26 AM »
Hi onelife
... not sure if that was needed ...
Yes, that is needed. When you load  compiletc.tcz  it loads all of the extensions required for a proper tool chain. In the
past I've seen people have problems because they loaded just gcc, make, and a couple of others instead of compiletc.

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #16 on: September 14, 2021, 11:39:00 AM »
Okay. Great - yay one thing right. Now to understand the error. But as I say I could be doing completely the wrong thing, although it's a script you just run so I'm sure something can't be right unless I'm really missing something.

Looking at all the lines of code that run during the compile I can't say I know enough to move forward.

Any suggestions on how we can build vtun?

Thank you.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #17 on: September 15, 2021, 01:49:49 AM »
The main problem is that the new openssl breaks vtun.

You'll need the patch set from here: http://deb.debian.org/debian/pool/main/v/vtun/vtun_3.0.4-2.debian.tar.xz

..then, using vtun-3.0.4

* load the compiletc, openssl-dev and lzo-dev extensions
* apply the patch set
* overwrite config.sub and config.guess with the files from the libtool extension
* edit the configure script and correct the lines staring with for p in $LZO_HDR_DIR, $SSL_HDR_DIR, $BLOWFISH_HDR_DIR..
* ...for the actual location of the headers
* run the configure script with the piCore standard flags
* make
* sudo make install

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #18 on: September 15, 2021, 02:00:08 AM »
Thank you for that Juanito,

I can try but this isn't something I haven't done before and not really sure - As I'm using vtun commercially I'm more than happy to pay for this to be do - Are you in a position to maybe do this? If so we can chat and send me a paypal invoice to tackle it?

I have no idea how long that would take even though the steps sound simple - But happy to make it worth your time and effort - Please let me know.

Kind Regards.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #19 on: September 15, 2021, 03:05:54 AM »
The extensions in the repo are user contributed for free  :)

I'll try to compile vtun for piCore in the next couple of days.
« Last Edit: September 15, 2021, 03:14:21 AM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #20 on: September 16, 2021, 01:27:35 AM »
posted - not tested

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #21 on: September 16, 2021, 08:35:48 AM »
Wow - That is super awesome that you compiled it - Sadly I installed from the repo and it seems to not be working :(

It fires up but then dies immediately - I've tried with exact same config that works on other systems but no luck.

I thought maybe the openssl version would make a difference? The new vtun is :

OpenSSL 1.1.1g  21 Apr 2020

And on the server side is :

OpenSSL 1.1.1  11 Sep 2018

Would that maybe make a difference?

If not, I'm really not sure how would I check this should work beside a config that I have already done?

Sorry to be helpless here - But any ideas?

Thank you!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #22 on: September 16, 2021, 08:48:20 AM »
Does “sudo vtund -n” give any useful error messages?

Is the ipv6-netfilter kernel modules extension required?
« Last Edit: September 16, 2021, 08:51:10 AM by Juanito »

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #23 on: September 16, 2021, 10:25:37 AM »
nope, vtund -n gives the normal "usage" command - So I wonder if that info is given does that mean all is good?

I installed the ipv6 net filter and that seemed to make some difference in that now the tunnel comes and drops, up and drops - It's as if the session opens but then is immediately closed - rather odd.

I then also installed iptables as thought maybe that would help but no further progress. It's odd, on the server side I get the connection but then immediately closes again. On the client side I don't actually see the vtun interface come up at all.

Any other ticks you can think of that I might need to poke at?

Thank you again :)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #24 on: September 16, 2021, 11:03:14 AM »
The piCore-13.x openssl is 1.1.1k, so there maybe a mismatch, but I doubt it.

Vtun is old and many patches were applied - perhaps the problem is there?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #25 on: September 17, 2021, 01:21:14 AM »
Does vtun need pppd and/or the ppp kernel modules (the latter are not present in piCore-13.x)?

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #26 on: September 17, 2021, 01:42:28 AM »
yes, it seems to reference that on the config - I in fact tried to look for ppp "tcz" but no luck - Is that something easy to bring into tv 13?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #27 on: September 17, 2021, 02:34:37 AM »
The ppp extension exists in the piCore armv6, armv7 and armv7l repos - which model of RPi are you using? (Note that I will add the ppp kernel module extensions shortly.)

If I understand correctly, you had vtun working without problems with piCore-8.x, but the ppp extension does not exist in the 8.x repos.

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #28 on: September 17, 2021, 02:57:12 AM »
Yip, you are 100% right - our current TC 8 doesn't have pppd.tcz installed - but the config seems to reference it - So maybe it's not valid at all :(

If I compare modules - our current working TC 8 has :

Code: [Select]
Module                  Size  Used by    Tainted: G 
tun                    18881  2
i2c_dev                 6500  0
brcmfmac              187979  0
brcmutil                5965  1 brcmfmac
cfg80211              443864  1 brcmfmac
snd_soc_bcm2835_i2s     6302  0
snd_soc_core          129843  1 snd_soc_bcm2835_i2s
snd_bcm2835            20533  1
snd_pcm_dmaengine       3467  1 snd_soc_core
snd_pcm                78164  4 snd_soc_core,snd_bcm2835,snd_pcm_dmaengine
snd_timer              19842  1 snd_pcm
snd                    54703  5 snd_soc_core,snd_bcm2835,snd_pcm,snd_timer
squashfs               29810 76
rfkill                 16951  2 cfg80211
bcm2835_wdt             3472  0
bcm2835_gpiomem         3207  0
i2c_bcm2708             4948  0
zram                   22044  1
zsmalloc               12420  1 zram
lz4_compress            3092  1 zram
spi_bcm2835             6880  0
uio_pdrv_genirq         3202  0
uio                     8755  1 uio_pdrv_genirq

While the latest TC 13 has :

Code: [Select]
Module                  Size  Used by    Tainted: G 
tun                    53248  0
ipv6                  507904 18 [permanent]
brcmfmac              299008  0
brcmutil               20480  1 brcmfmac
cfg80211              798720  1 brcmfmac
rfkill                 32768  2 cfg80211
snd_bcm2835            28672  1
snd_pcm               114688  2 snd_bcm2835
snd_timer              36864  1 snd_pcm
snd                    77824  4 snd_bcm2835,snd_pcm,snd_timer
fixed                  16384  0
squashfs               40960 159
raspberrypi_hwmon      16384  0
zram                   28672  1
zsmalloc               28672  1 zram

Perhaps you can see something - Maybe the lz4compress? Although that tcz is installed on TC 13 - Maybe the module is just not loading in TC13?

Chat now - Thanks

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13347
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #29 on: September 17, 2021, 03:02:15 AM »
ppp-modules-KERNEL added to piCore-13.x repos and ppp dep file added.

Note that the extension is called ppp and not pppd, but it contains pppd.