WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?  (Read 1567 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13351
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #30 on: September 17, 2021, 03:10:42 AM »
lz4_compress.ko is not included in any extensions in 13.x, but I doubt it is needed by vtun.

Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #31 on: September 17, 2021, 03:20:04 AM »
Sadly, even with ppp module added seems no luck :(

On our server side FYI, the "instant drop" and "reconnect" shows as this if it's any help :

Code: [Select]
Sep 17 12:15:04 server vtund[32982]: Session vpn_raspberry_new[41.216.204.144:51900] opened
Sep 17 12:15:04 server vtund[32982]: LZO compression[level 9] initialized
Sep 17 12:15:04 server vtund[32982]: Blowfish-128-ECB encryption initialized
Sep 17 12:15:04 server vtund[32982]: Connection closed by other side
Sep 17 12:15:04 server vtund[32982]: Session vpn_raspberry_new closed
Sep 17 12:15:10 server vtund[33131]: Use SSL-aware challenge/response
Sep 17 12:15:10 server vtund[33131]: Session vpn_raspberry_new[41.216.204.144:51901] opened
Sep 17 12:15:10 server vtund[33131]: LZO compression[level 9] initialized
Sep 17 12:15:10 server vtund[33131]: Blowfish-128-ECB encryption initialized
Sep 17 12:15:11 server vtund[33131]: Connection closed by other side
Sep 17 12:15:11 server vtund[33131]: Session vpn_raspberry_new closed
Sep 17 12:15:17 server vtund[33243]: Use SSL-aware challenge/response
Sep 17 12:15:17 server vtund[33243]: Session vpn_raspberry_new[41.216.204.144:51902] opened
Sep 17 12:15:17 server vtund[33243]: LZO compression[level 9] initialized
Sep 17 12:15:17 server vtund[33243]: Blowfish-128-ECB encryption initialized
Sep 17 12:15:17 server vtund[33243]: Connection closed by other side
Sep 17 12:15:17 server vtund[33243]: Session vpn_raspberry_new closed

So that is why the compress or encryption I suspect is the issue - But hummm, not sure what I can do to poke more?

Perhaps it's interesting to note that the vtun process doesn't "die" - IOW, it stays the same PID so I do think vtun is "working" and it's maybe something related that can be solved?


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13351
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #32 on: September 17, 2021, 03:39:31 AM »
The lzo extension is a dep of vtun, so it should be loaded (/usr/local/lib/liblzo2.so*).

You can obtain the lz4_compress module from http://tinycorelinux.net/13.x/armv7/releases/RPi/src/kernel/5.10.16-piCore-v7_modules.tar.xz if you wish to try it.

For troubleshooting purposes you could try replacing the piCore vtun with the one from the RPi os or debian?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13351
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #33 on: September 17, 2021, 04:02:49 AM »
You could also try recompiling vtun - see http://tinycorelinux.net/13.x/armv7/tcz/src/vtun - without the debian patch 00-sslauth.patch (ref /dev/random, which is not present?).


Offline onelife

  • Full Member
  • ***
  • Posts: 141
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #34 on: September 24, 2021, 08:20:55 AM »
Hi there Forum,

I thought for the benefit of this thread I would comment to say I've had no luck with another recompile of vtun :(

So for now I will attempt to move to open-vpn.

As mentioned, vtun is a very old programme so perhaps it has reached end of life.

BIG thank you to all who tried to assist me in making it work on TC 13 - Much appreciated.



Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13351
Re: Is it possible to update 8.1.5 for Raspberry Pi 3B+ board support?
« Reply #35 on: September 25, 2021, 01:38:17 AM »
You could try feeding /dev/random with the rng-tools extension and then retrying vtun?

Code: [Select]
$ sudo rngd --rng-device=/dev/hwrng
« Last Edit: September 25, 2021, 03:29:47 AM by Juanito »