WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.  (Read 2278 times)

Offline jesito

  • Newbie
  • *
  • Posts: 7
Hi everybody,
New to TC,  discovered it when looking for a lightweight distro to power my old Dell Latitude C800. It has a nice screen of 1600x1200 resolution, so I want to use it as a VNC viewer for my remaining computers. So far everything seems to be okay with some minor troubles (i.e. I cannot use Awesome as a target WM on the destination computer because the VNC stuff drops the Win key used as a lead for all the Awesome commands).
When trying to use Chromium, some of the sites return the above mentioned error:

@Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.

OpenSSL-1.1.1.tcz is installed.

I have no clues on how to fix it, so any help will be very welcome.

Thanks in advance.

Jes.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10661
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #1 on: July 13, 2021, 11:40:22 PM »
Browsers usually bundle their own SSL libs, so updating the distro's ones doesn't help any. Chromium specifically hasn't been updated in a while since there's no maintainer for it, you may want to use another browser, or download a chromium binary from somewhere.
The only barriers that can stop you are the ones you create yourself.

Offline jesito

  • Newbie
  • *
  • Posts: 7
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #2 on: July 14, 2021, 12:36:51 AM »
Many thanks.
Which one would you recommend?
Is there any preferred browser for Tiny core?
Again, thanks!.

Jes.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13807
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #3 on: July 14, 2021, 01:02:14 AM »
There are several browser options in tinycore - enter the tag "browser" in the apps gui to see a list of them.

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 628
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #4 on: July 14, 2021, 01:03:07 AM »
Hi jesito!

chromium-browser.tcz was last updated
"Current:  2012/11/09 Updated to 23.0.1271.64"
This is citation from chromium-browser.tcz.info file. It resides in the same repo with .tcz along with .dep and .md5.txt files. Info files are shown by "tce" as "About" and by "Apps" as "Info".
I use seamonkey, but it seems to me that most updated is Firefox. There is firefox_getlatest.tcz extension in current repo. You can download it and following instructions in the .info file will allow You to build firefox.tcz extension.

Happy browsing!

Offline jesito

  • Newbie
  • *
  • Posts: 7
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #5 on: July 14, 2021, 08:03:45 AM »
Thanks a lot!. I'll try them.

Offline jesito

  • Newbie
  • *
  • Posts: 7
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #6 on: July 14, 2021, 03:47:24 PM »
I think I forgot to say I'm currently using Tiny Core 32 bit.
Installing Firefox-ESR gives "illegal instruction" when launching...
I can't see any other browser besides Chromiun in tje apps browser.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10149
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #7 on: July 14, 2021, 07:06:33 PM »
Hi jesito
... Installing Firefox-ESR gives "illegal instruction" when launching... ...
Your processor does not support one or more instructions. A search suggests it's due to missing one or more
of the  sse, sse2, or movsd  instructions.

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 628
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #8 on: July 14, 2021, 11:19:01 PM »
Maybe seamonkey-noSSE2.tcz will fit ...

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10661
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #9 on: July 14, 2021, 11:44:40 PM »
If your cpu is too old to have SSE2, it won't run any recent chromium either. That too has raised the minimum years ago.
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13807
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #10 on: July 15, 2021, 03:24:20 AM »
Using the apps gui tags=“browser" gives:

chromium-browser
dillo-beta
elinks
epiphany
firefox-ESR
icecat
links
netsurf
opera-12
opera9
palemoon
seamonkey
vivaldi

« Last Edit: July 15, 2021, 05:13:41 AM by Juanito »

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10149
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #11 on: July 15, 2021, 06:49:19 AM »
Hi jazzbiker
Maybe seamonkey-noSSE2.tcz will fit ...
According to Dell, his laptop has a  Mobile Intel Pentium III  processor. That CPU lacks both  sse  and  sse2.
I'm guessing  seamonkey-noSSE2.tcz  still requires  sse.


Offline GNUser

  • Hero Member
  • *****
  • Posts: 846
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #12 on: July 15, 2021, 07:39:13 AM »
Hi, jesito. brave-browser is basically chromium plus a few privacy and speed enhancements. I will try to upgrade the version in the x86_64 repo twice a year or so (latest version is from June 2021).

You didn't mention your architecture. If you are on x86_64, give brave-browser a try. It is not available for x86, unfortunately.

EDIT: Just saw your subsequent post saying you use 32-bit. Oh, well. Sorry I couldn't help :-\
« Last Edit: July 15, 2021, 07:41:37 AM by GNUser »

Offline jesito

  • Newbie
  • *
  • Posts: 7
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #13 on: July 15, 2021, 11:16:09 PM »
Thanks to everybody!. This is a really helpful forum :O)
Yes, my Dell has a 32bit P3 Coppermine and lacks SSE2, so I tried the jazzbiker suggestion and installed  "Seamonkey non SSE2" and it works very well. The only limitation is the physical memory that the machine currently has (384Mb). I'm currently looking for a PC100 SODIMM of 256Mb to scale up that to 512Mb. Watcher tells me that using Seamonkey the system is taking 81% of the physical memory and 42% of the swap, so it becomes a little slow. Even Onshape (onlline CAD) is able to run on it (yes, too slow to be practical, but is running). To me is enough, I need a browser for occasional use. I write this on Seamonkey :O)

Thanks also to Juanito, I didn't know the application selection by tags, (now I know). I just installed epiphany, have to test it. I used it heavily in the past.
Again many thanks to everybody, it's a pleaseure to be here.

Jesito.

Offline jesito

  • Newbie
  • *
  • Posts: 7
Re: Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.
« Reply #14 on: July 15, 2021, 11:22:52 PM »
Well, Epiphany seems to need SSE2 as well....
Stick to Seamonkey by now.