WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: KeePassX 0.4.3 on tce12.0-32  (Read 2405 times)

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
KeePassX 0.4.3 on tce12.0-32
« on: May 24, 2021, 11:52:06 AM »
hi TinyCoreTeam,

with tce12.0-32 I downloaded keepassx.tcz from repository and tried to start ist, but no success.

So I remembered how I got keepassx  to work on  tce11.0-32 and tried the same with tce12.0-32:

From a tce8.0 where keepassx was working I copy

tc@box:~$ sudo cp -a  /mnt/sdb1/tce11.0/optional/keepassx.* /mnt/sdc1/tce12.0/optional/
tc@box:~$ sudo cp -a  /mnt/sdb1/tce11.0/optional/qt-4.x.base.* /mnt/sdc1/tce12.0/optional/
tc@box:~$ sudo cp -a  /mnt/sdb1/tce11.0/optional/qt-4.x.xml.* /mnt/sdc1/tce12.0/optional/

and, after restart with tce12.0 I open the AppsBrowser,
click on  [ Apps ]  Load App Locally

libmng.tcz
libpulseaudio.tcz
mirrors.tcz
qt-4.x-base.tcz
qt-4.x-xml.tcz

click on  keepassx.tcz  [  Load  ]

and now the green KeePassX icon appears in the wBar while the other .tcz extensions move to the Results side.

Now I can open KeePassX and use my keepassx databases.as desired.

On rundown keepassx is not saved, so I have to repeat this action after every reboot.
On extensions ftp://update keepassx and the other "oldstyle" extensions should not be marked.

This works for me.

Greetings
chattrhand
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #1 on: May 24, 2021, 12:52:03 PM »
What error message do you get when you try to start keepassx in tc-12?

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #2 on: May 25, 2021, 01:01:28 AM »
Hi Juanito,

on a fresh tce12.0-32 installation with firefox-ESR only I added keepassx.tcz from repository.

I started it by aterm, but keepassx did neither open nor finish its starting procedure. So I had to stop it with [ctrl-c].

And that's what aterm reported:

Code: [Select]
tc@box:~$ keepassx
qt.qpa.xcb: failed to initialize XRandr
qt.qpa.xcb: XKeyboard extension not present on the X server
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-tc'
Xlib:  extension "XInputExtension" missing on display ":0.0".
Unable to load auto-type plugin:
Unknown error
libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

^C
tc@box:~$

Thanks for your help
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #3 on: May 25, 2021, 02:50:45 AM »
The problem is with qt-5.x, which will not work with Xvesa.

keepassx works for me with Xorg-7.7:
Code: [Select]
$ keepassx
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-tc'
libEGL warning: DRI2: failed to authenticate
libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

libEGL warning: DRI2: failed to authenticate
libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

..but those warnings are referring to libs supplied by Xorg-7.7-3d.

Unfortunately keepassx only has qt-5.x as a gui option.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #4 on: May 25, 2021, 02:51:55 AM »
..I adjusted the qt-5.x-base dep file

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #5 on: May 28, 2021, 10:51:44 AM »
Hi Juanito,

As you recommended I updated tce12.0-32, the only dependency to actualize was  fltk-1.3.tcz. firefox 88.0.1 is the latest.

Again I start keepassx via aterm and get the following report:

Code: [Select]
tc@box:~$ keepassx
qt.qpa.xcb: failed to initialize XRandr
qt.qpa.xcb: XKeyboard extension not present on the X server
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-tc'
Xlib:  extension "XInputExtension" missing on display ":0.0".
Unable to load auto-type plugin:
Unknown error
libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

libEGL warning: MESA-LOADER: failed to open swrast: /usr/local/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/local/lib/dri)

^C
tc@box:~$

If this info helps: these extensions are installed:

Xorg-7.7-lib.tcz
qt-5.x-base.tcz
qt-5.x-dbus.tcz
qt-5.x-extended.tcz
qt-5.x-opengl.tcz
qt-5.x-sql.tcz
qt-5.x-xml.tcz

TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #6 on: May 28, 2021, 11:01:58 AM »
It looks like you’re using Xvesa?

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #7 on: May 28, 2021, 12:16:37 PM »
Hi Juanito,

yes I'm using Xvesa on tce12.0-32bit.

When I'm running tce12-0-64bit Xvesa is greyed out in the control panel, instead I see a lot of Xorg files in /optional

btw. I have taken a copy of my tce12.0-32 installatiion where keepassx was runnig with  qt-4.x-base and qt-4.x-xml and did an update of keepassx. This updated keepassx and added  qt-5.x-base  and  qt-5.x-opengl plus  libgcrypt  and  libzstd. (all with .tcz)

keepassx can't be started. Its reports by aterm are now very short:
Code: [Select]
tc@box:~$ keepassx
keepassx: error while loading shared libraries: libgpg-error.so.0: cannot open shared object file: No such file or directory
tc@box:~$

Thanks for your help!

TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10210
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #8 on: May 28, 2021, 12:24:17 PM »
Hi chattrhand
Maybe you need to install  libgpg-error.tcz.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #9 on: May 28, 2021, 12:45:50 PM »
I’m pretty sure the qt-5.x version of keepassx will not work with Xvesa.

Xvesa is 32-bit only.

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #10 on: May 29, 2021, 03:25:02 AM »
hi Juanito, Rich,

I took your idea and installed  libgpg-error.tcz  and tried again.

This time keepassx  complained a missing  libicui18n
I blind-searched the AppsBrowser and found  icu62.tcz

After installing and re-run keepassx complained a missing  libpcre2-16.

I found pcre2.tcz and installed it, and now keepassx reports:

Code: [Select]
tc@box:~$ keepassx
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb.

Aborted
tc@box:~$

Now I searched the available platform plugins proposed; but before trying everything I would ask whether I'm on the right track.

Greetings and thanks for your help!

TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #11 on: May 29, 2021, 03:33:42 AM »
That error means you need to use Xorg-7.7

Offline chattrhand

  • Full Member
  • ***
  • Posts: 132
Re: KeePassX 0.4.3 on tce12.0-32
« Reply #12 on: May 29, 2021, 12:52:46 PM »
Hi Juanito, Rich,
-
I tried it and installed  Xorg-7.7  with all of the dependencies required,- no effect

I removed Xvesa : no warning by the Apps Browser. The only effect was that  the de-DE keyboard had a fallback to en-US.

So for the next time I will continue using  tce12.0-32  on my old 32bit-Dell I7500 only.
Keepassx 0.4.3  with  qt-4.x  dependencies works for me.

Thank you for your help!
TinyCore, SliTaz, LinuxMint, Tails, Mac ...