WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: ALSA Sound ACL888-VD  (Read 408 times)

Offline gharig

  • Newbie
  • *
  • Posts: 13
ALSA Sound ACL888-VD
« on: September 22, 2021, 04:05:57 PM »
Hello Everyone,

So my problem today is that I'm trying to get the sound to work on a Winsystems C412 CPU. The sound chip is and ALC888-VD and is part of the CPU card.

I installed Tinycore 12.0 (32 bit). I hear the speakers pop when I run speaker-test but no sound plays. I figure the pop sound is a good sign.

So the next thing I did was to load up Ubuntu 12.04 on the Winsystems C412 and I had the same problem, no sound. I went to the search and found that if I made an entry into alsa-base.config on Ubuntu 12.04, then the sound worked. That is great it works on Ubuntu, so now I just need to get it to work on Tinycore 12.0 (32bit)
The reason for testing using Ubuntu is so I can rule out the card or speakers as being the problem.

I ran alsamixer to make sure that nothing was muted.

I have attached the results of dmesg and amixer.

I kind of figure that since I added snd-hda-intel to file alsa-base.conf on Ubuntu, There should be a similar process for Tinycore , I'm just not sure how to do that especially since there is no alsa-base.conf file in Tinycore.

On Ubuntu I modified alsa-base.conf
Code: [Select]
sudo gedit /etc/modprobe.d/alsa-base.conf
made following entry at end of file
Code: [Select]
options snd-hda-intel model=generic

On Tinycore:

I'm Loading the following Modules which are in my onboot.lst
Code: [Select]
Xversa.tcz
aterm.tcz
wbar.tcz
alsa-config.tcz
alsa.tcz
open-ssh.tcz
busybox-httpd.tcz
sqlite3-bin.tcz

Results from: lsmod -l
Code: [Select]
Module                  Size  Used by    Not tainted
snd_hda_codec_realtek    73728  1
snd_hda_codec_generic    45056  1 snd_hda_codec_realtek
snd_hda_intel          24576  0
snd_hda_codec          57344  3 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel
cpufreq_userspace      12288  0
cpufreq_conservative    12288  0
cpufreq_powersave      12288  0
snd_hda_core           36864  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec
snd_hwdep              12288  1 snd_hda_codec
snd_pcm                53248  3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              20480  1 snd_pcm
snd                    36864  7 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore              12288  1 snd
snd_intel_dspcfg       12288  1 snd_hda_intel
squashfs               24576 38
igb                   122880  0
ptp                    16384  1 igb
serio_raw              12288  0
pcspkr                 12288  0
pps_core               12288  1 ptp
ac                     12288  0
r6040                  16384  0
loop                   20480 76

Results from aplay -l
Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC888-VD Analog [ALC888-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC888-VD Digital [ALC888-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Results from: speaker-test -Ddefault:0 -c2 -t wav -l1
Code: [Select]
speaker-test 1.2.1
Playback device is default:0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV files
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
 0 - Front Left
 1 - Front Right
Time per period = 2.855890
« Last Edit: September 22, 2021, 04:13:45 PM by gharig »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9587
Re: ALSA Sound ACL888-VD
« Reply #1 on: September 22, 2021, 06:07:34 PM »
Hi gharig
Try following these instructions:
http://forum.tinycorelinux.net/index.php/topic,22145.msg138620.html#msg138620
The order that the extensions are installed in is important (steps 1 - 3).

Based on your  lsmod  and  aplay  commands it appears your hardware is being recognized.

Offline gharig

  • Newbie
  • *
  • Posts: 13
Re: ALSA Sound ACL888-VD
« Reply #2 on: September 22, 2021, 08:41:56 PM »
Hi Rich,

I did see those instruction earlier, and basically did follow them. What I came across is someone talking about auto-mute [enabled or disabled]  in the alsamixer program.  I set auto-mute disabled and everything started working.
So to recap:
I loaded
Code: [Select]
alsa-config.tcz
alsa.tcz

I then opened alsamixer made sure master was not muted and the volume level was set to about 81% and then scrolled all the way over to auto-mute and set it to disabled.
Code: [Select]
$>alsamixer
Then followed the rest of the instructions to save the setting
Code: [Select]
$>sudo alsactl store
Made sure the setting are restored on reboot or startup
Code: [Select]
$>echo alsactl restore >> /opt/bootlocal.sh

Made sure that the settings are persistent
Code: [Select]
$>echo usr/local/etc/alsa/asound.state >> /opt/.filetool.lst

Backup everything
Code: [Select]
$>filetool.sh -b

Finally, Thank you for your help
I still think you are a True Genius

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9587
Re: ALSA Sound ACL888-VD
« Reply #3 on: September 22, 2021, 08:56:27 PM »
Hi gharig
I wasn't aware of the  Auto-Mute  setting. I just checked my system  and  Auto-Mute  is enabled and my audio works.
I have  PCM  and  Line Out  both set to 100.  Master is set to 67. You want the audio sources set to the highest
setting that is practical and use the master to bring the audio volume back down to desired level. That will give you
the best signal to noise ratio.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 9587
Re: ALSA Sound ACL888-VD
« Reply #4 on: September 22, 2021, 09:53:25 PM »
Hi gharig
I wasn't aware of the  Auto-Mute  setting. ...
I also wasn't aware of the purpose of the  Auto-Mute  setting, until I ask Google. Do you have headphones plugged in?
With  Auto-Mute  enabled, your speakers get muted if you plug in headphones.