WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TinyCore12.0-64 update  (Read 1149 times)

Offline chattrhand

  • Full Member
  • ***
  • Posts: 131
TinyCore12.0-64 update
« on: April 28, 2021, 12:46:34 PM »
hello TinyCoreTeam,

My TinyCore12.0-64 SurfStick installation was created Mar 28 2021 and contains  alsa, fluff, vlc, firefox with  firefox_getLatest, libreoffice and with your friendly help a german keyboard with  /etc/X11/xorg.conf.d/de_keyboard.conf, all working fine.

Meanwhile the AppsBrowser shows a list of 20 extensions that should have an update. So I did a  $ sudo cp -a  to have a pre-update and a post-update version of  my surf installation.

The post-update version scrolls a huge list over the screen while coming up, but then it works. The first of this lines I note here, the other ones look alike, they contain some hints to find the problem, hopefully.

udevd[6639]: failed to execute '/lib/udev/libinput-device-group' 'libinput-device-group /sys/devices/LNXSYSTM:00LNXPWRBN:00/input/input2/event2': No such file or directory

The pre-update version shows no such scroll list and the files and directories that were missing above are present here.

Is ist possible that the updated version did not insert these links?

Greetings!
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13807
Re: TinyCore12.0-64 update
« Reply #1 on: April 29, 2021, 01:54:46 AM »
Hmm - not sure what happened there.

libinput reposted with libinput-device-group location adjusted.

Offline chattrhand

  • Full Member
  • ***
  • Posts: 131
Re: TinyCore12.0-64 update
« Reply #2 on: April 29, 2021, 04:05:26 PM »
Hi TinyCore Team,

perhaps I've found the mistake:

To prepare a booting  TinyCore-12-64bit  installation I started a  tce12.0-32-installation and used its  tc-install  to prepare a new USB-Stick.

So I had to select one of the 32bit-installations of the first stick. By this selection the 32bit-extensions of this stick were copied to the   /tce/optional/  directory of the new 64 bit installation.

This is no problem as they are not too big. The 64bit kernel should not use them. So I downloaded and installed all of the 64bit extensions I needed.

When I wanted to update the 64bit installation the AppsBrowser also listed the 32bit extensions as "not upgradeable".
I removed them with the AppsBrowser menu and updated the 64bit-extensions as usual.

This was the mistake. Now at boot the kernel tries to install them and scrolls a huge number of trials over the screen, but doesn't find them. At the end it works without these extensions, but the booting takes too much time.

I repeated the installation leaving the unneeded 32bit extensions in their place and now it boots without problems.

Greetings


TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline thane

  • Hero Member
  • *****
  • Posts: 669
Re: TinyCore12.0-64 update
« Reply #3 on: April 29, 2021, 11:03:41 PM »
The change to libinput appears to have eliminated a bunch of error messages I was getting when booting TC 12.0. I didn't post about it because I'm running TC on ancient hardware and the "errors" didn't seem to be causing any problems. Thanks!