WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: UEFI on Intel ATOM SoC, persistence problem  (Read 150 times)

Offline MapHtH

  • Newbie
  • *
  • Posts: 36
UEFI on Intel ATOM SoC, persistence problem
« on: January 12, 2021, 05:22:42 AM »
Hi guys,

I'm having problems setting up a TC persistent install on Minix Neo Z64-w10. I've managed to create a EFI FAT32 bootable partition with grub which loads the kernel and core, but i'm having problems with persistence.

I don't want a frugal install, but intend to use it like a USB-HDD (worked well with CMS BIOS in past without problems).

I've set up the grub to load it like this:
Code: [Select]
menuentry "tc" {
  linux /boot/vmlinuz64 loglevel=3 cde vga=791 video=vesafb:ywrap,mtrr:3 cron noutc nozswap tce=mmcblk1p2 restore=mmcblk1p2 home=mmcblk1p2 opt=mmcblk1p2
  initrd /boot/corepure64.gz
}

but it allways says that:
Invalid device specified. Ignoring persistant HOME request !
Invalid device specified. Skipping persistant OPT request !

When I try looking at the partition I can see that mmcblk1p2 is not mounted when it should be.

Any ideas?

Offline jazzbiker

  • Sr. Member
  • ****
  • Posts: 446
Re: UEFI on Intel ATOM SoC, persistence problem
« Reply #1 on: January 12, 2021, 05:59:04 AM »
Hi, MapHtH!

I think "cde" bootcode is unnecessary.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8653
Re: UEFI on Intel ATOM SoC, persistence problem
« Reply #2 on: January 12, 2021, 07:14:35 AM »
Hi MapHtH
You definitely want to get rid of that  cde  boot code.
The  restore=  boot code is unnecessary. It will default to the same location as the  tce  directory.

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 478
Re: UEFI on Intel ATOM SoC, persistence problem
« Reply #3 on: January 17, 2021, 08:43:26 AM »
You better use UUID instead

To do that, type this in your terminal
Code: [Select]
echo tce=$(blkid -s UUID /dev/mmcblk0p2 | cut -d ' ' -f 2)

Replace "tce=mmcblk1p2" with the output