WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Boot error message  (Read 2350 times)

tinycorelinux

  • Guest
Boot error message
« on: November 23, 2020, 04:44:10 AM »
Every time the system starts up, the following error messages will be displayed, and these error messages will be automatically entered as the login information, so the first login will almost always fail. Is there a way to eliminate these misinformation?
Code: [Select]
# This message will be displayed at least five times each time
udevd[180]: unknown key 'RUN{program}' in /etc/udev/rules.d/73-seat-late.rules: 17

# This message will be displayed at least two times each time
[drm: 0xffffffffa0249888] *ERROR* CPU pipe A FIFO underrun

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: Boot error message
« Reply #1 on: November 23, 2020, 09:44:39 AM »
Hi ONE
Try the following:
Code: [Select]
mkdir elog
cd elog
# Download the file attached to this post into this directory
chmod 644 73-seat-late.rules
chown tc:staff 73-seat-late.rules
cp /etc/sysconfig/tcedir/optional/elogind.tcz .
tce-load -wil squashfs-tools.tcz
unsquashfs -d elogind elogind.tcz
rm elogind.tcz
cp 73-seat-late.rules elogind/usr/local/share/elogind/files/
mksquashfs elogind elogind.tcz
cp elogind.tcz /etc/sysconfig/tcedir/optional/

Reboot and see if the  unknown key  messages are gone.

Rational:
The old linux die manual shows no option for RUN:
Quote
RUN
    Add a program to the list of programs to be executed for a specific device. This can only be used for very short running tasks. Running an event process for a long period of time may block all further events for this or a dependent device. Long running tasks need to be immediately detached from the event process itself. If the option RUN{fail_event_on_error} is specified, and the executed program returns non-zero, the event will be marked as failed for a possible later handling.
The  fail_event_on_error  option was removed in version 174 (our current version).
Found here:
https://linux.die.net/man/7/udev

The documentation at freedesktop states:
Quote
RUN{type}

    Specify a program to be executed after processing of all the rules for the event. With "+=", this invocation is added to the list, and with "=" or ":=", it replaces any previous contents of the list. Please note that both "program" and "builtin" types described below use a single list, so clearing the list with ":=" and "=" affects both types.

    type may be:

    "program"

        Execute an external program specified as the assigned value. If no absolute path is given, the program is expected to live in /usr/lib/udev; otherwise, the absolute path must be specified.

        This is the default if no type is specified.
    "builtin"

        As program, but use one of the built-in programs rather than an external one.
Found here:
https://www.freedesktop.org/software/systemd/man/udev.html#RUN%7Btype%7D

Since one doesn't use it, and the other defaults to it, removing  {program}  from the command should be safe.

tinycorelinux

  • Guest
Re: Boot error message
« Reply #2 on: November 23, 2020, 10:28:00 PM »
Hmm. The first problem was solved after I directly deleted the 'RUN{program}' code from the file as you said.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: Boot error message
« Reply #3 on: November 23, 2020, 10:46:35 PM »
Hi ONE
Since you didn't use the attachment I provided, I don't know what you did. It sounds like you removed the entire  RUN
command. That is not what I said. I said remove  {program}.
That meant change this:
Code: [Select]
TAG=="uaccess", ENV{MAJOR}!="", RUN{program}+="/usr/local/lib/elogind/elogind-uaccess-command %N $env{ID_SEAT}"to this:
Code: [Select]
TAG=="uaccess", ENV{MAJOR}!="", RUN+="/usr/local/lib/elogind/elogind-uaccess-command %N $env{ID_SEAT}"

tinycorelinux

  • Guest
Re: Boot error message
« Reply #4 on: November 24, 2020, 02:46:26 AM »
Hi ONE
Since you didn't use the attachment I provided
Sorry, My eyes are not good. I didn't see the attachment you provided at first. When you mentioned it again, I only saw it with great effort.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: Boot error message
« Reply #5 on: November 25, 2020, 06:41:21 AM »
Hi ONE
I updated the extension with the fix. To update your extensions:
Code: [Select]
tce-audit builddb
tce-audit updatedeps
tce-audit fetchmissing
tce-update
Then click the  Exit  icon and select reboot.

tinycorelinux

  • Guest
Re: Boot error message
« Reply #6 on: November 26, 2020, 04:13:47 AM »
Hi ONE
I updated the extension with the fix. To update your extensions:
Code: [Select]
tce-audit builddb
tce-audit updatedeps
tce-audit fetchmissing
tce-update
Then click the  Exit  icon and select reboot.
Thanks you, Rich!