WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Chromium or Chromium based browser issues  (Read 595 times)

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Chromium or Chromium based browser issues
« on: November 22, 2020, 02:19:39 AM »
I found that neither Chromium-Browser nor chromium-based browsers could enable hardware acceleration mode, and there were a lot of error messages on the terminal.
I haven't found this problem with Firefox yet (maybe I just don't know), but I just don't like using Firefox.
Code: [Select]
[12026:12026:1122/102351.873626:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
Fontconfig error: Cannot load default config file: No such file: (null)
[12026:12042:1122/102351.975736:ERROR:bus.cc(393)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
[12055:12055:1122/102352.127785:ERROR:angle_platform_impl.cc(43)] Display.cpp:805 (initialize): ANGLE Display::initialize error 12289: GLX is not present.
[12055:12055:1122/102352.127972:ERROR:gl_surface_egl.cc(773)] EGL Driver message (Critical) eglInitialize: GLX is not present.
[12055:12055:1122/102352.128029:ERROR:gl_surface_egl.cc(1322)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED, trying next display type
[12055:12055:1122/102352.128152:ERROR:angle_platform_impl.cc(43)] Display.cpp:805 (initialize): ANGLE Display::initialize error 12289: GLX is not present.
[12055:12055:1122/102352.128240:ERROR:gl_surface_egl.cc(773)] EGL Driver message (Critical) eglInitialize: GLX is not present.
[12055:12055:1122/102352.128295:ERROR:gl_surface_egl.cc(1322)] eglInitialize OpenGLES failed with error EGL_NOT_INITIALIZED
[12055:12055:1122/102352.128348:ERROR:gl_initializer_linux_x11.cc(160)] GLSurfaceEGL::InitializeOneOff failed.
[12055:12055:1122/102352.143616:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization
...... ......

The following error message is repeated throughout the browser. What's wrong with it? I merged the duplicate information
Code: [Select]
[13685:13778:1122/103337.926470:ERROR:bus.cc(393)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
[13721:13735:1122/103400.039014:ERROR:ssl_client_socket_impl.cc(960)] handshake failed; returned -1, SSL error code 1, net_error -101
(xxx:13685): Gdk-WARNING **: 10:34:03.112: gdk_window_set_user_time called on non-toplevel
...... ......
« Last Edit: November 22, 2020, 02:39:09 AM by ONE »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12644
Re: Chromium or Chromium based browser issues
« Reply #1 on: November 22, 2020, 03:39:57 AM »
Code: [Select]
[12026:12026:1122/102351.873626:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected). You could symlink /etc/machine-id -> /var/lib/dbus/machine-id

Code: [Select]
Fontconfig error: Cannot load default config file: No such file: (null) Is there a symlink present such that /etc/fonts -> /usr/local/etc/fonts?

Code: [Select]
Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory This indicates that the dbus daemon has not been started.

Code: [Select]
[12055:12055:1122/102352.128029:ERROR:gl_surface_egl.cc(1322)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED, trying next display type
Is graphics-KERNEL loaded and Xorg-7.7-3d running?

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #2 on: November 22, 2020, 05:07:54 AM »
Is graphics-KERNEL loaded and Xorg-7.7-3d running?
Yes. but now, as soon as hardware acceleration is enabled, the browser will have a flat screen, nothing to see, and nothing to use.


Offline vinceASPECT

  • Sr. Member
  • ****
  • Posts: 446
Re: Chromium or Chromium based browser issues
« Reply #3 on: November 22, 2020, 05:21:50 AM »
Hello,

Does that simply mean they are ineffectively functioning..?...Iridium and such like on Tcl 64?
(they are not correctly using the hardware?)

i did ask about graphics hardware earlier (Tcl drivers and why Xorg etc) but there hasn't been any reply.....(it was regarding Radeon or Intel drivers)

dam

v

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #4 on: November 22, 2020, 05:28:24 AM »
(they are not correctly using the hardware?)
There should be no problem with my hardware and driver, but the browser's GPU acceleration function is not normal.

Quote
i did ask about graphics hardware earlier (Tcl drivers and why Xorg etc) but there hasn't been any reply.....(it was regarding Radeon or Intel drivers)
Have you solved your problem now?

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #5 on: November 22, 2020, 06:26:33 AM »
After a few attempts to debug the browser, the display still seems to be a problem.
« Last Edit: November 22, 2020, 06:28:38 AM by ONE »

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #6 on: November 22, 2020, 06:45:07 AM »
This indicates that the dbus daemon has not been started.

It seems that dbus still cannot be started.
Code: [Select]
cd /usr/local/chromium-browser/chrome
dbus-run-session ./chrome

Code: [Select]
[19254:19270:1122/144934.533238:ERROR:bus.cc(393)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
[19254:19290:1122/144934.739940:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
(chrome:19254): Gdk-WARNING **: 14:49:36.896: gdk_window_set_user_time called on non-toplevel
[19285:19300:1122/145015.376721:ERROR:ssl_client_socket_impl.cc(960)] handshake failed; returned -1, SSL error code 1, net_error -101
« Last Edit: November 22, 2020, 06:51:43 AM by ONE »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12644
Re: Chromium or Chromium based browser issues
« Reply #7 on: November 22, 2020, 07:01:21 AM »
Boot to a console prompt and then:
Code: [Select]
$ tce-load -i graphics-KERNEL Xorg-7.7-3d alsa-config flwm aterm wbar
$ sudo /usr/local/etc/init.d/dbus start
$ sudo ln -s /var/lib/dbus/machine-id /etc/machine-id
$ sudo ln -s /usr/local/etc/fonts /etc/fonts
$ sudo ln -s /usr/local/etc/ssl /etc/ssl
$ startx

..and then try the browser.

Offline vinceASPECT

  • Sr. Member
  • ****
  • Posts: 446
Re: Chromium or Chromium based browser issues
« Reply #8 on: November 22, 2020, 07:38:08 AM »
ONE,

well my forum question about graphics drives on  tcl was not so much of a problem....but i just wondered how your hardware knows that's it's got the best TCL drivers from the repo for it.

there are lots of repo files concerning graphics frimware and drivers......radeon and intel and   vulkan and wayland and weston....never mind frame buffer which is what TCL  64 uses by default.

i realize that a user loads Xorg  for 3d performance and accelerations in graphics etc..........should a user LOAD IT or not?....... and does tcl know to also grab the specific Intel drivers it lists for my chip ontop of Xorg drivers?

thx

vin...

i imagine some of this stuff above may pertain to that Chromium GPU issue you mention....i would likely also suffer that issue too...... and so will all users
« Last Edit: November 24, 2020, 08:22:26 AM by Rich »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12644
Re: Chromium or Chromium based browser issues
« Reply #9 on: November 22, 2020, 08:00:59 AM »
I get this:
Code: [Select]
$ dbus-run-session chromium-browser
Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown element "its:rules"
...
[30175:30219:1122/195830.919703:ERROR:object_proxy.cc(626)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
[30225:30225:1122/195830.999801:ERROR:sandbox_linux.cc(375)] InitializeSandbox() called with multiple threads in process gpu-process

..but the browser works as expected.

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #10 on: November 22, 2020, 08:27:01 AM »
how your hardware knows that's it's got the best TCL drivers from the repo for it.
First of all, the hardware itself does not have the ability to automatically get the drivers from the repo.
Most of the drivers in addition to the built-in drivers of the kernel, you need to get them yourself.
The repository only provides common drivers (usually from hardware vendors), and some closed-source drivers require you to download them from a third party and then compile them yourself.Of course there are some newer hardware or older hardware that Linux generally doesn't support, so you'll have to figure it out yourself.

Quote
should a user LOAD IT or not?....... and does tcl know to also grab the specific Intel drivers it lists for my chip ontop of Xorg drivers?
It depends on your needs.
« Last Edit: November 22, 2020, 08:37:54 AM by ONE »

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #11 on: November 22, 2020, 08:41:45 AM »
..but the browser works as expected.
Ok, I'll try again tomorrow.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12644
Re: Chromium or Chromium based browser issues
« Reply #12 on: November 22, 2020, 08:45:10 AM »
..and does tcl know to also grab the specific Intel drivers it lists for my chip ontop of Xorg drivers?

What specific intel drivers are you speaking of?

Offline vinceASPECT

  • Sr. Member
  • ****
  • Posts: 446
Re: Chromium or Chromium based browser issues
« Reply #13 on: November 22, 2020, 10:11:36 AM »
juanto,

the specific drivers are radeon based ones in the repo and they cover the model issue number of my graphics chip ....

(1)firmware-radeon.tcz
(2)firmware-video.tcz  (what is that & how?)
(3)firmware-amdgpu.tcz  (what is that & how?)
(4)firmware-amd-ucode.tcz  (what is that and how?)
(5)xf86-video-amdgpu.tcz (what is that and how?)

i think the description page about (1) above mentions chip models which match my graphics chip model number

i think i tried loading  (1) above after Xorg was loaded....... but the screen went black and the os crashed.

thx

V

Amd Radeon hd 7570M graphics...........THAMES PRO edition chip...... 
 
(As in the river "Thames" London UK........... where the chip may have been co-developed .........along with Santa Clara's Amd)
« Last Edit: November 24, 2020, 08:23:08 AM by Rich »

Offline ONE

  • Jr. Member
  • **
  • Posts: 89
Re: Chromium or Chromium based browser issues
« Reply #14 on: November 22, 2020, 06:29:36 PM »
..and then try the browser.

Code: [Select]
[11573:11611:1123/022500.550408:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[11604:11604:1123/022500.632294:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[11573:11665:1123/022500.808031:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files

(chrome:11573): Gdk-WARNING **: 02:25:07.933: gdk_window_set_user_time called on non-toplevel

[11608:11615:1123/022511.409364:ERROR:ssl_client_socket_impl.cc(960)] handshake failed; returned -1, SSL error code 1, net_error -101