WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Error in link to linux source kernel used for Raspberry Pi V12.0  (Read 420 times)

Offline xsquared

  • Newbie
  • *
  • Posts: 4
Error in link to linux source kernel used for Raspberry Pi V12.0
« on: November 04, 2020, 12:20:20 PM »
I just upgraded to TC v12.0 for my Raspberry Pi project and noticed what I assumed to be a typo on the website. In the src directory for the kernel - newbielink:http://tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/ [nonactive] - all the version numbers are 5.4.51 except the linux source, which is labelled linux-5.4.41-piCore.tar.xz.

I downloaded and uncompressed the linux source and the Makefile says it is 5.4.51, so I assumed that the label was incorrect and renamed my directory accordingly.

However, when I build some extra kernel modules I needed, they built fine, but I got the dreaded "can't load module - invalid module format" from modprobe. Could it be that this isn't the kernel source that the 5.4.51-piCore-v7l kernel was built against?

Please help. Thanks.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #1 on: November 04, 2020, 12:47:34 PM »
Hi xsquared
If the kernel modules you want aren't in any of the  *-modules-5.4.51-piCore.tcz  extensions listed here:
http://tinycorelinux.net/12.x/armv6/tcz
They may be in  modules-5.4.51-piCore.tar.xz  also located at:
http://tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/

You'll have to wait for Juanito or Paul_123 to see what the issue with the numbering discrepancy is.

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 661
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #2 on: November 04, 2020, 01:13:21 PM »
The kernel source is identical in all versions (v6,v7,v7l,v8).  The difference is the configs used.

If you are trying to compile new modules that were originally not built, you will need 3 files

.config
System.map
Module.symvers

They are located in the same directories as the kernel source.
http://www.tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/
http://www.tinycorelinux.net/12.x/armv7/releases/RPi/src/kernel/
http://www.tinycorelinux.net/12.x/aarch64/releases/RPi/src/kernel/


But likely you want a module that was built, just not part of any extension.  Those are in the module tar files that Rich pointed you to.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #3 on: November 04, 2020, 01:31:05 PM »
Hi Paul_123
The kernel source version is labeled  5.4.41-piCore.
The other files have their version labeled as  5.4.51-piCore:
http://tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/

Offline xsquared

  • Newbie
  • *
  • Posts: 4
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #4 on: November 04, 2020, 01:48:17 PM »
Thank-you Rich and Paul for your swift replies.

Ah! My issue was that I wasn't using the correct config, so I should've been using the v7 for my RPi board. And, interestingly, in that directory, the linux source file was named with the correct kernel version, so I think it was just a typo in the v6.

:)

NB: The drivers I was seeking are to get 3D acceleration working on x windows. I don't see an extension for that, but I do see the drivers in the modules-5.4.51-piCore.tar.xz, so I can use those. I got this working on TC 11.0 and it saves a lot of processing for CPU if you're doing much OpenGL stuff. If there's interest for this, I could wrap my work into an extension - basically ko files and a couple of config files.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #5 on: November 04, 2020, 02:02:42 PM »
Hi xsquared
Extension submissions are always welcome. There is a Wiki which should provide some useful information:
https://www.linuxsecrets.com/tinycorelinux-wiki/wiki:creating_extensions.html

The instructions for emailing the extension are here:
https://www.linuxsecrets.com/tinycorelinux-wiki/wiki:creating_extensions.html#submitting

Use the  tcesubmit  email address, not the  picoresubmit  address.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #6 on: November 04, 2020, 02:11:12 PM »
Hi xsquared
... I should've been using the v7 for my RPi board. And, interestingly, in that directory, the linux source file was named with the correct kernel version, so I think it was just a typo in the v6. ...
Really? ??? I see  linux-5.4.41-piCore.tar.xz  listed in all 3 releases:
http://tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/
http://tinycorelinux.net/12.x/armv7/releases/RPi/src/kernel/
http://tinycorelinux.net/12.x/aarch64/releases/RPi/src/kernel/

Offline xsquared

  • Newbie
  • *
  • Posts: 4
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #7 on: November 04, 2020, 03:28:06 PM »
Sorry Rich, it's getting late, yep, they all appear to be .41

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #8 on: November 04, 2020, 07:18:00 PM »
Hi xsquared
No worries. ;D

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12628
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #9 on: November 05, 2020, 12:59:04 AM »
NB: The drivers I was seeking are to get 3D acceleration working on x windows. I don't see an extension for that, but I do see the drivers in the modules-5.4.51-piCore.tar.xz, so I can use those.

The piCore-12.x 3d graphics acceleration is working with the graphics-KERNEL and Xorg-3d extensions.

Offline xsquared

  • Newbie
  • *
  • Posts: 4
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #10 on: November 05, 2020, 04:03:12 AM »
Thanks Juanito, that's exactly what I need. Dang, that would've saved me a few hours :o I'll have to get more familiar with the TC extensions repository.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #11 on: November 05, 2020, 05:53:32 AM »
Hi xsquared
If you have a GUI, click on the  Apps  icon. Then  Apps->Cloud (Remote)->Browse.  Then click on the  Search  dropdown
and change it to  Provides.  Enter what you are looking for in the the textbox to the right (i.e. drm.ko).

If you don't have a GUI, enter  tce-ab  at the command line.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8393
Re: Error in link to linux source kernel used for Raspberry Pi V12.0
« Reply #12 on: November 07, 2020, 05:50:43 AM »
Hi Juanito
Hi xsquared
... I should've been using the v7 for my RPi board. And, interestingly, in that directory, the linux source file was named with the correct kernel version, so I think it was just a typo in the v6. ...
Really? ??? I see  linux-5.4.41-piCore.tar.xz  listed in all 3 releases:
http://tinycorelinux.net/12.x/armv6/releases/RPi/src/kernel/
http://tinycorelinux.net/12.x/armv7/releases/RPi/src/kernel/
http://tinycorelinux.net/12.x/aarch64/releases/RPi/src/kernel/
I checked the version number inside of  linux-5.4.41-piCore.tar.xz  and it is  5.4.51  as it should be.
All 3 locations have been renamed to reflect the correct version number.