WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: abiword configure: error: No package 'glib-2.0' found.  (Read 5614 times)

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
abiword configure: error: No package 'glib-2.0' found.
« on: December 15, 2008, 03:02:47 AM »
Trying to compile abiword2.6.5
Quote
configure: error: No package 'glib-2.0' found.
Our pacakge is
glib2 and glib2-dev. I think "-" problem.

What to do?

kagashe

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12404
Re: abiword configure: error: No package 'glib-2.0' found.
« Reply #1 on: December 15, 2008, 03:13:20 AM »
did you use:
Code: [Select]
$ export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfigthe name of the extension - glib2, glib-2, etc is irrelevant, the libs inside will be placed in /usr/local/lib irrespective of the name

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: abiword configure: error: No package 'glib-2.0' found.
« Reply #2 on: December 15, 2008, 03:29:56 AM »
did you use:
Code: [Select]
$ export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfigthe name of the extension - glib2, glib-2, etc is irrelevant, the libs inside will be placed in /usr/local/lib irrespective of the name
Ok. That was the problem. Now it is going further and asking for libgnomeprint and libgnomeprintui although the system requirements on Abiword site states GNOME as optional.

kagashe

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12404
Re: abiword configure: error: No package 'glib-2.0' found.
« Reply #3 on: December 15, 2008, 03:37:08 AM »
if you try
Code: [Select]
$ ./configure --helpyou'll get a whole bunch of details that might suggest --without-libgnomeprint or --disable-libgnomeprint or similar

note that if this turns up too much detail to fit in the scroll buffer you can use:
Code: [Select]
$ ./configure --help > help_details
$ beaver help_details &

you could also look in the README, INSTALL or similar files for clues

if you didn't look already http://www.linuxfromscratch.org/blfs/view/stable/xsoft/AbiWord.html might be helpful
« Last Edit: December 15, 2008, 04:24:02 AM by Juanito »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10273
Re: abiword configure: error: No package 'glib-2.0' found.
« Reply #4 on: December 15, 2008, 09:05:53 AM »
From 2.2 onwards Abiword requires Gnomeprint and -ui to do any printing. If you don't want those, use --disable-printing (I guess that was the switch)
The only barriers that can stop you are the ones you create yourself.