WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: request qt-devel libs  (Read 1453 times)

Offline lovelypp

  • Newbie
  • *
  • Posts: 41
request qt-devel libs
« on: September 26, 2020, 07:17:58 AM »
i want to develop a qt app on raspberry on piCore. can it support , thanks!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14083
Re: request qt-devel libs
« Reply #1 on: September 26, 2020, 07:21:33 AM »
You would have to build qt first...

Offline lovelypp

  • Newbie
  • *
  • Posts: 41
Re: request qt-devel libs
« Reply #2 on: September 26, 2020, 07:34:50 AM »
there maybe a lot of work to do to support running qt gui app. I don't know if anyone has succeeded tried it.
I see there are qt stuffs on x86 release of tinylinux.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14083
Re: request qt-devel libs
« Reply #3 on: September 26, 2020, 07:40:44 AM »
qt is large and bloated and thus not really suited to tinycore, never mind piCore - this being said, it probably can be built for piCore.

piCore has gtk3 - is there an equivalent to your qt app that runs on gtk3?

Offline lovelypp

  • Newbie
  • *
  • Posts: 41
Re: request qt-devel libs
« Reply #4 on: September 26, 2020, 05:42:25 PM »
Juanito  I need to port my app runs on CentOs before which use qt, boost, log4cplus and zeromq

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14083
Re: request qt-devel libs
« Reply #5 on: September 27, 2020, 02:17:44 AM »
A boost extension exists for piCore-11.x, but you'll need to compile the others.

Offline lovelypp

  • Newbie
  • *
  • Posts: 41
Re: request qt-devel libs
« Reply #6 on: September 29, 2020, 06:50:10 PM »
failed when compile log4cplus, because the gcc toolset does not support c++11.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10418
Re: request qt-devel libs
« Reply #7 on: September 29, 2020, 08:09:00 PM »
Hi lovelypp
Did you try adding this to CXXFLAGS:
Code: [Select]
-std=c++11