WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Ejecting the boot CD  (Read 64 times)

Offline clauder

  • Newbie
  • *
  • Posts: 11
Ejecting the boot CD
« on: September 16, 2020, 06:37:30 AM »
I did search the archive and found topics related to my problem but that did not solved it...

Basically, I am trying to eject the boot CD but I get the `eject: /dev/cdrom: Input/Output error ` message...

My setup
Virtualbox with a remastered CD image

Initially I was suspecting Virtualbox but booting with Arch Linux (on a local virtual disk) I can eject the Tiny Core CD.

The image is remastered and I added extension, but the extensions are installed before burning the CD image. In any case, the CD is not mounted and there is no loop device mounted either. See mount output

rootfs on / type rootfs (rw,size=3642396k,nr_inodes=1280976)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda1 on /tmp/rootfs type ext4 (rw,relatime)
/dev/sda2 on /tmp/data type ext4 (rw,relatime)

The /dev/cdrom link is present and points to /dev/sr0 - I also try `eject /dev/sr0` with same result.

I unmounted /sys/fs/fuse/connections but same result.

I am running out of ideas....Any suggestion?