WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [rough wiki] xmms RPi using headphones  (Read 81 times)

aus9

  • Guest
[rough wiki] xmms RPi using headphones
« on: August 31, 2020, 10:04:35 PM »
This is an attempt to document some steps I took to setup my RPi to play mp3 thru headphone socket.

Step 1 load sufficient TCEs to give you a chance to pass the speaker-test thru headphones
Code: [Select]
tce-load -i alsa alsa-utils
# EITHER
speaker-test -D default:Headphones
speaker-test -D hw:1,0
alsamixer -c1

alsamixer may already show a high volume setting YMMV.

Optional add TCEs to your boot list.

Step 2 Start xmms, it defaults like most players, to play the default device which will be HDMI.

Step 3 Click the little sand clock symbol top left hand corner of player -> Options -> Preferences  (or keyboard combo Ctrl + p)

First TAB is for input output....click libmpg123.so and ensure the button for Enable plugin is depressed
They may already be depressed for all plugins ...YMMV
Now pulldown the Output plugin and choose Alsa......default was OSS
Click the configure button below output ->

Ensure the Mixer "Use software volume control" is NOT depressed then
Pulldown Mixer card and select Headphones instead of HDMI
The mixer device will change to Headphone.

Now go to pulldown for Audio Device. It is difficult to see the full wording of choices so if you are in FVWM.....hold down Ctrl + Alt + m to maximise the opened window
Now you can see you need the bottom option for headphone......hw:1,0
After selection it only shows hw:1,0.
Click Ok
and then click apply

Because I prefer not to load and setup pulseaudio, I then allow Mixer to use software volume control

test your mp3s

Good Luck

« Last Edit: August 31, 2020, 10:09:23 PM by aus9 »