WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-12.0alpha1  (Read 1552 times)

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #30 on: August 31, 2020, 05:04:46 PM »
some minor feedback for arm7l not aarch64.

1) I use a distro to flash the image using dd and that distro automounts freshly created or installed media.
It detects 2 partitions but thinks it should be called piCore11. As sdcards do look the same and I now have a few, I inserted aarch64 which says piCore64_12 and my original 11x says its piCore11.

2) Key generation is really fast, relative to 11x arm7
but I have to press the enter key to get a prompt, do we need an exit command?
I am still so new to this key gen stuff.....I am never too sure how long to wait but
Code: [Select]
filetool.sh -b
cat /opt/.filetool.lst
# shows 8 keys in backup which I think is right
trivia.....hold shift page up works. keg gen seems to use this order, not sure if the string change
rsa.......dsa......ecdsa......ed<string>

3) using ssh commands
Code: [Select]
tce-load -w  -i Xorg Xlibs flwm aterm wbar nano
cat /mnt/mmcblk0p2/tce/onboot.lst
openssh.tcz
Xorg.tcz
flwm.tcz
aterm.tcz
wbar.tcz
nano.tcz

on RPi
Code: [Select]
startx  -> gives me a desktop
WOOHOO

oops forgot to expand p2
« Last Edit: August 31, 2020, 05:25:12 PM by aus9 »

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #31 on: August 31, 2020, 06:02:56 PM »
expanded parttiton2 complete, firefox working as I am typing on it ATM

If I open aterm, file:///home/tc/.Xdefaults looks correct. white foreground on black bg
If I run a download thru Apps, aterm opens but shows black foreground on black bg
any clues where to change?

2) I have only one RPi (a 4) first sound check is good
Code: [Select]
speaker-test -D default:Headphones
« Last Edit: August 31, 2020, 06:19:37 PM by aus9 »

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #32 on: September 01, 2020, 08:24:55 PM »
I am normally on ethernet but just tested wifi on arm7l, it works as I type with eth cable pulled.
I have wifi, so this is a casual remark in case the kernel can be tweaked?
Code: [Select]
dmesg | grep 509
[    0.000000] Memory: 3848180K/4050944K available (10240K kernel code, 725K rwdata, 2736K rodata, 2048K init, 851K bss, 137228K reserved, 65536K cma-reserved, 3264512K highmem)
[    1.194504] Asymmetric key parser 'x509' registered
[    1.487415] Loading compiled-in X.509 certificates
[   57.397279] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[   57.442509] WARNING: CPU: 2 PID: 2179 at crypto/rsa-pkcs1pad.c:539 pkcs1pad_verify+0x158/0x174
[   57.442630] [<c064306c>] (public_key_verify_signature) from [<c06448cc>] (x509_check_for_self_signed+0xcc/0x128)
[   57.442641] [<c0644800>] (x509_check_for_self_signed) from [<c0643cc0>] (x509_cert_parse+0x178/0x1c8)
[   57.442651] [<c0643b48>] (x509_cert_parse) from [<c064454c>] (x509_key_preparse+0x20/0x1a4)
[   57.442662] [<c064452c>] (x509_key_preparse) from [<c0641fac>] (asymmetric_key_preparse+0x60/0x90)
[   57.443101] cfg80211: Problem loading in-kernel X.509 certificate (-22)

A search of "problem loading etc" which may be completely irrelevant as its a diff distro suggests that a kernel had to change.
bug as reported = EFI: Problem loading in-kernel X.509 certificate
https://bugzilla.redhat.com/show_bug.cgi?id=1075966
That reporter ....reported as they wanted
Quote
Flawless/Clean boot with no warnings/errors
I don't see EFI but I do see Problem loading in-kernel X.509 certificate
so suggest it in case it helps a future kernel re-compile?

As I have a desktop, ca-certificates is loaded by recursive dep of  xorg-server
« Last Edit: September 01, 2020, 08:32:45 PM by aus9 »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8129
Re: piCore-12.0alpha1
« Reply #33 on: September 02, 2020, 07:53:36 AM »
Hi Paul_123
Emphasis mine:
... Also, from your above example.  this is not correct.
Code: [Select]
export CFLAGS="gcc -march=armv8-a+crc -mtune=cortex-a72 -Os -pipe"
export CXXFLAGS="g++ -march=armv8-a+crc -mtune=cortex-a72 -Os -pipe -fno-exceptions -fno-rtti"

CFLAGS should not include the compiler reference
Code: [Select]
export CFLAGS="-march=armv8-a+crc -mtune=cortex-a72 -Os -pipe"
export CXXFLAGS="-march=armv8-a+crc -mtune=cortex-a72 -Os -pipe -fno-exceptions -fno-rtti"
...

I can attest to the fact that including a compiler reference in the flags can cause problems. I recently ran into this problem (again)
while trying to run  configure  for a package from a build script. Running it from the command line it ran fine. That made it easy to
pinpoint the culprit in the build script.

I did notice this in the configure help:
Code: [Select]
tc@E310:~/BuildTCZs/Setxkbmap/setxkbmap$ ./configure --help
`configure' configures setxkbmap 1.3.2 to adapt to many kinds of systems.

 ----- Snip -----

Some influential environment variables:
  CC          C compiler command
  CFLAGS      C compiler flags
  LDFLAGS     linker flags, e.g. -L<lib dir> if you have libraries in a
              nonstandard directory <lib dir>
  LIBS        libraries to pass to the linker, e.g. -l<library>
  CPPFLAGS    (Objective) C/C++ preprocessor flags, e.g. -I<include dir> if
              you have headers in a nonstandard directory <include dir>
  CPP         C preprocessor

They list  CPPFLAGS  but not  CXXFLAGS , so I added this to my build script:
Code: [Select]
CPPFLAGS=$CXXFLAGS

Offline mortegai

  • Newbie
  • *
  • Posts: 2
Re: piCore-12.0alpha1
« Reply #34 on: September 03, 2020, 02:40:43 AM »
Missing bc for aarch64.
To recompile the kernel for aarch64 bc is needed, and the extension bc.tcz does not exist for that arch.
Please, could you create it?

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 617
Re: piCore-12.0alpha1
« Reply #35 on: September 03, 2020, 04:45:20 PM »
bc posted,   I hope you know that changing a kernel in piCore is far from a trivial task.

Offline mortegai

  • Newbie
  • *
  • Posts: 2
Re: piCore-12.0alpha1
« Reply #36 on: September 05, 2020, 06:15:57 AM »
bc posted,   I hope you know that changing a kernel in piCore is far from a trivial task.

Thank you. 
I know that the kernel modules are distributed among the various tcz extensions, but I only use the base and wireless modules.

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #37 on: September 05, 2020, 07:29:14 PM »
Hi

I am aware that this thread is mainly for TCB feedback. I just attempted to get into dropbox on firefox (Repo build) and it reports "there was a problem completing this request". I suspect after a search online it relates to our version of firefox.  Anyone able to login on 12x?

Its easy to evade. I just put the files onto a usb stick and transfer them on TC64 (or whatever you have)

thanks for reading

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #38 on: September 07, 2020, 09:10:45 PM »
@Juanito

You can safely ignore my 2 private messages. First one is still kind of correct that gtk2 is missing one cups backend file. But I am now on 32 bit and reading cups error log after rebuild of gtk2 on 12x and gutenprint
the error to print from leafpad a gtk2 app is filter failed.

error log shows
Quote
D [08/Sep/2020:03:49:52 +0000] [Job 3] /usr/local/bin/gs: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

so
Code: [Select]
strings /usr/local/bin/gs | grep libidn
libidn.so.11

trouble is with have libidn2 with /usr/local/lib/libidn2.so.0.3.7

I tried and failed to do a dirty sym link to see if I could print but can not. Its above my pay scale to recommend you or anyone else update these packages. So I will plod along and see if I can do a private build to resolve missing file.

thanks for reading and that may still not resolve all my issues.
« Last Edit: September 07, 2020, 09:12:53 PM by aus9 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12419
Re: piCore-12.0alpha1
« Reply #39 on: September 08, 2020, 12:14:36 AM »
You could try the libidn extension from piCore-9.x?

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #40 on: September 08, 2020, 12:43:32 AM »
did not see your reply to just now. I can report I am now printing on usb canon. Ink for Epson dried up but reported job complete. As I am pensioner, I am binning the Epson as it was a basic printer to begin with and its actually cheaper to buy a new printer than buy refills.

ON 32 bit Not sure if I needed to but re-compiled gtk2 and gutenprint and then re-compiled ghostscript without recompiling anything else, altho I can see cups-filters might get my attention.
Code: [Select]
strings /usr/local/bin/gs | grep libidn
tc@box:~/Downloads$

If you would like to re-compile ghostscript, I used

SRC=ghostscript-9.52
compiletc wget squashfs-tools zsync xz cups-dev cairo-dev libjpeg-turbo-dev lcms2-dev libXt-dev
# libXt-dev not detected until make
cd $SRC
rm -rf expat freetype lcms2mt jpeg libpng
./configure --prefix=/usr/local --with-system-libtiff --localstatedir=/var --enable-dynamic --disable-compile-inits
make -j5 takes 3.5 minutes

dep list modest change to remove libtiff as we are using GS
libcups.tcz
lcms2.tcz
fontconfig.tcz
libpng.tcz

If you do not have time, depending on your priorities, would you like me to submit a TCE
I promise I will re-check my crap. But I can see this pdf test is a pass

Code: [Select]
gs -v
GPL Ghostscript 9.52 (2020-03-19)
Copyright (C) 2020 Artifex Software, Inc.  All rights reserved
gs -dSAFER -dBATCH sample.pdf
GPL Ghostscript 9.52 (2020-03-19)
Copyright (C) 2020 Artifex Software, Inc.  All rights reserved.
This software is supplied under the GNU AGPLv3 and comes with NO WARRANTY:
see the file COPYING for details.
Processing pages 1 through 2.
Page 1
Loading NimbusSans-Regular font from /usr/local/share/ghostscript/9.52/Resource/Font/NimbusSans-Regular... 4009096 2525100 4357136 3025076 4 done.
>>showpage, press <return> to continue<<

exit the GUI causes a trivial error IMHO



aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #41 on: September 08, 2020, 12:50:12 AM »
offtopic but does affect my testing of wireless printing with my canon.
I think I used a different router to sync with my wl canon. So far, I have failed to get cups to see a wl canon that claims it has a "direct" wireless setting....with or without avahi running.

My router is not seeing any wl device. So I have to delay any gutenprint submission until I have exhausted my last 6 brain cells  ;D

aus9

  • Guest
Re: piCore-12.0alpha1
« Reply #42 on: September 16, 2020, 10:07:11 PM »
aarch64 avahi issues and modest success
####################
Build script has --localstatedir=/var, attempts to use --runstatedir=/var fails as configure output shows
Quote
avahi socket:/run/avahi-daemon/socket

Attempt to fix Makefile....looks good but still fails....still "makes"  to /run
Code: [Select]
sed 's|avahi_runtime_dir = /run|avahi_runtime_dir = /var/run|' -i Makefile
sed 's|avahi_socket = /run/avahi-daemon/socket|avahi_socket = /var/run/avahi-daemon/socket|' -i Makefile

after load and start daemon....I wonder does it really matter as avahi first tests without cups built appear ok

Code: [Select]
ls /run/avahi-daemon/
pid     socket
tc@box:~$ sudo /usr/local/etc/init.d/avahi stop
tc@box:~$ ls /run/avahi-daemon/ 
tc@box:~$ SNIP.....avahi is not running
###########################
# when it was running
avahi-browse -art
SNIP
eth0 IPv4 box                                           _ssh._tcp            local
SNIP
=   eth0 IPv4 Entertainment Room                            _mediaremotetv._tcp  local
   hostname = [Entertainment-Room.local]
   address = [fe80::107f:e600:247c:3a34]
   port = [49152]
   txt = ["LocalAirPlayReceiverPairingIdentity=4FC9C511-EA41-41C2-950A-B6FB01E11623" "SystemBuildVersion=17M61"
"UniqueIdentifier=4FC9C511-EA41-41C2-950A-B6FB01E11623" "Name=Entertainment Room" "macAddress=50:32:37:a8:2c:0e"
 "BluetoothAddress=P27�,\013" "AllowPairing=YES" "ModelName=Apple TV"]

Question Can I continue or does it matter that run for this daemon needs to be /var/run and not /run

If it does matter I will probably look to an older version that does not know about systemd

thanks for reading


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12419
Re: piCore-12.0alpha1
« Reply #43 on: September 16, 2020, 11:39:36 PM »
I believe that will be OK.