WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: With Qt-5.x version 5.14.0 qmake gives compile error  (Read 531 times)

Offline rhermsen

  • Jr. Member
  • **
  • Posts: 50
Re: With Qt-5.x version 5.14.0 qmake gives compile error
« Reply #15 on: August 25, 2020, 01:00:16 PM »
Trying to run the package on TCL-11.0 requires a lot more dependencies to be loaded but still failed with:

Code: [Select]
tc@box:~$ sudo ostinato
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb.

Aborted
tc@box:~$

Only if I also load 'qt-5.x-dev' with all its dependencies it will run.

Other packages I had to install:
Code: [Select]
tce-load -wi harfbuzz.tcz
tce-load -wi libGL.tcz
tce-load -wi gcc_libs.tcz
tce-load -wi libzstd.tcz

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8113
Re: With Qt-5.x version 5.14.0 qmake gives compile error
« Reply #16 on: August 25, 2020, 01:31:43 PM »
Hi rhermsen
... Only if I also load 'qt-5.x-dev' with all its dependencies it will run. ...
If you install  qt-5.x-opengl  instead of  qt-5.x-dev , does it run then?

Offline rhermsen

  • Jr. Member
  • **
  • Posts: 50
Re: With Qt-5.x version 5.14.0 qmake gives compile error
« Reply #17 on: August 25, 2020, 02:41:57 PM »
Hi Rich, that was the first one I tried, but that one was already installed.

Code: [Select]
tc@box:~$ tce-load -wi qt-5.x-opengl.tcz
qt-5.x-opengl is already installed!
tc@box:~$ tce-load -wi qt-5.x-dev

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8113
Re: With Qt-5.x version 5.14.0 qmake gives compile error
« Reply #18 on: August 25, 2020, 05:18:41 PM »
Hi rhermsen
Instead of loading  qt-5.x-dev , run this:
Code: [Select]
ldd `which ostinato` | grep -i foundThose are not apostrophes in that command, they are back ticks and found on the  ~  key. If that command produces any  Not found
messages, you can find the missing libraries using the  Apps  utilities  Provides  function.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12392
Re: With Qt-5.x version 5.14.0 qmake gives compile error
« Reply #19 on: August 25, 2020, 10:20:32 PM »
From this message:
Code: [Select]
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb

..I'd guess that you'll need qt-5.x-all.