WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TinyCore x86 with a black screen + underscore  (Read 1867 times)

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8231
Re: TinyCore x86 with a black screen + underscore
« Reply #15 on: July 11, 2020, 04:29:42 AM »
Hi Sashank999
Please attach a copy of your  /opt/.filetool.lst  file to your next post.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #16 on: July 11, 2020, 05:29:10 AM »
Hi Juanito, Rich,

Juanito, I have tried again with flwm but still the same black screen. I have also done the command you said but the output was nothing. I also piped the command to "less" to manually check for "found" text but there is no such text.

Rich, here is /opt/.filetool.sh.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #17 on: July 11, 2020, 07:42:18 AM »
Hi !

Did anyone get a solution ? I am really sad :( to get my first linux distro going wrong.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12506
Re: TinyCore x86 with a black screen + underscore
« Reply #18 on: July 11, 2020, 08:02:08 AM »
Have you tried booting with code "norestore" and only Xvesa, flwm aterm and wbar "onboot"?

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #19 on: July 11, 2020, 07:40:16 PM »
Hi Juanito,

I have tried as you said. Then, I got the Xvesa resolution setup (That Green Color setup). Then, I got the black screen. I have seen somewhere in forums that Alt + Control + F1 returns to Terminal. I did it and then I saw "failed in waitforX". I have also done sudo startx but then I got Xvesa setup again but again black screen. Again I returned to Terminal and I got "Giving up. failed in waitforX".

What to do ?

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8231
Re: TinyCore x86 with a black screen + underscore
« Reply #20 on: July 11, 2020, 08:53:34 PM »
Hi Sashank999
I'd like to try something. Go to this thread:
http://forum.tinycorelinux.net/index.php/topic,23936.0.html
Download the  TCscan.sh  script. Make it executable and run it. Attach the  .txt  file it produces to your next post.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #21 on: July 11, 2020, 10:59:13 PM »
Hi Rich,

Here is the result text file attached.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8231
Re: TinyCore x86 with a black screen + underscore
« Reply #22 on: July 12, 2020, 06:00:23 AM »
Hi Sashank999
Try this:
Code: [Select]
rm .xsession
filetool.sh -b
tce-load -i Xvesa aterm wbar flwm
startx

...  I got the Xvesa resolution setup (That Green Color setup). Then, I got the black screen. I have seen somewhere in forums that Alt + Control + F1 returns to Terminal. ...
If this happens again, run the  TCscan.sh  script after you hit  Ctrl-Alt-F1  and attach the  .txt  file it produces.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #23 on: July 12, 2020, 09:56:57 PM »
Hi Rich,

Sorry for the delay.

I have done as you said but still I got the black screen. I waited for 5 mins but the black screen stayed there. When I returned to Alt+F1 prompt, it says "failed in waitforX". I have attached 2 log files. One before loading the wifi (TCscan200713044314.txt) and one after loading the wifi (TCscan200713045018.txt).

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8231
Re: TinyCore x86 with a black screen + underscore
« Reply #24 on: July 12, 2020, 10:26:10 PM »
Hi Sashank999
It seems Xvesa is throwing an error:
Code: [Select]
traps: Xvesa[2096] trap invalid opcode ip:6800 sp:fa8 error:0 in zero[1000+9f000]

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #25 on: July 12, 2020, 10:37:12 PM »
Hi Rich,

Oh  :(. Is there any solution to this problem ? I have also tried loading Xorg (after giving you the logs and restarting with base) but even that gives a black screen. I can't get back to terminal (Alt+F1) in Xorg to see the status.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12506
Re: TinyCore x86 with a black screen + underscore
« Reply #26 on: July 12, 2020, 10:46:29 PM »
If you start with Xorg, rather than Xvesa, you can look for errors in /var/log/Xorg.0.log

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #27 on: July 12, 2020, 10:47:58 PM »
Hi Juanito,

But I can't return back to Alt + F1 terminal after loading Xorg server with startx. What to do to get back to terminal ?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12506
Re: TinyCore x86 with a black screen + underscore
« Reply #28 on: July 12, 2020, 10:56:27 PM »
Isn't it <ctrl-alt-f1>?

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 372
Re: TinyCore x86 with a black screen + underscore
« Reply #29 on: July 12, 2020, 11:01:02 PM »
Hi Juanito,

I have tried that but it didn't work. I will try that once again.