WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problem on php7-ext.tcz package and dependence missing on Tinycore 11.x x86  (Read 151 times)

Offline Tiago Araujo da Costa

  • Newbie
  • *
  • Posts: 9
Good Morning Tinycore Team.

Is missing library /usr/local/lib/php/extensions/hash.so on php7-ext.tcz.
Is missing libffi.tcz on dependence list of file php7-mod.tcz.dep or other package dep.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7774
Hi Tiago Araujo da Costa
According to the  Change-log:  found in the  .info  file:
http://tinycorelinux.net/11.x/x86/tcz/php7-ext.tcz.info

It says:
                2019/12/05 upgrade to 7.4.0
                        extension hash is now required to be compiled in
                                remove extension=hash from php.ini

                        extensions recode and wddx are deprecated (dropped)
                        extension ffi (foreign function interface) is new
                        extension mbstring requires libonig.tcz (no longer bundled)
                2020/02/06 updated to 7.4.2, recompiled for TC 11.x

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7774
Hi andyj
By the way, you misspelled  extension:
Code: [Select]
Title: php7-ext.tcz
Description:    PHP Hypertext Processor extention modules
Version: 7.4.7

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Only one spelling mistake? I must be getting better in my old age. 8)  I did confirm that libffi.tcz is listed as a requirement for the ffi extension in the php.ini-sample file, so at least I didn't miss that in the upgrade to 7.4. It is worth repeating that the dependencies for optional extensions (which technically is all of them) are not in the .dep file and must be loaded manually as required.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7774
Hi andyj
Only one spelling mistake? I must be getting better in my old age. 8) ...
Or maybe I'm slipping and missed the other 6. ;D