WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: WındowMaker ( I was unable to enable the local language. )  (Read 558 times)

Offline xor

  • Hero Member
  • *****
  • Posts: 671
WındowMaker ( I was unable to enable the local language. )  :'(

http://www.windowmaker.org/docs/wmaker_i18n.html

Code: [Select]
tc@box:~$ wmaker --locale tr wmaker(StartUp(startup.c:636)): fatal: it seems that there is already a window manager running

can you write the commands needed to activate the local language!

---

http://www.windowmaker.org/docs/wmaker_i18n.html

I read and write with google translate

There are too many foreign language (english) words on the page.
« Last Edit: June 16, 2020, 01:40:03 AM by xor »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #1 on: June 16, 2020, 01:40:59 AM »
http://www.windowmaker.org/docs/wmaker_i18n.html
Quote
WINDOW MAKER has the possibility to be translated in many languages, but by default none of them will be installed, and the support for translation will not be compiled.

http://tinycorelinux.net/11.x/x86_64/tcz/src/windowmaker/compile_windowmaker
Code: [Select]
Translated languages to support     : disabled

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #2 on: June 16, 2020, 02:03:07 AM »
http://www.windowmaker.org/docs/wmaker_i18n.html
Quote
WINDOW MAKER has the possibility to be translated in many languages, but by default none of them will be installed, and the support for translation will not be compiled.

http://tinycorelinux.net/11.x/x86_64/tcz/src/windowmaker/compile_windowmaker
Code: [Select]
Translated languages to support     : disabled

* Can you tell me what to do now?

* by the way ; can you add the new update!?

http://tinycorelinux.net/11.x/x86_64/tcz/src/windowmaker/compile_windowmaker
cd WindowMaker-0.95.8

http://www.windowmaker.org/
Latest source of stable version is 0.95.9, released on 04.04.2020. See the NEWS section for more information.

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #3 on: June 16, 2020, 02:51:59 AM »
You have already created the required language file and published it in the TCZ file!

http://tinycorelinux.net/11.x/x86/tcz/windowmaker.tcz

windowmaker.tcz -> usr -> local -> share -> WindowMaker -> menu.tr



http://www.windowmaker.org/docs/wmaker_i18n.html
Quote
WINDOW MAKER has the possibility to be translated in many languages, but by default none of them will be installed, and the support for translation will not be compiled.

http://tinycorelinux.net/11.x/x86_64/tcz/src/windowmaker/compile_windowmaker
Code: [Select]
Translated languages to support     : disabled
« Last Edit: June 16, 2020, 02:54:34 AM by xor »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #4 on: June 16, 2020, 04:17:21 AM »
windowmaker updated, windowmaker-locale and wmalauncher added to CorePure64 repo.

Please test and let us know if it works.

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #5 on: June 18, 2020, 02:04:24 AM »
(I am writing with google translate)

I use 2 different TCL versions

TCL 11.1 has 64 bit ezre-master problem
http://forum.tinycorelinux.net/index.php/topic,23902.0.html
It is not right to comment without making sure that it works well in 64-bit packages!

2nd place

Ezre-master works fine for TCL 11.1 32-bit version
however, I see that the Wmaker update is not produced for 32 bits.

 :-\

windowmaker updated, windowmaker-locale and wmalauncher added to CorePure64 repo.

Please test and let us know if it works.
« Last Edit: June 18, 2020, 02:09:22 AM by xor »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #6 on: June 18, 2020, 03:15:58 AM »
The 32-bit version of windowmaker was not updated because of waiting for feedback on the 64-bit version of windowmaker.

You do not need ezremaster to test the 64-bit version of windowmaker.

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #7 on: June 18, 2020, 05:45:25 AM »
good news ; the new version works smoothly!

bad news ; I couldn't find how to activate local language support.

? Which command do I need to enter in the terminal to do TR!

The 32-bit version of windowmaker was not updated because of waiting for feedback on the 64-bit version of windowmaker.

You do not need ezremaster to test the 64-bit version of windowmaker.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #8 on: June 18, 2020, 05:52:00 AM »
I would assume you need to:

* use the getlocale extension to create a TR UTF mylocale extension
* reboot
* load the windowmaker-locale extension
* startx

If that doesn't work then you'll need a wrapper script to start windowmaker with "wmaker --locale tr"
« Last Edit: June 18, 2020, 05:54:21 AM by Juanito »

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #9 on: June 18, 2020, 07:17:25 AM »
for x86 (32-bit) could you please add the new version.

I would assume you need to:

* use the getlocale extension to create a TR UTF mylocale extension
* reboot
* load the windowmaker-locale extension
* startx

If that doesn't work then you'll need a wrapper script to start windowmaker with "wmaker --locale tr"

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #10 on: June 18, 2020, 07:24:23 AM »
I'll look at compiling the 32-bit version after you successfully test the 64-bit version in Turkish - if you cannot get the 64-bit version to work in Turkish, there is no point to compile the 32-bit version.

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #11 on: June 18, 2020, 10:55:36 AM »
 :) ok :)

it is necessary to end the session and then restart from the terminal.




I'll look at compiling the 32-bit version after you successfully test the 64-bit version in Turkish - if you cannot get the 64-bit version to work in Turkish, there is no point to compile the 32-bit version.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #12 on: June 18, 2020, 10:49:04 PM »
Did you set the locale to Turkish and load windowmaker-locale?

Does wmalauncher work?

Offline xor

  • Hero Member
  • *****
  • Posts: 671
Re: WındowMaker ( I was unable to enable the local language. )
« Reply #13 on: June 19, 2020, 02:58:35 AM »
Did you set the locale to Turkish and load windowmaker-locale?

Does wmalauncher work?


+  windowmaker-locale  ok YES ! :)

- wmalauncher.tcz ( not in the warehouse! ) https://sourceforge.net/projects/wmalauncher/

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255