WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver  (Read 4345 times)

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #105 on: June 19, 2020, 07:50:29 PM »
@Juanito
Thanks for accepting the extension.
You need to update the dependency pygobject2 to pygobject. There is nothing like pygobject2. http://tinycorelinux.net/11.x/x86/tcz/pygtk.tcz.dep
pygtk is a dependency for minigalaxy.
After updating that, I will submit the minigalaxy.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #106 on: June 19, 2020, 10:53:10 PM »
I'll take a look at pygtk, but I think it is far more likely that minigalaxy needs py3.6gobject and gtk3-gir.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #107 on: June 19, 2020, 10:55:32 PM »
I am getting some kind of API error which contains the word gtk in it.
I have also seen gtk+ in requirements. So, I searched for gtk+ tag and got pygtk. Then it worked.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #108 on: June 19, 2020, 11:57:16 PM »
You need to update the dependency pygobject2 to pygobject. There is nothing like pygobject2. http://tinycorelinux.net/11.x/x86/tcz/pygtk.tcz.dep

pygobject2 copied from the x86 10.x repo to the 11.x repo - thanks for pointing that out.

Note:

pygobject2 = python-2.7 bindings for gobject, version 2
pygobject = python-2.7 bindings for gobject, version 3
py3.6gobject = python-3.6 bindings for gobject, version 3

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #109 on: June 20, 2020, 12:28:29 AM »
I am getting some kind of API error which contains the word gtk in it.
I have also seen gtk+ in requirements. So, I searched for gtk+ tag and got pygtk. Then it worked.

Was the error you got something like:
Code: [Select]
ValueError: Namespace Gtk not available
pygtk contains the python-2.7 bindings for gtk2 - did you compile minigalaxy against python(2.7) or python3.6?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #110 on: June 20, 2020, 12:47:43 AM »
pygobject2 copied from the x86 10.x repo to the 11.x repo - thanks for pointing that out.

I spoke too soon - pygobject2 has a dep on the outdated libffi5, so pygobject2 and pygtk removed from the x86 11.x repo

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #111 on: June 20, 2020, 01:55:12 AM »
I think I have to compile the extension minigalaxy again and delete that python.tcz from my TCEs and update the python deps.
I will now compile pygobject (anyhow, it requies v3.29.1+ but we have older one) and minigalaxy.
I will do it.
« Last Edit: June 20, 2020, 02:02:55 AM by Sashank999 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #112 on: June 20, 2020, 02:12:08 AM »
See: http://tinycorelinux.net/11.x/x86/tcz/py3.6gobject.tcz.info

pygobject is already version 3.36.1

You don't need to delete python, just don't load it...

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #113 on: June 20, 2020, 02:30:02 AM »
But we need pygtk. Only one left !!!  :P
I was actually looking at the pygobject.tcz not at py3.6gobject.tcz. My bad.
« Last Edit: June 20, 2020, 02:40:36 AM by Sashank999 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #114 on: June 20, 2020, 02:35:03 AM »
Are you sure you need pygtk (python-2.7, gtk2) or gtk3-gir?

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #115 on: June 20, 2020, 02:54:37 AM »
gtk3-gir is now enough.
I am attaching an updated .dep file. Replace this instead of the submitted one.
Should I run the submitqc again for the new .dep file ?
I am still able to see the pygtk you removed. Pls check it once.
« Last Edit: June 20, 2020, 02:56:17 AM by Sashank999 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #116 on: June 20, 2020, 04:19:44 AM »
Does minigalaxy work for you?

I get a blank logon window on top of a blank main window - if I close the logon window, the main window exits.

The problem could be that minigalaxy is blocked here.

Edit: see attached
« Last Edit: June 20, 2020, 04:41:25 AM by Juanito »

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #117 on: June 20, 2020, 05:07:48 AM »
The logon is too slow to load.
You need to wait a second.
In logon window, after you login, you will see games for download.
You can also watch here https://m.youtube.com/watch?v=XPc-Ty3rtRE

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12387
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #118 on: June 20, 2020, 05:42:37 AM »
I've waited 15mins with no result, so I'll have to take your word for it...

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 357
Re: Installation of aircrack-ng,hashcat,hcxdumptool,hcxpcaptools,reaver
« Reply #119 on: June 20, 2020, 05:49:52 AM »
I'm sorry to ask but I got it in less than 1 min.
Could you pls recheck your dependency file for the package ? I am suggesting this because I have updated the dependency file and you might accidentally have old one.