WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: sce-import problem?  (Read 111 times)

Offline ctor

  • Newbie
  • *
  • Posts: 7
sce-import problem?
« on: May 19, 2020, 06:52:23 PM »
I am using dCore-bionic64 from the release directory, dCore-bionic64:201912.03.20.44. I ran in to a failed download of chromium-browser with this command:

Code: [Select]
sce-import chromium-browser
I had the following setup for the sce-import command:

1) the debmirror and securitymirror files were set to their respective, default values,

2) No additional repositories were set in the debinx directory

I got the following results:

1) The ubuntu_bionic_main_amd64_Package file pointed to Filename: pool/universe/c/chromium-browser/chromium-browser_65.0.3325.181-0ubuntu1_amd64.deb, a very old version,

2) ubuntu_bionic_security_amd64_Packages file pointed to Filename: pool/universe/c/chromium-browser/chromium-browser_80.0.3987.163-0ubuntu0.18.04.1_amd64.deb which did not exist in the security respository. Instead,chromium-browser_80.0.3987.163-0ubuntu1_amd64.deb exists -- ubuntu1, not ubuntu0. There is actually a newer version available in the security repository, chromium-browser_81.0.4044.138-0ubuntu0.18.04.1_amd64.deb.

3) sce-import picked up the chromium-browser from the security universe repository instead of the security main repository.

My questions are:
 
1) why was the latest .deb file not picked?

2) why was the universe repository used, not main? Note: there were no chromium-browser files in the main repository. To be honest, I am not convinced that this is even an sce-import issue. Rather, this could be an issue with the Ubuntu security repository. Please advise.

I have attached the sce-import log file below. If you look at it, you will see that 3 file downloads failed. The reason I believe the download failed is the ubuntu_bionic_main_amd64_Package file pointed to a file that does not exist in the security repository.

Thank you to all the tinycore and dCore contributors for these wonderful distributions.

regards,
ctor



Online Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9678
Re: sce-import problem?
« Reply #1 on: May 21, 2020, 06:11:23 PM »
Hi ctor, I just saw this.  There was a bug on our server regarding dCore-bionic64, I fixed it today.  Please try again.  Thanks. 

Online Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9678
Re: sce-import problem?
« Reply #2 on: May 21, 2020, 06:22:22 PM »
I am running dCore-bionic64 and just imported and loaded chromium-browser.  It imports and loads and runs just fine.  Thank you for reporting the issue, it is fixed.  It involved a typo on my part on our server. 

Offline ctor

  • Newbie
  • *
  • Posts: 7
Re: sce-import problem?
« Reply #3 on: May 21, 2020, 09:13:36 PM »
JasonW,

Thank you for fixing the server bug. More importantly, thank you for your reply. I looked at it again today and discovered it had already been fixed.

regards,
ctor