WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xorg Configure Touchpad  (Read 607 times)

Offline stzero

  • Newbie
  • *
  • Posts: 6
Xorg Configure Touchpad
« on: May 04, 2020, 09:10:00 AM »
Is there a reliable way to configure the touchpad with Xorg? I added a 50-synaptics.conf file to /usr/local/share/X11/xorg.conf.d. I then added that file to /opt/.filelist.lst. The file remains after reboot, but the configuration changes are not implemented. Also, the file in Bash is not sky-blue (it does not link to a file in /tmp, as do the other files in /usr/local/share/X11/xorg.conf.d). What am I doing wrong?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12429
Re: Xorg Configure Touchpad
« Reply #1 on: May 04, 2020, 10:17:07 AM »
Which version of tinycore are you using?

As from 11.x Xorg uses libinput instead of evdev, so the touchpad configuration would be different.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12429
Re: Xorg Configure Touchpad
« Reply #2 on: May 05, 2020, 11:15:41 PM »
You can take a look here for some tips on configuration:

https://wiki.archlinux.org/index.php/libinput#Via_xinput

..or if you prefer, you can modify your Xorg-7.7 dep file locally "xf86-input-libinput.tcz" -> "xf86-input-evdev.tcz" to use your existing config.

Offline stzero

  • Newbie
  • *
  • Posts: 6
Re: Xorg Configure Touchpad
« Reply #3 on: May 07, 2020, 02:31:47 PM »
Thanks! I am using TinyCore 11.1. I was able to use the 'xinput set-prop' command to reconfigure the touchpad, but I get a BadAccess error when trying to change the default configurations. So my changes do not persist after reboot.

I therefore created an xorg.conf.d directory at /usr/share/X11, and added the file 40-libinput.conf with the following content:

Section "InputClass"
   Identifier "libinput touchpad catchall"
   Driver "libinput"
   MatchIsTouchpad "on"
   Option "Tapping" "true"
EndSection
       
I then added the line usr/share/X11/xorg.conf.d to opt/.filetool.lst

I am new to TinyCore and linux, and am not sure what I am doing wrong.


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12429
Re: Xorg Configure Touchpad
« Reply #4 on: May 07, 2020, 09:25:10 PM »
You need to use /usr/local/share/X11/xorg.conf.d

Offline stzero

  • Newbie
  • *
  • Posts: 6
Re: Xorg Configure Touchpad
« Reply #5 on: May 11, 2020, 08:52:22 AM »
Thanks! That worked. /usr/local/share/X11/xorg.conf.d/40-libinput.conf already existed and was read only, so I created a 50-libinput.conf file with the relevant changes.

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8135
Re: Xorg Configure Touchpad
« Reply #6 on: May 11, 2020, 09:27:39 AM »
Hi stzero
... /usr/local/share/X11/xorg.conf.d/40-libinput.conf already existed and was read only, so I created a 50-libinput.conf file ...

You can make it writable like this if you wish:
Code: [Select]
sudo busybox cp -f /usr/local/share/X11/xorg.conf.d/40-libinput.conf /usr/local/share/X11/xorg.conf.d/40-libinput.conf
Then make your changes and add it to your backup.

Offline stzero

  • Newbie
  • *
  • Posts: 6
Re: Xorg Configure Touchpad
« Reply #7 on: May 14, 2020, 06:04:10 AM »
Thanks, that's good to know.