WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Plymouth installation problems  (Read 291 times)

Offline Lachu

  • Newbie
  • *
  • Posts: 15
Plymouth installation problems
« on: April 30, 2020, 03:51:39 AM »
1. Wiki points to broken link, so I was unable to download pylmouth source. I downloaded it from github and in next step type git checkout 0.8.8
2. convert program don't worked for me - probably TCE contains newer version, so I use other theme
3. Tiny core contains never GCC, so in src/libply/ply-key-file.c I must change each %a (in format string) to %m .

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12255
Re: Plymouth installation problems
« Reply #1 on: April 30, 2020, 04:10:28 AM »
Assuming you are speaking of https://github.com/freedesktop/plymouth

This seems to work without errors:
Code: [Select]
$ tce-load -i compiletc automake libtool-dev intltool
$ ./autogen.sh

Offline andyj

  • Hero Member
  • *****
  • Posts: 861
Re: Plymouth installation problems
« Reply #2 on: April 30, 2020, 04:46:46 AM »
Version 0.8.8 was the current version when I first wrote the plymouth wiki but as you can see that was eight years ago. I don't have the hardware to test it anymore.  I tried to test it with vmware dri last year but it did not work so I gave up. You should start with the latest version, it is less than two years old.