WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-11beta wifi problem  (Read 5060 times)

Offline danny

  • Jr. Member
  • **
  • Posts: 73
piCore-11beta wifi problem
« on: April 12, 2020, 10:29:28 PM »
Hi
I can't find wifi on rpi3b+ in piCore-11beta
When I key "sudo /usr/local/bin/wifi.sh".
I got "No wifi devices found!".

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #1 on: April 12, 2020, 10:36:34 PM »
This works for me:
Code: [Select]
$ tce-load -i firmware-rpi-wireless
$ tce-load -i wireless-KERNEL
$ tce-load -i wifi
$ sudo wifi.sh

Note that the firmware must be loaded first

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #2 on: April 12, 2020, 10:58:16 PM »
I executed "tce-load -i firmware-rpi-wireless"
I got firmware-rpi-wireless.tcz not found!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #3 on: April 12, 2020, 11:51:14 PM »
What does this show for you:
Code: [Select]
$ version
11.0beta1a

$ uname -m
armv7l

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #4 on: April 13, 2020, 01:11:58 AM »
I executed "tce-load -i firmware-rpi-wireless"
I got firmware-rpi-wireless.tcz not found!

What about this:
Code: [Select]
$ tce-load -wil firmware-rpi-wireless

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #5 on: April 13, 2020, 01:14:06 AM »
Please refer this when I executed "uname -m".
armv7l
And then I executed "tce-load -wil firmware-rpi-wireless".
I got the following:
Downloading: firmware-rpi-wireless.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 404 Not Found
md5sum: firmware-rpi-wireless.tcz.md5.txt: No such file or directory
Error on firmware-rpi-wireless.tcz

« Last Edit: April 13, 2020, 01:16:51 AM by danny »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #6 on: April 13, 2020, 04:20:37 AM »
Sorry, my mistake, that should have been:
Code: [Select]
$ tce-load -wil firmware-rpi-wifi
..it used to be called firmware-rpi-wireless in the 9.x repo...
« Last Edit: April 13, 2020, 04:22:50 AM by Juanito »

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #7 on: April 14, 2020, 01:11:47 AM »
Hi Juanito
I got the same message "No wifi device found!"
It seems unable to detect "wlan0".

Thanks

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #8 on: April 14, 2020, 01:36:08 AM »
Do you get something similar to this after reboot and without loading anything "onboot":
Code: [Select]
$ tce-load -i firmware-rpi-wifi
$ tce-load -i wireless-KERNEL
$ dmesg | tail -15
...
[ 3737.522708] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 3737.543585] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[ 3737.543692] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 3737.543698] cfg80211: failed to load regulatory.db
[ 3737.556288] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
[ 3737.560204] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 3737.560365] usbcore: registered new interface driver brcmfmac
[ 3737.751547] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 3737.751621] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 3737.752178] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #9 on: April 14, 2020, 07:17:37 PM »
I got the following message:
Code: [Select]
tc@box:~$ dmesg | tail -15
[   10.330499] random: fc-cache: uninitialized urandom read (4 bytes read)
[   10.334269] random: fc-cache: uninitialized urandom read (4 bytes read)
[   10.334992] random: fc-cache: uninitialized urandom read (4 bytes read)
[   10.539697] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[   10.581086] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[   10.581191] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   10.581197] cfg80211: failed to load regulatory.db
[   10.608695] brcmfmac: F1 signature read @0x18000000=0x15264345
[   10.619324] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[   10.619504] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2
[   10.619923] usbcore: registered new interface driver brcmfmac
[   11.629176] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
[   11.772219] i2c /dev entries driver
[   11.798151] random: crng init done
[   11.798158] random: 6 urandom warning(s) missed due to ratelimiting

    [EDIT]: Added code tags.  Rich
« Last Edit: April 14, 2020, 07:35:08 PM by Rich »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: piCore-11beta wifi problem
« Reply #10 on: April 14, 2020, 07:36:01 PM »
Hi danny
Please use  Code Tags  when posting commands and responses seen in a terminal. To use  Code Tags  click on the  #  icon
above the reply box and paste your text between the  Code Tags  as shown in this example:

Quote
[code][   36.176529] pcm512x 1-004d: Failed to get supply 'AVDD': -517
[   36.176536] pcm512x 1-004d: Failed to get supplies: -517
[   36.191753] pcm512x 1-004d: Failed to get supply 'AVDD': -517[/code]

It will appear like this in your post:
Code: [Select]
[   36.176529] pcm512x 1-004d: Failed to get supply 'AVDD': -517
[   36.176536] pcm512x 1-004d: Failed to get supplies: -517
[   36.191753] pcm512x 1-004d: Failed to get supply 'AVDD': -517

Code Tags  serve as visual markers between what you are trying to say and the information you are posting. They also preserve
spacing so column aligned data displays properly.
« Last Edit: August 01, 2020, 10:22:49 AM by Rich »

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #11 on: April 14, 2020, 08:00:10 PM »
Hi Rich,
Sorry to cause you confuse.
Thanks for your notice.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #12 on: April 14, 2020, 10:01:09 PM »
It looks like firmware-rpi-wifi does not contain the correct firmware for your machine - what does this show for you:
Code: [Select]
$ cat /proc/cpuinfo | grep Model
Model           : Raspberry Pi 3 Model B Rev 1.2

Offline danny

  • Jr. Member
  • **
  • Posts: 73
Re: piCore-11beta wifi problem
« Reply #13 on: April 14, 2020, 11:00:04 PM »
I got the following information:

Code: [Select]
Model           : Raspberry Pi 3 Model B Plus Rev 1.3

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: piCore-11beta wifi problem
« Reply #14 on: April 15, 2020, 08:03:21 AM »
After some checking, it looks like the firmware for your hardware is present in firmware-rpi-wifi - I don't know why it doesn't load.