WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Error on libattr.tcz  (Read 120 times)

Offline jmckinzie

  • Newbie
  • *
  • Posts: 2
Error on libattr.tcz
« on: March 25, 2020, 01:16:36 PM »
I am running tce-load -w libattr
D/Ling
Connecting to Repo repo.tinycore.com
wget: server returned error No such file or directory.
Error on libattr.tcz.

So, given i cannot install it via a repository, how can I install it?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: Error on libattr.tcz
« Reply #1 on: March 25, 2020, 01:27:39 PM »
Hi jmckinzie
When reporting an issue, you need to include version (TC10 or TC11) and architecture (x86, x86_64, ARMv6, etc).

Offline jmckinzie

  • Newbie
  • *
  • Posts: 2
Re: Error on libattr.tcz
« Reply #2 on: March 25, 2020, 01:40:18 PM »
TC 11 x86

Any ideas?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: Error on libattr.tcz
« Reply #3 on: March 25, 2020, 01:46:33 PM »
Hi jmckinzie
The TC 11 x86 repository shows  libattr.tcz  is present:
http://tinycorelinux.net/11.x/x86/tcz/

Maybe you meant  TC 11 x86_64 (64 bit)? If that's the case, try downloading the TC9 version:
wget http://tinycorelinux.net/9.x/x86/tcz/libattr.tcz

It has no dependencies. Please report back if this works for you.


    [EDIT]: Post contents struck out because this guy didn't know what he was talking about.  Rich
« Last Edit: March 27, 2020, 05:20:45 AM by Rich »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: Error on libattr.tcz
« Reply #4 on: March 26, 2020, 06:34:34 AM »
Hi jmckinzie
TC 11 x86

Any ideas?
Yes. First of all, disregard everything I said in my previous post.

It appears  libattr.so  was separated from  attr.tcz  for  x86.  Over time, a newer version of  libattr.so  was added back into  attr.tcz.
However, the  libattr.tcz  extension continued to exist in the repository.

In  x86_64 , that separation never took place, so there you would want  attr.tcz.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11471
Re: Error on libattr.tcz
« Reply #5 on: March 26, 2020, 11:32:46 PM »
libattr removed and dep files adjusted

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: Error on libattr.tcz
« Reply #6 on: March 27, 2020, 07:30:50 AM »
Hi jmckinzie
I just noticed something else:
... Connecting to Repo repo.tinycore.com ...
That address looks wrong. Your  /opt/tcemirror  file is probably wrong. Do this:
Code: [Select]
echo "http://repo.tinycorelinux.net/" > /opt/tcemirrorSee if that fixes your downloading problem.