WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] piCore-11: Problems with tce-load  (Read 509 times)

Offline jazzbiker

  • Full Member
  • ***
  • Posts: 183
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #15 on: March 23, 2020, 09:50:35 AM »
Hi, Core guys!

Sorry for my 2 cents, but FetchExt.sh uses #!/bin/bash. Is bash installed?

Offline bricolodu13

  • WikiUser
  • *
  • Posts: 18
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #16 on: March 23, 2020, 10:01:54 AM »
Hello Rich,

Thank you very much for trying to help.

However, no progress....

I even rebooted and did everything again (create a download directory, getting your file, making it executable, trying to exe, escape from the ssh session, launch a new session, ./FetchExt.sh nano) still no success.

And I'm almost sure it is executable as it is apearing in green after chmod.
Also, if accessing from WinSCP, the file poperties are correctly set as 0777

Hello jazzbiker
No bash is not installed !
The trick is that bash can't be installed for the very same reason that it is not availlable in the http://tinycorelinux.net/11.x/armv7/tcz/ repo...

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #17 on: March 23, 2020, 10:02:16 AM »
Hi jazzbiker
Sorry for my 2 cents, but FetchExt.sh uses #!/bin/bash. Is bash installed?
Yeah, that must be it. My local copy still uses  #!/bin/sh.  I forgot the posted version uses  #!/bin/bash.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #18 on: March 23, 2020, 10:05:36 AM »
Hi bricolodu13
... No bash is not installed !
The trick is that bash can't be installed for the very same reason that it is not availlable in the http://tinycorelinux.net/11.x/armv7/tcz/ repo...
Try changing  #!/bin/bash  to  #!/bin/sh  in the script.

Offline jazzbiker

  • Full Member
  • ***
  • Posts: 183
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #19 on: March 23, 2020, 10:05:53 AM »
In the case when shebanged binary is not found shell's error message is the same as in the case of missing original file, i've lost some hours before on such trap.

Offline bricolodu13

  • WikiUser
  • *
  • Posts: 18
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #20 on: March 23, 2020, 10:17:58 AM »
Hi,

I tryed to download bash from repo http://tinycorelinux.net/10.x/armv7/tcz/ with wget
then: tce-load -i bash.tcz
then i tried again :
Code: [Select]
./FetchExt.sh nano
http://repo.tinycorelinux.net/11.x/armv7/tcz/nano.tcz.tree  not found.
tc@box:~/download$ ./FetchExt.sh nano
http://repo.tinycorelinux.net/11.x/armv7/tcz/nano.tcz.tree  not found.
So making progress.
Maybe, I should just allways try wget and tce-load -i ?

Offline jazzbiker

  • Full Member
  • ***
  • Posts: 183
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #21 on: March 23, 2020, 10:18:14 AM »
Frankly speaking such fake error message is very misleading and may be encountred  a bug.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #22 on: March 23, 2020, 10:26:10 AM »
Hi bricolodu13
Code: [Select]
./FetchExt.sh nano
http://repo.tinycorelinux.net/11.x/armv7/tcz/nano.tcz.tree  not found.
tc@box:~/download$ ./FetchExt.sh nano
http://repo.tinycorelinux.net/11.x/armv7/tcz/nano.tcz.tree  not found.
You need to change the version in the script. You are trying to download  nano  from the  11.x  repository.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #23 on: March 23, 2020, 10:28:23 AM »
Hi jazzbiker
Frankly speaking such fake error message is very misleading and may be encountred  a bug.
The message is not fake.  nano  doesn't exist in that  11.x  repository.

Offline jazzbiker

  • Full Member
  • ***
  • Posts: 183
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #24 on: March 23, 2020, 10:30:59 AM »
Hi jazzbiker
Frankly speaking such fake error message is very misleading and may be encountred  a bug.
The message is not fake.  nano  doesn't exist in that  11.x  repository.
Hi, Rich!
I was talking about ash message about missing shebang, sorry, haven't checked the thread before posting...

Offline bricolodu13

  • WikiUser
  • *
  • Posts: 18
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #25 on: March 23, 2020, 10:35:47 AM »
Hello Rich,

OK
but, I thought that as I was using piCore-11.0beta1a.zip, I had to keep the same repo in your script.

So, If I select another repo, it is the same as wget repo xyz.tcz that repo and tce-load -i xyz.tcz or am I wrong ?

And, there is a risk that the package doen't work if it has not been produced for the piCore-11.0beta1a, or am I wrong ?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7328
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #26 on: March 23, 2020, 10:48:53 AM »
Hi bricolodu13
... but, I thought that as I was using piCore-11.0beta1a.zip, I had to keep the same repo in your script. ...
No. The purpose of the script is to allow someone to fetch extensions without regard to which Linux distro they are running. The
extensions/dependencies you need to avoid are the ones with a kernel version in their name. Your kernel version is 4.19.81, so if you
want ALSA modules you need to use the TC11 version which is  alsa-modules-4.19.81-piCore-v7.tcz.

Quote
So, If I select another repo, it is the same as wget repo xyz.tcz that repo and tce-load -i xyz.tcz or am I wrong ?
That's basically correct, except my script will resolve dependencies for you.

Quote
And, there is a risk that the package doen't work if it has not been produced for the piCore-11.0beta1a, or am I wrong ?
Thats always a risk when trying to use packages from a different version without recompiling, but trying it won't hurt anything.

Offline bricolodu13

  • WikiUser
  • *
  • Posts: 18
Re: [SOLVED] piCore-11: Problems with tce-load
« Reply #27 on: March 23, 2020, 11:02:22 AM »
Thank you