WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TC 11 Pale Moon browser not playing videos  (Read 859 times)

Offline thane

  • Hero Member
  • *****
  • Posts: 657
TC 11 Pale Moon browser not playing videos
« on: February 29, 2020, 01:04:12 PM »
Although in general the TC 11 version of the Pale Moon browser appears to work correctly, I am unable to play videos with it. The message "Your browser does not currently recognize any of the video formats available" is displayed.

The info for palemoon.tcz states "Requires ffmpeg for h.264 playback". In TC 10.x (where Pale Moon could play videos) ffmpeg.tcz is a separate extension from ffmpeg3.tcz. I assume it was the 10.x ffmpeg3.tcz extension that was upgraded to ffmpeg4.tcz in 11.0. Maybe 10.x ffmpeg.tcz needs to be upgraded for 11.0 also? Just a guess, unfortunately I didn't save my 10.x setup and so can't see what I actually had loaded. Doh...

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12392
Re: TC 11 Pale Moon browser not playing videos
« Reply #1 on: February 29, 2020, 09:52:25 PM »
palemoon will play webm videos without sound, but not h264 - a recent version of firefox will play the same webm/h264 videos with sound

tc-10.x had ffmpeg-1.x and ffmpeg-3.x. tc-11.x has ffmpeg-4.x. In addition tc-11.x has a more recent version of pulseaudio.

Starting palemoon from the cli does not give any error messages when trying to play videos, which makes it difficult to troubleshoot.

palemoon does not look like it was built on tinycore and it might be pre-compiled - I suggest that you pm the maintainer for an update.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8113
Re: TC 11 Pale Moon browser not playing videos
« Reply #2 on: February 29, 2020, 10:03:03 PM »
Hi Juanito
... a recent version of firefox will play the same webm/h264 videos with sound ...
I don't know if this helps, but on my copy of Firefox, clicking  Tools->Add-ons  lists this:
Quote
OpenH264 Video Codec provided by Cisco Systems, Inc. 1.6

This plugin is automatically installed by Mozilla to comply with the WebRTC specification and to enable WebRTC calls with devices that require the H.264 video codec. Visit http://www.openh264.org/ to view the codec source code and learn more about the implementation.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12392
Re: TC 11 Pale Moon browser not playing videos
« Reply #3 on: February 29, 2020, 11:19:36 PM »
Hmm..

When used with gst-libav (which uses ffmpeg4), epiphany will play h264, but not h265.

I guess the codecs have been updated such that backwards compatibilty has been broken.

Offline neonix

  • Sr. Member
  • ****
  • Posts: 278
Re: TC 11 Pale Moon browser not playing videos
« Reply #4 on: March 01, 2020, 10:45:10 AM »
OpenH264 is only for WebRTC. It's not used for videos.

https://andreasgal.com/2014/10/14/openh264-now-in-firefox/
Quote
Note: Firefox currently uses OpenH264 only for WebRTC and not for the <video> tag, because OpenH264 does not yet support the high profile format frequently used for streaming video. We will reconsider this once support has been added.
]

Offline thane

  • Hero Member
  • *****
  • Posts: 657
Re: TC 11 Pale Moon browser not playing videos
« Reply #5 on: March 02, 2020, 11:50:28 AM »
Thanks for the feedback. Trying out the Vivaldi browser which so far seems to do what I need!

Thane

Offline thane

  • Hero Member
  • *****
  • Posts: 657
Re: TC 11 Pale Moon browser not playing videos
« Reply #6 on: March 12, 2020, 02:43:13 AM »
Ok, went back and fiddled around with Pale Moon some more, and found out the video "problem" was a settings issue. In Pale Moon Tools/Preferences/Content/Video panel, unchecked the "Use MSE asynchronously" option and checked the "Enable MSE for WebM video" option. Now web videos (at least what I've looked at so far) play. I don't recall having to do this before, which makes me feel slightly less dumb for not figuring that out before :/

Offline thane

  • Hero Member
  • *****
  • Posts: 657
Re: TC 11 Pale Moon browser not playing videos
« Reply #7 on: March 16, 2020, 12:28:58 AM »
Well, but Pale Moon still doesn't play embedded MP3 files (e.g. the ones with the player icon on the web page). Hmm...

Offline thane

  • Hero Member
  • *****
  • Posts: 657
Re: TC 11 Pale Moon browser not playing videos
« Reply #8 on: July 03, 2020, 12:58:19 PM »
Belated FYI, it looks like Juanito was right about the TC version of Pale Moon requiring older codecs etc. I didn't get a reply from the maintainer on updating, so resorted to downloading libavcodec, libavutil, libvpx, and X264 extensions from TC 10.x repository. The 11.x repository had some other extensions that were needed. This restored the functionality of Pale Moon. Not something I'd recommend as a general solution since there are probably incompatibilities with more recent versions of the 10.x extensions, but works OK for me.