WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Core v11.0beta1  (Read 4288 times)

Offline andyj

  • Hero Member
  • *****
  • Posts: 838
Re: Core v11.0beta1
« Reply #60 on: February 07, 2020, 03:45:42 PM »
Your mylocale extension is broken. Did you download the latest getlocale, and remember to select en_US.UTF-8 before you hit OK? Did you load it in onboot.lst?

Offline GNUser

  • Sr. Member
  • ****
  • Posts: 495
Re: Core v11.0beta1
« Reply #61 on: February 07, 2020, 04:59:22 PM »
I had done all of that twice without success. But on your say so I decided to try again. This time I made sure to start from scratch: Removed  mylocale.tcz  from onboot.lst, deleted all  mylocale*  and  getlocale*  files from tce/optional, rebooted. Then I created a new  mylocale.tcz  by running $ tce-load -wi getlocale. Lo and behold, after another reboot everything works.

Thank you! :)

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11881
Re: Core v11.0beta1
« Reply #62 on: February 07, 2020, 11:18:00 PM »
What I see is the following:

If you load the extension, the getlocale script runs automatically and makes a 4k extension that doesn't work.

If you run the getlocale script at some point after loading it makes a 652k extension that does work.

Whilst the tc-10.x mylocale extension is of a similar size, the tc-9.x extension is 324k.

Offline neonix

  • Sr. Member
  • ****
  • Posts: 273
Re: Core v11.0beta1
« Reply #63 on: February 08, 2020, 04:56:27 AM »
In TC11.0beta1 (x86)
There is missig dependency in mc.tcz, it require libgcrypt.tcz
In TC11.0beta1 (x86_64) mc.tcz works OK.

In TC11.0beta1 (x86_64) I can't install midori.tcz
Code: [Select]
tc@box:~$ tce-load -iw midori
midori.tcz.dep OK
gcr.tcz.dep OK
gnupg.tcz.dep OK
libassuan.tcz.dep OK
libksba.tcz.dep OK
libusb.tcz.dep OK
Downloading: webkitgtk.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 404 Not Found
md5sum: webkitgtk.tcz.md5.txt: No such file or directory
Error on webkitgtk.tcz

In TC11.0beta1 (x86_64) qemu.tcz require libssl.so.1.0.0
« Last Edit: February 08, 2020, 05:07:55 AM by neonix »

Offline GNUser

  • Sr. Member
  • ****
  • Posts: 495
Re: Core v11.0beta1
« Reply #64 on: February 08, 2020, 05:07:32 AM »
I did more experiments. If I try generating a new mylocale.tcz without any mylocale.tcz currently loaded, the process succeeds (a 667k mylocale.tcz extension is created):

Code: [Select]
$ tce-status -i | grep locale
[note no hits]
$ tce-load -wi getlocale
getlocale.tcz.dep OK
Downloading: getlocale.tcz
Connecting to gnuser.ddns.net (192.168.10.1:80)
saving to 'getlocale.tcz'
getlocale.tcz        100% |********************************|  4096  0:00:00 ETA
'getlocale.tcz' saved
getlocale.tcz: OK

[The below shows up in a different terminal after I've selected the locale I want]
Now processing... /
Locales installed. Creating extension... \

Done. The extension is at /mnt/sda3/tce/optional/mylocale.tcz and in onboot.lst
Reboot with lang=xyz (for example lang=en_US.UTF-8) to start using this.


Press enter to quit.

If I try generating a new mylocale.tcz with mylocale.tcz already loaded, the process fails (a 4k mylocale.tcz extension is created):
Code: [Select]
$ tce-status -i | grep locale
mylocale
$ tce-load -wi getlocale
getlocale.tcz.dep OK
Downloading: getlocale.tcz
Connecting to gnuser.ddns.net (192.168.10.1:80)
saving to 'getlocale.tcz'
getlocale.tcz        100% |********************************|  4096  0:00:00 ETA
'getlocale.tcz' saved
getlocale.tcz: OK

[The below shows up in a different terminal after I've selected the locale I want]
Now processing... cannot open locale archive "/usr/lib/locale/locale-archive": Read-only file system
Locales installed. Creating extension... \

Done. The extension is at /mnt/sda3/tce/optional/mylocale.tcz and in onboot.lst
Reboot with lang=xyz (for example lang=en_US.UTF-8) to start using this.


Press enter to quit.
It seems the script should error-out if it "cannot open locale archive"--as it is, the script seems to succeed in the end (causing user to interpret "cannot open locale archive" as a benign warning).
« Last Edit: February 08, 2020, 05:13:57 AM by GNUser »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11881
Re: Core v11.0beta1
« Reply #65 on: February 09, 2020, 03:11:21 AM »
mc updated in the x86 repo.

midori and spice updated in the x86_64 repo - qemu seems to work now.

Offline neonix

  • Sr. Member
  • ****
  • Posts: 273
Re: Core v11.0beta1
« Reply #66 on: February 09, 2020, 03:54:41 AM »
Now, TC11.0beta1 (x86)
There is missing dependency in mc.tcz, libgpm.so.2

There is also problem with appbrowser, when I click "Size" all extensions have zero MB.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11881
Re: Core v11.0beta1
« Reply #67 on: February 09, 2020, 04:01:19 AM »
dep file corrected