WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Core v11.0beta1  (Read 4802 times)

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Re: Core v11.0beta1
« Reply #45 on: January 31, 2020, 07:45:51 PM »
On 64 bit it's icu61.tcz, and on 32 bit it's icu62.tcz. Current version of ICU is 65. Could we get them sync'ed up to the latest version, and have the same name?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: Core v11.0beta1
« Reply #46 on: February 01, 2020, 12:49:25 AM »
Yes, at some point it will get done (after ncurses, openssl, etc)  :)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: Core v11.0beta1
« Reply #47 on: February 01, 2020, 02:45:45 AM »
We'll need the xf86-video-vmware extension at some point, soon if possible.

'not sure why they were missing - done now

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Re: Core v11.0beta1
« Reply #48 on: February 04, 2020, 02:08:17 PM »
More beta issues:

Wget needs to be recompiled against openssl-1.1.1. It currently wants 1.0, which doesn't exist and this breaks submitqc and certainly other things.
Gvim needs gnome-icon-theme.tcz. The toolbar is all placeholders without it.
This is back http://forum.tinycorelinux.net/index.php/topic,22312.msg139801.html#msg139801. This breaks open-vm-tools-desktop.
« Last Edit: February 04, 2020, 02:11:27 PM by andyj »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: Core v11.0beta1
« Reply #49 on: February 04, 2020, 11:13:38 PM »
wget reposted - one more extension where the breakage is masked by recursive deps..

adwaita-icon-theme substituted for the depreciated gnome-icon-theme

I don't see that .xsession was changed - was it the removal of "-print" in the last two lines you were looking for?

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Re: Core v11.0beta1
« Reply #50 on: February 05, 2020, 06:45:37 AM »
I don't see that .xsession was changed - was it the removal of "-print" in the last two lines you were looking for?
Yes.

I also just noticed that glibmm in the 32-bit repo is the 64-bit version, or so ld and ldd seem to think.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: Core v11.0beta1
« Reply #51 on: February 05, 2020, 06:55:58 AM »
I just downloaded glibmm from the tc-11.x x86 repo - it's 32-bit..

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Re: Core v11.0beta1
« Reply #52 on: February 05, 2020, 07:06:32 AM »
I deleted mine and redownloaded and it seems find now.  :o

Offline GNUser

  • Hero Member
  • *****
  • Posts: 539
Re: Core v11.0beta1
« Reply #53 on: February 05, 2020, 09:06:21 AM »
I noticed that the 32-bit repo has several (29) extensions that end in  -tinycore64.tcz
Is that intended?

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7783
Re: Core v11.0beta1
« Reply #54 on: February 05, 2020, 09:20:24 AM »
Hi GNUser
... Is that intended?
Yes, those are kernel modules. They are needed if you are running  Core64  (not CorePure64)  which is a 64 bit kernel with 32 bit
extensions.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 539
Re: Core v11.0beta1
« Reply #55 on: February 05, 2020, 09:34:52 AM »
Got it, thank you. I've often wondered about the significance of "Pure" in Pure64. Glad I asked :)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: Core v11.0beta1
« Reply #56 on: February 06, 2020, 04:31:09 AM »
.xsession adjusted and Xlibs reposted

Offline GNUser

  • Hero Member
  • *****
  • Posts: 539
Re: Core v11.0beta1
« Reply #57 on: February 07, 2020, 01:05:59 PM »
Hi, @andyj. I see you are the maintainer of one of my favorite extensions, rxvt.tcz

It seems that rxvt.tcz needs to be rebuilt for tc-11 because it's only able to show Unicode characters if I copy over my old mylocale.tcz extension from Pure64 10.1. Unfortunately, the old mylocale.tcz breaks some things (e.g. http://forum.tinycorelinux.net/index.php/topic,23484.msg147289.html#msg147289).

If I use the new mylocale.tcz that I generated in Pure64 v11.0beta1, no Unicode characters show up in rxvt.
« Last Edit: February 07, 2020, 01:09:50 PM by GNUser »

Offline andyj

  • Hero Member
  • *****
  • Posts: 847
Re: Core v11.0beta1
« Reply #58 on: February 07, 2020, 02:54:04 PM »
Already done. Which font are you using? Are you setting lang in the kernel command line? Remember, rxvt supports true type fonts if you have one that you know has the glyphs you need.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 539
Re: Core v11.0beta1
« Reply #59 on: February 07, 2020, 03:42:14 PM »
andyj, I set the terminal font with this in my ~/.Xdefaults:
Code: [Select]
URxvt*font: xft:Luxi Mono:pixelsize=14This font was working fine with rxvt in Pure64 10.1

I set the lang with this boot code: lang=en_US.UTF-8 (the locale in mylocale.tcz).

Is this worrisome:
Code: [Select]
$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
?

Maybe rxvt.tcz is innocent and the problem is that getlocale.tcz is not generating the locale files properly?