WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: vim.tcz missing dependency libcanberra.tcz  (Read 1314 times)

Offline andrechalella

  • WikiUser
  • *
  • Posts: 4
vim.tcz missing dependency libcanberra.tcz
« on: October 18, 2019, 01:03:29 PM »
Upon regular installation in Core Plus, vim won't run. It complains it cannot find some libcanberra file (I don't have the exact error message right now).

By loading libcanberra manually, the problem goes away.

Here is the current vim.tcz.dep:

Code: newbielink:javascript:void(0); [nonactive]
ncursesw.tcz
gvim-base.tcz

There's a 2019 bug in vim's github about it, but I think it's unrelated, because it's about "vim tiny" -- I don't think this is ours, is it? I think I can't post links, but Google "libcanberra is linked with Tiny features build #4531".

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12398
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #1 on: October 19, 2019, 01:23:13 AM »
dep file adjusted - thanks for reporting this.

Strange that the x86_64 version of vim does not need libcanberra..

Offline hiro

  • Hero Member
  • *****
  • Posts: 1152
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #2 on: October 19, 2019, 02:54:44 AM »
weeeelll, why does vim depend on gvim?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8119
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #3 on: October 19, 2019, 05:54:49 AM »
Hi hiro
weeeelll, why does vim depend on gvim?
It doesn't. It depends on  gvim-base.tcz.  From the info file:
Quote
Title:      gvim-base.tcz
Project:   vim
Description:   VI Improved text editor support files common to both console and GUI versions
Version:   8.1.1585
Author:      Bram Moolenaar <Bram@vim.org>
Original-site:   http://www.vim.org/
Copying-policy:   GPL 2
Size:      7.7M
Extension_by:    andyj
Tags:      vim vi text editor gui gtk3 console
Comments:   Supporting files for both GUI and console versions
      ----
Change-log:   2016/04/06 First version, 7.4.1721
      2016/09/18 upgraded to version 8.0.5
      2017/01/26 updated to version 8.0.0142
      2017/07/01 updated to version 8.0.0600, recompiled for TC 8.x
      2018/01/12 updated to version 8.0.1428, recompiled for TC 9.x
      2018/05/29 upgraded to version 8.1.0026, use ncursesw library
      2018/07/19 updated to version 8.1.0193
      2018/10/08 updated to version 8.1.0451
      2019/01/21 updated to version 8.1.0784, compiled for TC 10.x
      2019/05/05 updated to version 8.1.1280
Current:   2019/07/06 updated to version 8.1.1585

Offline andyj

  • Hero Member
  • *****
  • Posts: 872
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #4 on: October 19, 2019, 06:03:50 AM »
weeeelll, why does vim depend on gvim?

Gvim-base contains non-executable files common to both vim and gvim. It's platform independent apparently, when I diff the 32 and 64 bit versions I get no differences. Vim.tcz and gvim.tcz are two separate builds and extensions so that X dependencies don't get pulled into the command line version of vim. The build dependencies are: gettext, fontconfig-dev, libXft-dev, xorg-server-dev, Xorg-7.7-dev, and gtk3-dev. Libcanberra is getting pulled in because libcanberra-dev is a dependency of gtk3-dev on 32-bit TC but not 64-bit. It would seem that libcanberra would need to be a dependency of gtk3 on 32-bit.

I try to keep the extensions between 32 and 64 bit the same. A few present some challenges.

Offline hiro

  • Hero Member
  • *****
  • Posts: 1152
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #5 on: October 19, 2019, 11:23:48 AM »
so only gvim should be depending on gtk3 and thus libcanberra, right?

Offline andyj

  • Hero Member
  • *****
  • Posts: 872
Re: vim.tcz missing dependency libcanberra.tcz
« Reply #6 on: October 19, 2019, 11:51:25 AM »
Right, but I've just recompiled it and it doesn't have the libcanberra dependency anymore. I'll need to recompile the 64-bit version to be sure, then I'll submit the updated extensions.