WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Totem Player not working  (Read 1064 times)

Offline cute curtis

  • WikiUser
  • *
  • Posts: 13
  • Welcome In Da Club
Totem Player not working
« on: October 16, 2019, 01:03:10 PM »
Hello I have Sony netbook VPC115WXG PCG-4T4P running at 1.66 GHz Intel Atom N280 with Intel GMA 950 and 1G RAM.

I installed Totem player but it does not seem working or the GUI does not show at all after execution. I installed Xorg.7.7-3d together with xf86-intel, is there still any extension I need to install?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Totem Player not working
« Reply #1 on: October 16, 2019, 10:29:51 PM »
Assuming you're speaking of tc-10.x x86, the problem seems to be here:
Code: [Select]
$ totem
totem: error while loading shared libraries: libgstbasevideo-1.0.so.0: cannot open shared object file: No such file or directory

I'll take a look - it seems libgstbasevideo-1.0 became libgstbadvideo-1.0 between tc-8.x and tc-9.x
« Last Edit: October 16, 2019, 10:42:38 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Totem Player not working
« Reply #2 on: October 17, 2019, 02:12:33 AM »
clutter-gst and totem recompiled and reposted

Things seem to work now.

Offline cute curtis

  • WikiUser
  • *
  • Posts: 13
  • Welcome In Da Club
Re: Totem Player not working
« Reply #3 on: October 18, 2019, 05:23:26 AM »
Hi Juanito, did you mean you fixed the extension and I have just to redownload and install?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Totem Player not working
« Reply #4 on: October 18, 2019, 05:25:51 AM »
Affirmative - be sure to update totem and clutter-gst.

Offline cute curtis

  • WikiUser
  • *
  • Posts: 13
  • Welcome In Da Club
Re: Totem Player not working
« Reply #5 on: October 18, 2019, 08:19:20 PM »
Great, thanks! I'll feedback you what's the outcome

Offline cute curtis

  • WikiUser
  • *
  • Posts: 13
  • Welcome In Da Club
Re: Totem Player not working
« Reply #6 on: October 21, 2019, 06:55:27 PM »
Hi, I freshly installed  TC 10 with only Xorg.7.7-3D and totem as new new extensions. The GUI don't pop-up only a terminal-like window then immediately close. I also tried to right click a video file and then open with totem. The GUI shows but also immediately close.

clicking the icon:

https://ibb.co/ZMt94zG

Opening via left click context menu of video file with totem:

https://ibb.co/85tkBQn
« Last Edit: October 21, 2019, 07:25:53 PM by cute curtis »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6959
Re: Totem Player not working
« Reply #7 on: October 21, 2019, 07:07:06 PM »
Hi cute curtis
What happens if you open a terminal and enter:
Code: [Select]
totem

Offline cute curtis

  • WikiUser
  • *
  • Posts: 13
  • Welcome In Da Club
Re: Totem Player not working
« Reply #8 on: October 21, 2019, 07:26:57 PM »
Hi Rich same as the first image link and also immediately closes. I can't capture the other Windows but it's same as terminal-like blank screen. You could see the warnings below, thanks:

https://ibb.co/c3QTZX3
« Last Edit: October 21, 2019, 07:34:53 PM by cute curtis »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Totem Player not working
« Reply #9 on: October 22, 2019, 11:16:34 PM »
I just double-checked totem.

* boot to console
* load graphics-KERNEL Xorg-7.7-3d alsa-config
* load pavucontrol
* start dbus daemon
* startx
* check sound OK with pavucontrol

then:
Code: [Select]
$ totem /mnt/sdb1/media/video/video_test.mp4

(totem:10354): GLib-GObject-WARNING **: 10:11:47.991: g_object_set_is_valid_property: object class 'GstPlayBin' has no property named ''

(totem:10354): Grilo-WARNING **: 10:11:48.080: [magnatune] grl-magnatune.c:342: Plugin can't reach magnatune.com - 'Error resolving ?www.magnatune.com?: Temporary failure in name resolution'
..and video plays without problems.