WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: WiFi on Raspberry 3A+  (Read 416 times)

Offline zansara

  • WikiUser
  • *
  • Posts: 2
WiFi on Raspberry 3A+
« on: August 24, 2019, 04:01:39 PM »
I recently got a Raspberry Pi 3A+ and I tried experimenting with piCore. I managed to get it booting using one of the betas of the 10.x release (piCore-10.0beta12b: newbielink:http://tinycorelinux.net/10.x/armv7/test_relases/RPi/piCore-10.0beta12b.zip [nonactive]), but so far still no luck with the wifi.

The 3A+ model has no Ethernet, but all the guides I found on the wiki and here on the forum make use of wired connection I don't have. On the other hand, the instructions I found for Pi 0 W and similar models refer piCore v9.x, which currently doesn't boot on my Pi, and by following them I get stuck at different points:

- Not all packages requires has been ported yet ---> I fetched them from the 9.x repos

- Not all packages have been compiler for ARMv7 --> I downloaded their ARMv6 version

- tce-load -i firmware-rpi3-wireless works fine, but tce-load -i wifi.tcz fails with the message wireless-4.19.13-piCore-v7.tcz not found! and actually I can't find such package on the repos (maybe I missed it?) --> I renamed wireless-4.19.10-piCore-v7.tcz to match the requirement and seemingly it worked

- Running wifi.sh returns simply No wifi devices found! and indeed iwconfig detects no wireless interfaces :(

I believe the entire process was a desperate attempt, and anyway I got absolutely nothing working. Can anyone give me at least an hint on how to proceed? I am a newbie of piCore and TinyCore in general, but I love the concept and I would like to get it working.

Any help is really appreciated :)

Offline galinski

  • WikiUser
  • *
  • Posts: 9
Re: WiFi on Raspberry 3A+
« Reply #1 on: August 25, 2019, 11:23:26 PM »
Hi, try to use this file as your System, there you can install the Raspberry Pi ARMv7 files and use the WiFi devices (im actually using it on a Raspberry Pi 3B).
On this system you can directly load extensions from the repo for tinycore 9 and 10 (beta).

The normal tce-load is downloading files from tinycore 10 and the command tce-load9 from tinycore 9 repo.

In the worst case since some cryptography files are missing you have to install the missed_crpto-4.19.46-piCore-v7 extension.
Code: (bash) [Select]
tce-load -wi missed_crypto-4.19.46-piCore-v7.tcz
If you do not trust the file you can find further details on it here.

Kind regards
galinski
« Last Edit: August 25, 2019, 11:30:20 PM by galinski »

Offline zansara

  • WikiUser
  • *
  • Posts: 2
Re: WiFi on Raspberry 3A+
« Reply #2 on: August 26, 2019, 01:14:47 PM »
Hello galinski, thank you for your hints!
I made some progress, but it's still not working. Here is what I have done:

I downloaded the beta you pointed me to and booted successfully. Then I tried to follow the wiki's brand new tutorial on How to set up the WiFi on Pi 0 W and I downloaded the packages into tce/optional:

 - libiw libnl readline wifi wireless_tools wpa_supplicant from newbielink:http://timjanes.uk/piCore/ [nonactive]10.x/armv7/tcz/
 - firmware-rpi3-wireless was missing, so I got it from from newbielink:http://timjanes.uk/piCore/ [nonactive]9.x/armv7/tcz/
 - wireless-4.9.22-piCore was missing too, so I got it from from newbielink:http://timjanes.uk/piCore/ [nonactive]9.x/armv6/tcz/

Once the Pi booted:

Code: newbielink:javascript:void(0); [nonactive]
> tce-load -i firmware-rpi3-wireless
firmware-rpi3-wireless.tcz: OK

> tce-load -i wifi
readline.tcz: OK
libnl.tcz: OK
wpa_supplicant.tcz: OK
wireless-4.19.46-piCore-v7.tcz not fond!

Luckily wireless-4.19.46-piCore-v7.tcz seems to be available on the 10.x ARMv7 repo, so I just dowloaded it too and retried the same procedure: after that, > tce-load -i wifi works fine.

Nonetheless, running sudo wifi.sh still returns (after a few second of processing) a No wifi devices found! and iwconfig agrees there are no wireless devices. Is surely not a hardware problem because Rasbpian detected wlan0. I tried a few rebooting and the like, but seems like it won't work. Below you will find the complete output of dmesg, there might be something in I overlooked.

In addition, trying to install the missing crypto library you pointed to gave me a bizzarre error:
Code: newbielink:javascript:void(0); [nonactive]
> tce-load -i missed_crypto-4.19.46-piCore-v7.tcz
mount: mounting /dev/loop22 on /tmp/tcloop/missed_crypto-4.19.56-piCore-v7.tcz failed: Invalid argument
I downloaded the package from the 10.x ARMv7 repo.

What can I do from here? The system shows no clear error messages and simply tells me there is no wireless interface.

Thank you again for helping out so far!

Offline galinski

  • WikiUser
  • *
  • Posts: 9
Re: WiFi on Raspberry 3A+
« Reply #3 on: August 29, 2019, 11:17:00 PM »
So try the following steps:

  • clean Install of tiny core, since i do not know what is already installed
  • use tce-ab instead of tce-load (tce-ab can search for applications and install them with their dependencies, at least it tries to do so)
  • install missing packages which are not in the tinycore 10.x repo with 9.x repo (also imlemented with tce-ab9
  • test your equipment if you can connect to any devices if not, it could be that you had to load the firmware for the wifi-device manually, since i found 2 lines in your dmesg.log file which says firmware can not be loaded (failed for regulatory.db and the brcmfmac43455-sdio.bin)

The brcmfmac4345 object is probably the wifi and bluetooth device, since you can read with some imagination broadcom (brcm) and some forums are reffering to it with wifi/bluetooth problems, if it is the same  device you could follow the firmware flash steps in here.