WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: oss.tcz missing dep ?  (Read 5275 times)

Offline Pats

  • Sr. Member
  • ****
  • Posts: 322
oss.tcz missing dep ?
« on: August 17, 2019, 11:57:30 PM »
coreplus , TC10.0
In  Apps size tab of  oss.tcz  , this error message is flashed : 

** oss-modules-4.19.10-tinycore.tcz Error , not found. ** .

Is it pointing to Meta ext *original.modules.xxx.xxx.xxx.tcz* ? Meta ext is too big !  Or is it already a known error ? TC10.0

In  Apps size tab of  oss.tcz  , this error message is flashed :  ** oss-modules-4.19.10-tinycore.tcz Error , not found. ** . Is it pointing to Meta ext *original.modules.xxx.xxx.xxx.tcz* ? Meta ext is too big !  Or is it already a known error ?

Offline nick65go

  • Full Member
  • ***
  • Posts: 235
Re: oss.tcz missing dep ?
« Reply #1 on: August 18, 2019, 02:10:18 AM »
IMHO, OSS sound drivers dream si over!; I wish was not, but nobody wants to maintain it. Linux kernel is advancing so FAST, so faster changes and [by purpose introduced by kernel developers] incompatibilities. Plus main trend in pre-compiled Firefox to use only ALSA, etc.
« Last Edit: August 18, 2019, 02:12:28 AM by nick65go »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6886
Re: oss.tcz missing dep ?
« Reply #2 on: August 18, 2019, 05:20:21 AM »
Hi Pats
oss-modules-KERNEL.tcz  has been missing since TC9:
http://forum.tinycorelinux.net/index.php/topic,22608.msg141645.html

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11063
Re: oss.tcz missing dep ?
« Reply #3 on: August 18, 2019, 05:26:00 AM »
The oss modules have not been built for x86, whereas they have been built for x86_64.

See here: http://www.tinycorelinux.net/10.x/x86_64/tcz/src/oss

..if you like to build them for x86.

Offline Pats

  • Sr. Member
  • ****
  • Posts: 322
Re: oss.tcz missing dep ?
« Reply #4 on: August 18, 2019, 06:24:47 AM »
Hi nick65go , Rich and Juanito thanks. All my PCs are pure intel-based hardware, so I hardly face any drivers issues , my  ALSA is ok .
 .. My friend was fade-up with many viruses and other issues on his XP mails. So I suggested TC on his old  h/w.  I loaded his PC with older ver of  TC now with OSS . I had to train him a bit.  And he is more than happy for so fast and quick loading of TC without bloat.  He only uses mail and old music !

... By the way, I was not aware of this 32 to 64 upgrade of OSS  in latest TCs.
 Thanks ! :)

Offline nick65go

  • Full Member
  • ***
  • Posts: 235
Re: oss.tcz missing dep ?
« Reply #5 on: August 18, 2019, 09:25:04 AM »
as per my subject "oss4 not working in TC10 x64"http://forum.tinycorelinux.net/index.php/topic,22721.msg142212.html#msg142212
in TC10 x64, file /usr/sbin/vmixctl is prezent but not functional.using tce-load -i OSS-modules-4.19.10-tinycore64.tcz will issue: "Segmentation fault"