WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: $XDG_RUNTIME_DIR not set  (Read 3469 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
$XDG_RUNTIME_DIR not set
« on: August 09, 2019, 05:46:07 AM »
Hi
I had an error message when enlightenment starts, I was told that the problem is that $XDG_RUNTIME_DIR is not set apart from another problem.
If I understand well this variable should be set by the system.
dCore user

Offline GNUser

  • Full Member
  • ***
  • Posts: 140
Re: $XDG_RUNTIME_DIR not set
« Reply #1 on: August 09, 2019, 06:43:31 AM »
Hi, jls. In other OSes that variable is set at login by bloatware such as systemd or pamd. Maybe in lean-and-mean TC you need to manually export that variable somewhere at login? Try putting this in your ~/.profile (or ~/.xsession or the like), backing up your files, and rebooting:
Code: [Select]
export XDG_RUNTIME_DIR=/tmp/$(id -u)-runtime-dir
In the referenced thread below in Arch Linux forum, the problem was that a service launched at boot--psd (profile-sync-daemon) in that specific case--was unsetting the variable. If the above idea doesn't work by itself, try also booting into a bare-minimum GUI environment (X server + enlightenment + any xdg* extensions you normally load) and checking to see whether the variable is set, to exclude the possibility that some rogue TC extension in unsetting the variable.

Hope that helps.

refs:
http://forum.tinycorelinux.net/index.php/topic,18838.msg115688.html#msg115688
https://bbs.archlinux.org/viewtopic.php?id=207536
« Last Edit: August 09, 2019, 07:12:38 AM by GNUser »