WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Incorrect backup instructions in pci-utils.tcz.info in TC9 and TC10  (Read 148 times)

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6699
pci-utils.tcz is identical in TC9 and TC10 so this applies to both.

Change the line about backing up updates
From:
Code: [Select]
add usr/local/share/pci.ids.gz to your backup to keep the update
To:
Code: [Select]
add usr/local/share/hwdata/pci.ids.gz to your backup to keep the update
From lspci help:
Code: [Select]
Usage: lspci [<switches>]

 ---- SNIP ----
Other options:
-i <file>       Use specified ID database instead of /usr/local/share/hwdata/pci.ids.gz
-p <file>       Look up kernel modules in a given file instead of default modules.pcimap
-M              Enable `bus mapping' mode (dangerous; root only)
 ---- SNIP ----

From the tce-installed file:
Code: [Select]
tc@box:~$ cat /usr/local/tce.installed/pci-utils
#!/bin/sh

if [ ! -d /usr/local/share/hwdata ]; then
  mkdir -p /usr/local/share/hwdata
fi

if [ ! -f /usr/local/share/hwdata/pci.ids.gz ]; then
  cp /usr/local/share/pciutils/files/pci.ids.gz /usr/local/share/hwdata
fi
tc@box:~$

Attached is a corrected  .info  file with the correction noted in the change log.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10934
Re: Incorrect backup instructions in pci-utils.tcz.info in TC9 and TC10
« Reply #1 on: July 21, 2019, 12:35:43 AM »
info file updated - thanks  :)

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6699
Re: Incorrect backup instructions in pci-utils.tcz.info in TC9 and TC10
« Reply #2 on: July 21, 2019, 05:31:24 AM »
Hi Juanito
Trying to access:
http://tinycorelinux.net/10.x/x86/tcz/pci-utils.tcz.info
gives a  403 Forbidden  message.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10934
Re: Incorrect backup instructions in pci-utils.tcz.info in TC9 and TC10
« Reply #3 on: July 21, 2019, 05:41:20 AM »
It should be OK now