WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Ethernet doesn't get IP Address  (Read 571 times)

Offline A Guy

  • WikiUser
  • *
  • Posts: 25
Ethernet doesn't get IP Address
« on: July 10, 2019, 10:44:50 AM »
Pulled down vmlinuz-stretch64 and dCorePlus-stretch64.gz . Added them to my PXE server and booted in a virtual machine. Noticed that I didn't have an IP address.
Did this on an actual CPU and found that the same boot had an IP address.
Both will get an IP address when using the Corepure64 packages.
So :
dCoreCorepure64
VMWARE PXENo IP address acquiredIP Address acquired
CPU PXEIP Address acquiredIP Address acquired

Curious if there is some delay missing for the virtual machine not to obtain an address. The dmesg command shows that the eth device found. The device is renamed to ens33 and nothing happens after that. I mean a delay doesn't make sense , obviously everything is available for VM , but I just grasping at straws.
Tony M.
Embedded Software and BIOS Engineer

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9660
Re: Ethernet doesn't get IP Address
« Reply #1 on: July 10, 2019, 03:47:31 PM »
Hi, I do remember having to use the boot code "waitusb=5" when running dCore in Virtualbox at one point and I believe it was for the network rather than the usb device to be found. 

Offline A Guy

  • WikiUser
  • *
  • Posts: 25
Re: Ethernet doesn't get IP Address
« Reply #2 on: July 12, 2019, 07:42:50 AM »
I believe that fixed it. Now I got a pesky floppy controller not found error,but I can turn the VMs floppy on again.
Tony M.
Embedded Software and BIOS Engineer