WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Are releases backwardcompatible? can 3x extension be run on 9x?  (Read 207 times)

Offline ltrk

  • WikiUser
  • *
  • Posts: 10
I am trying to run pppsetup on 9x. It seems pppsetup, wvdial, pppd extensions are available in the 3x repo but not in the 9x repo.
So I'm wondering if can just assume that 9x will be backward compatible with previous releases and the extensions in earlier repos will work?
Also does that mean we search through earlier releases for extensions and not just browse 9x repo?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10871
Re: Are releases backwardcompatible? can 3x extension be run on 9x?
« Reply #1 on: May 31, 2019, 10:55:41 PM »
In general it is not recommended to use extensions from earlier versions of tinycore as the libraries that those extensions depend on might have been superseded by newer ones. That being said, extensions from older repos may work.

Note that there are wvdial and pppd extensions in the CorePure64 9.x and 10.x repos.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10871
Re: Are releases backwardcompatible? can 3x extension be run on 9x?
« Reply #2 on: June 01, 2019, 01:13:09 AM »
wdial added to x86 10.x repo - pppd was already in the repo.

pppsetup is a script so you should be able to run it with the current version of tinycore - you can download it here:

http://tinycorelinux.net/4.x/x86/tcz/pppsetup.tcz
http://tinycorelinux.net/4.x/x86/tcz/pppsetup.tcz.dep
http://tinycorelinux.net/4.x/x86/tcz/pppsetup.tcz.md5.txt