WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: SDL/SDL2 issues with installing Vice 3.3 commodore emulator  (Read 669 times)

Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Hi,

I'm trying to make a small install of Vice3.3 commodore 64.
Right now, I'm trying it out in Virtualbox with TinycoreV10.

Everything seems to work fine when I use the SDL dependency, but when I try
to compile Vice with SDL2 enabled, the program flashes briefly on the screen and I get the following error:
SDLVideo: Error - SDL_CreateRenderer() failed: Couldn't find matching render driver

Any suggestions?

Keeping in mind I'm still very much a noob: as a summary, I do the following in a new virtualbox machine:

- Install TC10 to a new machine
- Install the following dependencies:
    - alsa-config
    - alsa-dev
    - alsa
    - libpng-bin
    - libpng-dev
    - libpng
    - compiletc
    - SDL
    - SDL-dev
    - readline
    - readline-dev
    - SDL2
    - SDL2-dev

download xa-2.3.9, unzip into a folder
download the tarball vice-3.3, unzip into a folder

- in a terminal window, I start up Alsa by the following command: alsactl init
   I compile xa-2.3.9 by "make" followed by "sudo make install"
   I compile vice-3.3 by the following commands
     "./configure --enable-sdlui"   (for SDL)
     "./configure --enable-sdlui2"   (for SDL2)
     "make"
     "sudo make install"

when I enter X64 to start the emulator, it runs fine with SDL,
but when I compile it with SDL2 (which apparently has better graphics), I get the following error
"SDLVideo: Error - SDL_CreateRenderer() failed: Couldn't find matching render driver"

Thanks so much in advance for any ideas I could try!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10957
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #1 on: May 24, 2019, 10:24:30 AM »
Did you have both SDL-dev and SDL2-dev loaded at the same time?

If not that, maybe you need sdl2_image-dev?

Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #2 on: May 25, 2019, 02:51:56 PM »
No, only the SDL2-dev was loaded.
I just tried with sdl2_image-dev, and unfortunately had the same error:

SDLVideo: Error - SDL_CreateRenderer() failed: Couldn't find matching render driver

Is it possible that it could be a setting in Virtualbox?

Thank you so much for your help.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10957
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #3 on: May 25, 2019, 10:34:51 PM »
I gave things a go on real hardware and it appears to work:
Code: [Select]
$ x64
...
Drive: Finished loading ROM images.
Sound: Available sound devices: alsa uss sdl dummy fs dump wav voc iff aiff soundmovie
SDLJoystick: No joysticks found
SDLKeyboard: Loading hotkey map `/usr/local/lib/vice/C64/sdl_hotkeys.vkm'.
SDLKeyboard: Warning - Failed to open `/home/tc/.config/vice/sdl-hotkey-C64.vkm'.
Keyboard: Loading keymap `/usr/local/lib/vice/C64/sdl_sym.vkm'.
SDLVideo: Available Renderers: opengl opengles2 opengles software
SDLVideo: SDL2 renderer driver selected: opengl

SDLVideo: VICII (active) 768x544 32bpp
Main CPU: starting at ($FFFC).
Main CPU: RESET.
ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
Playback open error for 'default': No such file or directory
Drive 8: RESET.
..(the alsa error is due to analogue sound not being the default) and I get the "64k ram system 39811 basic bytes free - ready" prompt.


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6758
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #4 on: May 26, 2019, 04:59:23 AM »
Hi Joey_Joejoe
No, only the SDL2-dev was loaded.
I just tried with sdl2_image-dev, and unfortunately had the same error:

SDLVideo: Error - SDL_CreateRenderer() failed: Couldn't find matching render driver
Maybe you need to run  ./configure --enable-sdlui2  again after installing  sdl2_image-dev.

Quote
Is it possible that it could be a setting in Virtualbox?
The quickest way to find out would be to try it without  virtualbox.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10957
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #5 on: May 26, 2019, 05:44:17 AM »
sdl2_image-dev is not required - vice builds and runs on real hardware without it

Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #6 on: May 27, 2019, 04:36:14 AM »
You're the best!
Thanks for the help, I'll try it out on a USB.

Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #7 on: June 05, 2019, 06:54:40 AM »
OK, So I've got Vice running on a machine (with GTK3 GUI instead of SDL2) using the following dependencies:
    - alsa-config
    - alsa-dev
    - alsa
    - libpng-bin
    - libpng-dev
    - libpng
    - compiletc

    - readline
    - readline-dev


Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #8 on: June 05, 2019, 07:01:34 AM »
sorry ... continued ...
    - alsa-config
    - alsa-dev
    - alsa
    - libpng-bin
    - libpng-dev
    - libpng
    - compiletc
    - GTK3-dev
    - GTK3
    - readline
    - readline-dev
    - bash

and I was thinking of creating a squashed extension and submitting it for posting.

It's not super clear from the wiki, but ...

I know not to include compileTC, but do I include any of the above dependencies into the squishy file?
Or, are they linked via the dependency list that goes along with the submission?

Basically, if someone downloads vice, I want to know if alsa is automatically downloaded along with Vice, or do I have to include it in the Vice.tcz app?

Hope this makes sense!
Thanks,
Joey

« Last Edit: June 05, 2019, 07:06:20 AM by Joey_Joejoe »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6758
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #9 on: June 05, 2019, 07:19:37 AM »
Hi Joey_Joejoe
You don' need the  -dev  files or  compiletc  to run  Vice,  only to build it. AS near as I can, your dependencies look like this:

Run dependencies:
Code: [Select]
alsa-config
alsa
libpng-bin
GTK3
bash
readline  gets pulled in by  bash.  libpng  gets pulled in by  libpng-bin.

Build dependencies:
Code: [Select]
alsa-config
alsa-dev
compiletc
GTK3-dev
readline-dev

The  run dependencies  would be listed in your  vice.tcz.dep  file, not packaged with the app.

Offline Joey_Joejoe

  • WikiUser
  • *
  • Posts: 9
Re: SDL/SDL2 issues with installing Vice 3.3 commodore emulator
« Reply #10 on: June 05, 2019, 07:35:04 AM »
Perfect, I've enjoyed learning about Linux and Tinycore.
Thanks for the help Rich!
« Last Edit: June 05, 2019, 07:36:55 AM by Joey_Joejoe »