WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: dbxcli cert problem  (Read 255 times)

Offline DrRob

  • WikiUser
  • *
  • Posts: 44
dbxcli cert problem
« on: May 19, 2019, 02:49:04 AM »
Hi,

I'm trying to use https://github.com/dropbox/dbxcli on piCore, but when I run ./dbxcli-linux-arm account to set it up and enter the auth code as instructed, it says, "Error: Post https://api.dropboxapi.com/1/oauth2/token: x509: certificate signed by unknown authority".

dbxcli is a Go application.  I see here: https://golang.org/src/crypto/x509/root_unix.go that Go apps don't look for certs in /usr/local/etc/ssl so I tried copying /usr/local/etc/ssl/certs to /etc/ssl/ but that made no difference.

Any ideas?

Thanks,
Rob.

Offline DrRob

  • WikiUser
  • *
  • Posts: 44
Re: dbxcli cert problem
« Reply #1 on: May 19, 2019, 03:28:31 AM »
ps. I've tried the same dbxcli binary under Raspbian and it works fine.

Offline DrRob

  • WikiUser
  • *
  • Posts: 44
Re: dbxcli cert problem
« Reply #2 on: May 19, 2019, 03:33:20 AM »
Aha - I made it work by copying the whole of the /etc/ssl/certs/ directory from Raspbian into piCore.

What's the correct way to fix this?

Offline DrRob

  • WikiUser
  • *
  • Posts: 44
Re: dbxcli cert problem
« Reply #3 on: May 19, 2019, 03:56:20 AM »
I can also fix it by doing this:

Code: [Select]
sudo mkdir /etc/pki/tls
sudo ln -s /usr/local/etc/pki/certs /etc/pki/tls

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 479
Re: dbxcli cert problem
« Reply #4 on: May 19, 2019, 04:50:58 AM »
Yes, some programs have the cert location hardcoded to /etc/ssl.   Making the link is your best option