WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: asunder.dep has extra chars (at end of line) so asunder.tcz does not load  (Read 460 times)

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
in TC10 x64, asunder.dep has
asunder.tcz
   gtk2.tcz <-here
   libcddb.tcz <-here
   cdparanoia.tcz <-here
   lxde-icon-theme.tcz<-here

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6722
Hi nick65go
The  http://tinycorelinux.net/10.x/x86_64/tcz/asunder.tcz.dep  file looks fine to me:
Code: [Select]
gtk2.tcz
libcddb.tcz
cdparanoia.tcz
lxde-icon-theme.tcz

What you are showing is the  http://tinycorelinux.net/10.x/x86_64/tcz/asunder.tcz.tree  file.
Code: [Select]
asunder.tcz
   gtk2.tcz
   libcddb.tcz
   cdparanoia.tcz
   lxde-icon-theme.tcz
And I don't see any extra characters at the end of the lines.
« Last Edit: May 11, 2019, 06:25:55 AM by Rich »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6722
Hi nick65go
I think I might know what's wrong. The last line in the  .dep  file (lxde-icon-theme.tcz) is missing a carriage return. Try adding a
carriage return to the last line in your  tce/optional/asunder.tcz.dep  file and see if that fixes your problem.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10944
The dep file on the server looks OK..

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Thanks Rich, I could manage myself to correct the *dep file. I tried to help other TC users :)
I did not used any desktop manager like LXDE, just simple flwm.
the asunder.dep 'looks' OK, but it is NOT. please try youself to see from default TC Apps fltk utility.
it is an 'invisible' char, like lower case R (|-).
« Last Edit: May 11, 2019, 08:06:09 AM by nick65go »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6722
Hi nick65go
I just downloaded the file and you are correct. Someone edited the file with a Windows compatible editor. There are
CR LF  sequences terminating the lines. Running  dos2unix  on the file will fix it.

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
after manual editing of asunder.tcz.dep, then missing md5 for asunder...
Code: [Select]
tc@box:~$ tce-load -w asunder
asunder.tcz.dep OK
Downloading: lxde-icon-theme.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 400 Bad Request
.md5.txt: No such file or directory
Error on lxde-icon-theme.tcz

even after using apps to load it
Code: [Select]
tc@box:~$ tce-load -wi lxde-icon-theme.tcz
lxde-icon-theme is already installed!
« Last Edit: May 11, 2019, 09:02:03 AM by nick65go »

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
finally, i cheated, using wget, as a temporary solution:
Code: [Select]
tc@box:~$ wget http://repo.tinycorelinux.net/10.x/x86_64/tcz/asunder.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
asunder.tcz          100% |********************************| 73728  0:00:00 ETA
tc@box:~$

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6722
Hi nick65go
Maybe when you executed:
Code: [Select]
tc@box:~$ tce-load -w asunderit read the  .dep  file from the repository again with the extra  CR  characters.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10944
dep file fixed on the server