WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: MicroCore Manual Install - GRUB not finding files  (Read 720 times)

Offline lawrenced1

  • WikiUser
  • *
  • Posts: 6
MicroCore Manual Install - GRUB not finding files
« on: May 03, 2019, 02:53:24 PM »
Hello all,

I've come back to a project that uses TinyCore. I am in the process of creating an TCL dev box inside a VirtualBox VM. I have created scripts to automate the installation of the core to the VM hard drive (along with other steps). The script follows the instructions posted on installing TCL manually located here on the install_manual.html page

Since my script was failing I'm doing each step one at a time.  When I get to the point of setting up GRUB on the drive I type (after I create the /boot/grub/menu.lst):

Code: (bash) [Select]
sudo grub
root (hd0,0)
setup (hd0)

When I hit enter after the setup (hd0) I get:
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 15: File not found


I only have one drive with one partition.

Outside of the GRUB command line I can see the files I copied under /mnt/sda1/boot/grub and stage1 exists there along with other files.

I spent the day looking for a fix and I haven't found anything worthwhile. I wanted to post here if any has a solution or workaround.

I'm running Oracle VirtualBox 6.0.6 (updated 2019/05/03)
VM is configured for
  • Linux 2.6 / 3.x / 4.x (32-bit)
  • 1024MB RAM
  • IDE Controller for Core-current.iso
  • SATA Controller for 512MB VirtualDisk (I've tried the IDE controller and 4GB and 8GB sized disks
  • NAT

I'm sure something has changed since I did this project in 2017. I can't find anything that talks about GRUB not able to find it's files once root has been set. I've seen posts about a corrupted GRUB but this is at the point of installation.

Any insight is greatly appreciated.

Thanks.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: MicroCore Manual Install - GRUB not finding files
« Reply #1 on: May 03, 2019, 04:25:16 PM »
Hi

Not sure if this is your issue,  but grub legacy uses stage1.   This error is common if you previously used grub legacy then installed grub2, as remnants of grub legacy often interferes with the latest grub2

Grub root refers to the grub installation files
Eg: /boot   


Sent from my iPhone using Tapatalk

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10049
Re: MicroCore Manual Install - GRUB not finding files
« Reply #2 on: May 04, 2019, 02:53:34 AM »
Some of the commands have tab-completion. You could try that to see what files grub sees. Maybe there's another disk, etc.
The only barriers that can stop you are the ones you create yourself.

Offline lawrenced1

  • WikiUser
  • *
  • Posts: 6
Re: MicroCore Manual Install - GRUB not finding files
« Reply #3 on: May 04, 2019, 06:44:20 AM »
The install is fresh and I'm tce-load[ing] the grub-0.97-splash files so I can type the grub command. I then copy the grub files from the CD image Current-core. Does this mix the two? grub1 and grub2?

The tab auto-complete only shows the one drive (hd0) when filling in the command. I admit it has been rough trying to figure out how grub sees devices.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: MicroCore Manual Install - GRUB not finding files
« Reply #4 on: May 04, 2019, 07:42:22 AM »
The current Tinycorelinux iso doesn’t use grub at all,  it uses isolinux

What you should do is boot the Tinycorelinux current ISO. Download from the repo and run grub legacy (if that’s your preference)  to install to your virtual drive, then boot it.


Sent from my iPhone using Tapatalk

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10049
Re: MicroCore Manual Install - GRUB not finding files
« Reply #5 on: May 04, 2019, 09:12:49 AM »
I mean some of the file commands. Going from memory, maybe it had "cat" or similar, which would tab-complete the files available after running root().
The only barriers that can stop you are the ones you create yourself.

Offline lawrenced1

  • WikiUser
  • *
  • Posts: 6
Re: MicroCore Manual Install - GRUB not finding files
« Reply #6 on: May 07, 2019, 12:17:47 PM »
Thank you all for your help.

I have finally gotten it to work.

In my steps I replaced the command to format the filesystem with a 4 instead of a 3. So my command was

Code: (bash) [Select]
mkfs.ext4 /dev/sda
and it should have been

Code: (bash) [Select]
mkfs.ext3 /dev/sda
Once I had formatted my drive with ext3 instead of ext4 grub started working. I did something dangerous and assumed ext4 would be the better filesystem since it is the most recent.

I hope others will be able to see the post and check what filesystem they are using and that might be the solution.

Thanks again.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6906
Re: MicroCore Manual Install - GRUB not finding files
« Reply #7 on: May 07, 2019, 01:14:38 PM »
Hi lawrenced1
... Once I had formatted my drive with ext3 instead of ext4 grub started working. I did something dangerous and assumed ext4 would be the better filesystem since it is the most recent. ...
I run  grub-0.97  and one of my machines uses  EXT4.  Is it possible  VirtualBox  is causing the problem?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10049
Re: MicroCore Manual Install - GRUB not finding files
« Reply #8 on: May 08, 2019, 12:03:11 AM »
Could also be a recent-ish ext4 new feature. Grub legacy does support ext4, but the patch is a few years old, so if mkfs.ext4 now uses some new ext4 feature, grub may not recognize it.
The only barriers that can stop you are the ones you create yourself.

Offline lawrenced1

  • WikiUser
  • *
  • Posts: 6
Re: MicroCore Manual Install - GRUB not finding files
« Reply #9 on: May 08, 2019, 06:24:45 AM »
VirtualBox very well could be the problem, but I don't have another VM program to run. Any suggestions other than Oracle's VirtualBox and VMWare (which it requires a license now right?)?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11068
Re: MicroCore Manual Install - GRUB not finding files
« Reply #10 on: May 08, 2019, 07:47:34 AM »
qemu?