WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: modprobe: can't load module igb (kernel/drivers/net/ethernet/intel/igb/igb.ko.gz  (Read 328 times)

Offline halma

  • Full Member
  • ***
  • Posts: 145
hi

i run TC 4.19.10 i686 and i have an intel card inside but the driver wont load. if i try to load the driver with modprobe. an error comes:

Code: [Select]
sudo modprobe igb
modprobe: can't load module igb (kernel/drivers/net/ethernet/intel/igb/igb.ko.gz): unknown symbol in module, or unknown parameter

Code: [Select]
sudo modprobe igb
modprobe: can't load module igb (kernel/drivers/net/ethernet/intel/igb/igb.ko.gz): unknown symbol in module, or unknown parameter
Code: [Select]
modinfo igb
filename:       /lib/modules/4.19.10-tinycore/kernel/drivers/net/ethernet/intel/igb/igb.ko.gz
author:         Intel Corporation, <e1000-devel@lists.sourceforge.net>
description:    Intel(R) Gigabit Ethernet Network Driver
license:        GPL
parm:           debug:Debug level (0=none,...,16=all)
parm:           max_vfs:Maximum number of virtual functions to allocate per physical function
version:        5.4.0-k
alias:          pci:v00008086d000010D6sv*sd*bc*sc*i*
alias:          pci:v00008086d000010A9sv*sd*bc*sc*i*
alias:          pci:v00008086d000010A7sv*sd*bc*sc*i*
alias:          pci:v00008086d000010E8sv*sd*bc*sc*i*
alias:          pci:v00008086d00001526sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Dsv*sd*bc*sc*i*
alias:          pci:v00008086d000010E7sv*sd*bc*sc*i*
alias:          pci:v00008086d000010E6sv*sd*bc*sc*i*
alias:          pci:v00008086d00001518sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Asv*sd*bc*sc*i*
alias:          pci:v00008086d000010C9sv*sd*bc*sc*i*
alias:          pci:v00008086d00000440sv*sd*bc*sc*i*
alias:          pci:v00008086d0000043Csv*sd*bc*sc*i*
alias:          pci:v00008086d0000043Asv*sd*bc*sc*i*
alias:          pci:v00008086d00000438sv*sd*bc*sc*i*
alias:          pci:v00008086d00001516sv*sd*bc*sc*i*
alias:          pci:v00008086d00001511sv*sd*bc*sc*i*
alias:          pci:v00008086d00001510sv*sd*bc*sc*i*
alias:          pci:v00008086d00001527sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Esv*sd*bc*sc*i*
alias:          pci:v00008086d00001524sv*sd*bc*sc*i*
alias:          pci:v00008086d00001523sv*sd*bc*sc*i*
alias:          pci:v00008086d00001522sv*sd*bc*sc*i*
alias:          pci:v00008086d00001521sv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Csv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Bsv*sd*bc*sc*i*
alias:          pci:v00008086d00001538sv*sd*bc*sc*i*
alias:          pci:v00008086d00001537sv*sd*bc*sc*i*
alias:          pci:v00008086d00001536sv*sd*bc*sc*i*
alias:          pci:v00008086d00001533sv*sd*bc*sc*i*
alias:          pci:v00008086d00001539sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F45sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F41sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F40sv*sd*bc*sc*i*
srcversion:     B3AFFBD06E2D8395E4C596B
depends:        ptp,i2c-algo-bit
intree:         Y
vermagic:       4.19.10-tinycore SMP mod_unload 486

and dmesg says:
Code: [Select]
igb: Unknown symbol i2c_bit_add_bus (err -2)

whats wrong ? how can i get the card to work?
thanks
« Last Edit: April 27, 2019, 04:01:54 AM by halma »
1 + 2 = 6  cause  10 - 6 = 78 ;-) lol

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10934
Code: [Select]
depends:        ptp,i2c-algo-bit
Is the i2c-KERNEL extension loaded?
« Last Edit: April 27, 2019, 04:28:19 AM by Juanito »

Offline halma

  • Full Member
  • ***
  • Posts: 145
Hi Juanito :-)

this is what lsmod says:

Code: [Select]
Module                  Size  Used by    Not tainted
cpufreq_userspace      12288  0
cpufreq_conservative    12288  0
cpufreq_powersave      12288  0
fujitsu_laptop         12288  0
sparse_keymap          12288  1 fujitsu_laptop
video                  28672  1 fujitsu_laptop
backlight              12288  2 fujitsu_laptop,video
pcspkr                 12288  0
xhci_pci               12288  0
xhci_hcd               86016  1 xhci_pci
squashfs               28672  0
zstd_decompress        53248  1 squashfs
xxhash                 16384  1 zstd_decompress
loop                   20480  0
ptp                    16384  0
pps_core               12288  1 ptp
r8169                  49152  0
acpi_cpufreq           12288  0

Code: [Select]
sudo modprobe i2c-algo-bit
modprobe: module i2c-algo-bit not found in modules.dep
1 + 2 = 6  cause  10 - 6 = 78 ;-) lol

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10934
You need:
Code: [Select]
$ tce-load -i i2c-KERNEL

Offline halma

  • Full Member
  • ***
  • Posts: 145
thanks a lot Juanito, i found this -> http://forum.tinycorelinux.net/index.php?topic=18469.0
and now i not going the tinycoreway cause the machine has no internet access in this state,
i download the http://tinycorelinux.net/10.x/x86/tcz/i2c-4.19.10-tinycore.tcz, extracted core.gz
created /mnt/tce/optional and put into the optional directory the file "i2c-4.19.10-tinycore.tcz".
then rebuild the core.gz
After Tinycore hase booted successfull from PXE-Boot. i do "tce-load -i /mnt/tce/optional/i2c-4.19.10-tinycore.tcz"
and then sudo modprobe igb... now the networkcard works :-)

thanks a lot
1 + 2 = 6  cause  10 - 6 = 78 ;-) lol