WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xfbdev native resolution with TC64 found!  (Read 1234 times)

Offline PDP-8

  • Sr. Member
  • ****
  • Posts: 469
Xfbdev native resolution with TC64 found!
« on: May 31, 2019, 01:42:30 AM »
On some hardware, it appears that while successul in booting ver 10 of TC64 in UEFI, I had no control over the video resolution.

Most of the other computer hardware dutifully booted to native res, but not this one box - (an Intel Computestick), and very limited ability in UEFI to trick it.

Solution:  (actually found from a 2011 or so post waaaaay back:

I just forced native resolution and color depth in my grub.cfg file by adding a line to the TC and TCW menu entries:

Code: [Select]
.
.
.
set gfxpayload=1920x1080x24
}

Note: I only put this into the graphical menu items, TC and TCW.  I did not put this into CORE or COREW, since at my native resolution, those fonts for text-mode only operation are just, um too tiny for me to see! :)

Totally stoked!  Failure was not an option.  TC64 just *had* to run on this box, and look good doing so.  Thanks again guys - awesome.
« Last Edit: May 31, 2019, 02:10:41 AM by PDP-8 »
That's a UNIX book! - cool  -- Garth

Offline PDP-8

  • Sr. Member
  • ****
  • Posts: 469
Re: Xfbdev native resolution with TC64 found!
« Reply #1 on: June 20, 2019, 10:53:25 PM »
Aha!  But what if even this doesn't seem to work?

Got that one crazy box, that even though set for UEFI only, still does not come up in native resolution, AND ignores your attempts to force it via syslinux or even grub commands as shown above??

The *real* fix, I think is to load the graphics-4.19.10-tinycore64.tcz (or whatever is appropriate later) and make it onboot.  It works for me as the last thing in my onboot.lst.

By having graphics-<kernel> loaded, I was able to actually remove my gfxpayload= command from grub, and the system came up in native res.

Note that this worked without me going into a full-on xorg environment, just the tiny-x Xfbdev server.

Moral - if native res is what you are after, and manual kernel parameter line options still don't seem to have any effect, try installing the graphics-<kernel> tcz.  Last.

« Last Edit: June 20, 2019, 10:55:47 PM by PDP-8 »
That's a UNIX book! - cool  -- Garth