WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: can not send Mail attachment with Firefox webmail  (Read 657 times)

Offline chattrhand

  • Full Member
  • ***
  • Posts: 100
can not send Mail attachment with Firefox webmail
« on: April 14, 2019, 04:11:42 AM »
Hello TinyCoreTeam,

actually I'm running TinyCore-10.0 with Firefox-66.0.3 (the latest one, over  firefox_getLatest)

My preferred mail provider is  www.posteo.de  (they use PerfectForwardSecrecy PFS).

When I start  posteo.de with my mail address, add a receiver mail address and some text and click the tab to attach a file, then firefox closes immediately all of the firefox windows that are open at same time.

Other programs are not affected.

The download of Mails attachments from posteo.de however works fine. (even with AddOns like eMatrix et al)

With other email providers like  www.freenet.de  firefox sends eMails with attachments and no problems.

 posteo forbids a list of Win executable file types, but I do not even come so far.

The palemoon browser on TinyCore is a replacement for sending eMails with attachments.

Firefox-66.0.3 on a daily updated Manjaro also allows mail attachments over  posteo.de.

To avoid cross reactions I took a naked TinyCore-10.0 installation with all of the actual updates and only downloaded and ran firefox_getLatest to have a fresh firefox-66.0.3. The same result: Open firefox, open posteo.de, click on the [Attach file...] tab,- crash.

TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline gwalther

  • Full Member
  • ***
  • Posts: 128
Re: can not send Mail attachment with Firefox webmail
« Reply #1 on: April 14, 2019, 05:16:17 AM »
Had similar problem with FF 64 and gmail attachments.  At suggestion of moderator, switched from xvesa to xorg and problem with attachments went away.  Are you using xvesa?  If so suggest you try using xorg. 

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10963
Re: can not send Mail attachment with Firefox webmail
« Reply #2 on: April 14, 2019, 05:36:16 AM »
Start firefox from a terminal window to see if you get an error message

Offline chattrhand

  • Full Member
  • ***
  • Posts: 100
Re: can not send Mail attachment with Firefox webmail
« Reply #3 on: April 16, 2019, 01:35:34 AM »
Hi Juanito, this is my Terminal answer:

In a recent firefox call I had permanently allowed NoScript to run the posteo.de scripts.

Now I've opened firefox by Terminal. (same with or without -private-window)


Code: [Select]
tc@box:~$ firefox -private-window www.posteo.de
Xlib:  extension "XInputExtension" missing on display ":0.0".
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Xlib:  extension "XInputExtension" missing on display ":0.0".

(firefox:9940): Gdk-ERROR **: The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 13505 error_code 2 request_code 139 (RENDER) minor_code 34)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
ExceptionHandler::GenerateDump cloned child 10185ExceptionHandler::WaitForContinueSignal waiting for continue signal...

ExceptionHandler::SendContinueSignalToChild sent continue signal to child
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Trace/breakpoint trap
tc@box:~$ Xlib:  extension "XInputExtension" missing on display ":0.0".
Xlib:  extension "XInputExtension" missing on display ":0.0".
Xlib:  extension "XInputExtension" missing on display ":0.0".


At this point Firefox crashed.
[Enter] in the Terminal,- finished.

tc@box:~$

Thanks for your help!

    [EDIT]: Added code tags.  Rich
« Last Edit: April 16, 2019, 05:46:47 AM by Rich »
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10963
Re: can not send Mail attachment with Firefox webmail
« Reply #4 on: April 16, 2019, 01:37:29 AM »
You need to use Xorg-7.7

Offline chattrhand

  • Full Member
  • ***
  • Posts: 100
installed Xorg-7.7.tcz
« Reply #5 on: April 16, 2019, 05:58:27 AM »
this indeed helps to send mails with attachments using FF and posteo.de.

However, now I fall back from DE keyboard to US keyboard. (this is bad for entering passwords)

I created a fresh tinycore installation, (no browser installed)
started it, downloaded  alsa-config.tcz and alsa.tcz, checked alsamixer to unmute the sound,
modified /opt/bootlocal.sh and /home/tc/.xsession and /home/tc/.X.d/autostart to have DE keyboard and sound check,
did an update with the Apps Browser,
after a restart the sound was ok and the keyboard was DE.

After installing Xorg-7.7.tcz  the sound is ok but the keyboard falls back to US.
additional: Keys F1, F2 ... do not work.

that's the actual state.
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6771
Re: can not send Mail attachment with Firefox webmail
« Reply #6 on: April 16, 2019, 06:16:48 AM »
Hi chattrhand
Please use  Code Tags  when posting commands and responses seen in a terminal. To use  Code Tags  click on the  #  icon
above the reply box and paste your text between the  Code Tags  as shown in this example:

Quote
[code ][   36.176529] pcm512x 1-004d: Failed to get supply 'AVDD': -517
[   36.176536] pcm512x 1-004d: Failed to get supplies: -517
[   36.191753] pcm512x 1-004d: Failed to get supply 'AVDD': -517[/code ]
Please note that  Code Tags  don't actually have a space between the  e  and  ]  characters. This was done here so that they
would be visible rather than executed by the browser.

Code Tags  serve as visual markers between what you are trying to say and the information you are posting. They also preserve
spacing so column aligned data displays properly.

... After installing Xorg-7.7.tcz  the sound is ok but the keyboard falls back to US.
additional: Keys F1, F2 ... do not work. ...
See if this thread has any useful information:
http://forum.tinycorelinux.net/index.php/topic,22592.msg141532.html#msg141532

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6771

Offline chattrhand

  • Full Member
  • ***
  • Posts: 100
Re: can not send Mail attachment with Firefox webmail
« Reply #8 on: April 17, 2019, 02:14:42 PM »
Thank you Rich,

this step by step introduction helped very much.

With Xorg7.7.tce the desktop looks slightly different, but it works.

The bootcode for adjusting the german keyboard has migrated from /opt/bootlocal.sh  to a manual action.
I hope I get it back there.

Thanks and happy Easter holidays
TinyCore, SliTaz, LinuxMint, Tails, Mac ...