WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Skype outdated and cannot connect  (Read 3539 times)

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #15 on: April 30, 2019, 05:16:58 PM »
I made a copy of gconf for TCL 8.x a while back to get chrome working. You can try this one: http://www.asjohnson.com/tinycorelinux/8.x/x86_64/test/GConf.tcz

Thankyou, but I think that your extension has a lot of files unneeded, instead what I did is uncompress only the needed library and place it on the same dir on the skype binary

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #16 on: April 30, 2019, 07:14:07 PM »
Well, I think I am in the right way, now the thing is related to permissions

I modified skypeforlinux.desktop to add /local/ to the Exec parameter

and then moved all the files in /usr to /usr/local and then redid the mksquash process

now I have the "Skype" item in apps menu, but attempting to launch it does anything, in the log file shows:

Code: [Select]
nohup: can't execute '/tmp/tcloop/usr/local/share/skypeforlinux/skypeforlinux': Permission denied

doing a ls to the binary says this

Code: [Select]
tc@box:~$ ls -la /usr/local/share/skypeforlinux/skypeforlinux
lrwxrwxrwx 1 root root 69 Apr 30 19:58 /usr/local/share/skypeforlinux/skypeforlinux -> /tmp/tcloop/usr/local/share/skypeforlinux/skypeforlinux

My guess is about the owner of the file, but don't know exactly what to do

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12388
Re: Skype outdated and cannot connect
« Reply #17 on: April 30, 2019, 10:29:19 PM »
If you've named your extension "skype", then the command needed to check the permissions would be:
Code: [Select]
$ ls -la /tmp/tcloop/skype/usr/local/share/skypeforlinux/skypeforlinux

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #18 on: April 30, 2019, 11:19:07 PM »
If you've named your extension "skype", then the command needed to check the permissions would be:
Code: [Select]
$ ls -la /tmp/tcloop/skype/usr/local/share/skypeforlinux/skypeforlinux

Sorry, I did a mistake because I copied manually the path and missed the extension name, the right path is

Code: [Select]
/tmp/tcloop/skypeforlinux/usr/local/share/skypeforlinux/skypeforlinux
and doing a ls to the tcz

Code: [Select]
tc@box:~$ ls -la /tmp/tcloop/skypeforlinux/usr/local/share/skypeforlinux/skypeforlinux
-rw-r--r-- 1 197611 197121 81125488 Oct 12 2018 /tmp/tcloop/skypeforlinux/usr/local/share/skypeforlinux/skypeforlinux
« Last Edit: April 30, 2019, 11:23:48 PM by julcar »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12388
Re: Skype outdated and cannot connect
« Reply #19 on: April 30, 2019, 11:40:04 PM »
That file should be root:root and executable.

Did you unpack the deb as root?

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #20 on: April 30, 2019, 11:43:18 PM »
That file should be root:root and executable.

Did you unpack the deb as root?

No, I did the whole process in windows XP, I uncompressed the deb file with 7zip and created the extension with a windows version of mksquashfs

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12388
Re: Skype outdated and cannot connect
« Reply #21 on: April 30, 2019, 11:53:44 PM »
You need to unpack the deb in linux:
Code: [Select]
$ sudo ar vx skypeforlinux-64.deb
$ sudo tar xf data.tar.xz
$ ls -l /tmp/pkg/usr/local/share/skypeforlinux/skypeforlinux
-rwxr-xr-x    1 root     root      81125488 Oct 12  2018 /tmp/pkg/usr/local/share/skypeforlinux/skypeforlinux
« Last Edit: May 01, 2019, 01:37:56 AM by Juanito »

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #22 on: May 01, 2019, 12:54:42 PM »
Ok, the permission denied error is gone, but still don't want to run, is very weird this

Offline andyj

  • Hero Member
  • *****
  • Posts: 869
Re: Skype outdated and cannot connect
« Reply #23 on: May 01, 2019, 01:09:19 PM »
64-bit executables copied from other distros typically want files in /lib64. Try:

Code: [Select]
ldd /path/to/skypeforlinux | grep /ld-

and see what it's looking for. You may need to create a link to /lib/ld-2.28.so for it.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12388
Re: Skype outdated and cannot connect
« Reply #24 on: May 01, 2019, 10:42:45 PM »
Even if you symlink /lib64 -> /lib, the latest skypeforlinux will fail with:
Code: [Select]
dbus[10875]: dbus message iterator has already been closed, or is uninitialized or corrupt
Apparently this is because skypeforlinux now depends on systemd - google indicates that versions 8.29.76.43 and 8.29.0.50 do not require systemd if you can find them somewhere...

Offline mocore

  • Sr. Member
  • ****
  • Posts: 263
  • ~.~
Re: Skype outdated and cannot connect
« Reply #25 on: May 02, 2019, 12:42:46 AM »
skypeforlinux now depends on systemd

this could be relevant ?
https://forums.gentoo.org/viewtopic-t-1086741-start-0.html - skypeforlinux 8.30.0.50 segfaults with dbus
Quote
it does look like systemd or OpenRC+elogind could be required for >skypeforlinux-8.29.0.50.


Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #26 on: May 03, 2019, 03:53:14 AM »
Even if you symlink /lib64 -> /lib, the latest skypeforlinux will fail with:
Code: [Select]
dbus[10875]: dbus message iterator has already been closed, or is uninitialized or corrupt
Apparently this is because skypeforlinux now depends on systemd - google indicates that versions 8.29.76.43 and 8.29.0.50 do not require systemd if you can find them somewhere...

I guess I have now the correct tcz extension for skype, but it doesn't go further than the same error message

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #27 on: May 03, 2019, 04:07:54 AM »
Here are some skype deb packages, including the 8.29.0.50 version
http://mirror.cs.uchicago.edu/skype/pool/main/s/skypeforlinux/

Offline julcar

  • Jr. Member
  • **
  • Posts: 76
Re: Skype outdated and cannot connect
« Reply #28 on: May 04, 2019, 01:28:09 PM »
Here are some skype deb packages, including the 8.29.0.50 version
http://mirror.cs.uchicago.edu/skype/pool/main/s/skypeforlinux/

this version does not run because an error "No such file or directory" even when ldd says all the dependencies are in place, gonna try with another version

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12388
Re: Skype outdated and cannot connect
« Reply #29 on: May 04, 2019, 10:53:51 PM »
Did you remember to make the symlink /lib64 -> /lib?