WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Video Xsetup problems IBM 760XL  (Read 455 times)

Offline Cometphoton

  • WikiUser
  • *
  • Posts: 5
Video Xsetup problems IBM 760XL
« on: March 14, 2019, 08:23:34 AM »
Hardware: IBM 760XL Laptop

Intel Pentium MMX 166 MHz CPU
Trident Cyber9385 video controller with 1MB, 12.1" TFT display with 800x600 resolution
106 MB memory standard
2.1GB HDD
ES1688 Audio controller
IrDA 1.0
UltraBay Thick with 1.44MB FDD
(2) Type II CardBus slots or (1) type III

Trident Cyber9385 video adapter: Features:  Chipset: Trident ProVidia: PCI ID: 1023:9385 1 or 2MB EDO DRAM Interface: PCI 2.1
I have no clue what the Vertical / Horizontal scan rates are.

I boot this laptop using Plop and boot to a PCMIA slot using USB thumbdrive ( This was a battle that is solved )
I loaded the Core-10.0. iso on the thumbdrive for my test. ( This Core load works well on several other Dell Laptops ) 

The problem I have is: 
When I load one of the choices with the IBM and X starts its not good. The Lcd display is not working. If i Ctrl+Alt+Backspace out and end x. I ran Xsetup and all the choices give me the same results. 

Can anyone shed some light on this. Kindly Understand I am new kinda new to LINUX.
Only experience I have is at one time I had Red Hat 6.1 working on this laptop but I am not sure what the Xf86config consisted of. Its all lost. This laptop did work with X with Readhat so maybe we have a chance to get the IBM 760 running with Tiny core.






« Last Edit: March 14, 2019, 08:27:30 AM by Cometphoton »
Thanks for the support

Offline Cometphoton

  • WikiUser
  • *
  • Posts: 5
Re: Video Xsetup problems IBM 760XL
« Reply #1 on: March 14, 2019, 09:12:13 AM »
Trident TUGI 9660 may be the correct Driver ? Found some old notes I had on the Red hat installation. Seems this was one of my solutions during the installation.
Thanks for the support

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9956
Re: Video Xsetup problems IBM 760XL
« Reply #2 on: March 14, 2019, 10:58:49 AM »
Some of those old GPUs are not vesa compatible. Xfbdev or xorg may work, see the FAQ for framebuffer bootcodes.
The only barriers that can stop you are the ones you create yourself.

Offline Cometphoton

  • WikiUser
  • *
  • Posts: 5
Re: Video Xsetup problems IBM 760XL
« Reply #3 on: March 14, 2019, 12:00:10 PM »
OK I into this now.
How do I do this:

boot: tinycore tce=hda1 text vga=788


Thanks for the support

Offline Cometphoton

  • WikiUser
  • *
  • Posts: 5
Re: Video Xsetup problems IBM 760XL
« Reply #4 on: March 14, 2019, 01:08:30 PM »
At the boot choice screen I pressed ESC
Now I am at the prompt

boot: core plus tce=hda1 text vga=788

$ tce-load -w -i Xfbdev.tcz # This is for TC 2.3 and above

$ xsetup.sh
$ startx

Thanks for the support

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6427
Re: Video Xsetup problems IBM 760XL
« Reply #5 on: March 14, 2019, 01:18:41 PM »
Hi Cometphoton
Are you sure your USB thumbdrive is hda1? I doubt that it is. What's the output for this command:
Code: [Select]
fdisk -lThat's a lower case  L  in that command.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10717
Re: Video Xsetup problems IBM 760XL
« Reply #6 on: March 15, 2019, 03:42:39 AM »
Trident TUGI 9660 may be the correct Driver?

You could try compiling xf86-video-trident

Offline Pats

  • Sr. Member
  • ****
  • Posts: 294
Re: Video Xsetup problems IBM 760XL
« Reply #7 on: March 15, 2019, 05:43:43 AM »
Posted by :Cometphoton
Quote
...Can anyone shed some light on this. Kindly Understand I am new kinda new to LINUX.
Only experience I have is at one time I had Red Hat 6.1 working on this laptop but I am not sure what the Xf86config consisted of. Its all lost. This laptop did work with X with Readhat so maybe we have a chance to get the IBM 760 running with Tiny core.

If time permits, then Better understand linux in general and TCL in perticular here :
http://tinycorelinux.net/book.html

:)