WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Noob feedback - wicd launch issue, firefox install issue  (Read 104 times)

Offline postcd

  • WikiUser
  • *
  • Posts: 3
Noob feedback - wicd launch issue, firefox install issue
« on: March 13, 2019, 05:24:59 AM »
I ran V10 Plus (100MB iso) Dled today from official page.
In boot menu (which is not easy for noob to decide which option to select) i tried first boot option and also the one that says wifi and drivers or such.
After installing wicd using package manager, i was unable to launch "sudo wicd-start" via terminal or via Launch program feature as instructed in tutorial: newbielink:http://wiki.tinycorelinux.net/wiki:setting_up_wifi [nonactive]

Then worked "wicd" command, but it shows icon in the menu, but it does nothing to click it.
The /var/log/wicd/wicd.log shows Failed to connect to socket error system_bus_socket: No such file or directory

Also i tried to install firefox_getLatest.tcz, but it is not apparent for noob like me how to complete it. It installed package OK. but what then? "firefox" command does not work.

Third thing is keyboard layout language. I need czech keyboard and in COntrol panel i do not see the option to change language. It is not intuitive.

Fourth issue, i do not know how to install the OS on HDD so i can free up my USB flash disk port and use it for my peripherals.
« Last Edit: March 13, 2019, 05:43:44 AM by postcd »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6298
Re: Noob feedback - wicd launch issue, firefox install issue
« Reply #1 on: March 13, 2019, 05:46:09 AM »
Hi postcd
Quote
After installing wicd using package manager, i was unable to launch "sudo wicd-start" via terminal or via Launch program feature as instructed ...
I believe  wifi.tcz  is the preferred tool to use these days.

Quote
... in tutorial: newbielink:http://wiki.tinycorelinux.net/wiki:setting_up_wifi ...
Wiki pages are maintained by forum members. Any member can correct them using their forum login credentials.

Quote
... Also i tried to install firefox latest ...
It's called  firefox_getLatest.tcz. Did you read the instructions in the  .info  file? :
http://tinycorelinux.net/10.x/x86/tcz/firefox_getLatest.tcz.info

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10492
Re: Noob feedback - wicd launch issue, firefox install issue
« Reply #2 on: March 13, 2019, 05:59:53 AM »
As per the wicd info file:
Quote
To start wicd daemon add to your boot script (/opt/bootlocal.sh):
        /usr/local/etc/init.d/dbus restart
        /usr/local/etc/init.d/wicd start

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10492
Re: Noob feedback - wicd launch issue, firefox install issue
« Reply #3 on: March 13, 2019, 06:01:47 AM »
To install to hd you can use the tc-install extension, but be carefull you do not delete something important...

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6298
Re: Noob feedback - wicd launch issue, firefox install issue
« Reply #4 on: March 13, 2019, 06:10:27 AM »
Hi postcd
I see you edited your post while I was composing my answer. You might want to take an hour to read this fine book on using Tinycore:
http://tinycorelinux.net/book.html

Quote
Third thing is keyboard layout language. I need czech keyboard and in COntrol panel i do not see the option to change language. It is not intuitive.
The FAQs has some information on that:
http://tinycorelinux.net/faq.html#keyboard
More can be found by going here:
http://forum.tinycorelinux.net/index.php?action=search
Set  Search order:  to  Most recent topics first  and set  Search for:  to  kmaps.
« Last Edit: March 13, 2019, 06:12:23 AM by Rich »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6298
Re: Noob feedback - wicd launch issue, firefox install issue
« Reply #5 on: March 13, 2019, 06:48:11 AM »
Hi postcd
Quote
... i was unable to launch "sudo wicd-start" via terminal or via Launch program feature as instructed ...
That was a typo in the Wiki and should have read  wicd start. Based on a search through the forum it's been there quite a
while but was never fixed. The Wiki has been corrected.