WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help  (Read 746 times)

Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Ok so i have read the faq here:
http://tinycorelinux.net/faq.html#keyboard

installed the via the app on x (kmaps.tcz) and added it to boot with that tool

sudo loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys gives no return on my command line and changes nothing i cant type ÄÜ and everything else like -_\ / is moved around on my keyboard z=y and y=z and so on...

what can i do? There are several threads on this forum none of which work, even changing the xconfig files wont help

I have tried http://forum.tinycorelinux.net/index.php/topic,19847.45.html
post Number #57 and it doesn help!

cat /opt/bootlocal.sh does contain my keyboard mappings yet nothing changes EVEN AFTER A REBOOT it is there but gets ignored

Where can i change the keyboard layout systemwide and maybe set the locale to germany!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #1 on: February 28, 2019, 02:32:27 AM »
You can set the locale using the getlocale extension

Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #2 on: February 28, 2019, 03:02:36 AM »
ok thanks i installed getlocale extension and set it to OnDemand

then i ran:
sudo getlocale.sh

Menü poped up and i chosed the de-German ones..script did its thing
i hit enter to exit it
sudo backup

now where do i need to add "lang=de_DE@euro" to? The /opt/bootlocal.sh needs to be changed?

I also installed nano to get an familiar editor for me

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #3 on: February 28, 2019, 03:17:48 AM »
Depending on which RPi you have, you put "lang=de_DE@euro" in /mnt/mmcblk0p1/cmdline.txt or /mnt/mmcblk0p1/cmdline3.txt

Note that you don't really need getlocale in ondemand.lst,  but you do need to check that mylocale is in onboot.lst

Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #4 on: February 28, 2019, 05:38:26 AM »
My board is a Raspberry Pi 3 (non plus old version)

Didn't work:   
sudo su
nano /mnt/mmcblk0p1/cmdline.txt
lang=de_DE@euro"   in first line

backup
reboot

if i type locale it shows:
LANG=C
C
C
and so on

Keyboard is still chaos y=z and z=y :-( disappointing.. :-/
« Last Edit: February 28, 2019, 05:51:22 AM by ScaleThePoo »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #5 on: February 28, 2019, 05:56:16 AM »
I believe that you would need to use /mnt/mmcblk0p1/cmdline3.txt for an RPi3.

You should also check that the mylocale extension created by getlocale is loaded.

Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #6 on: February 28, 2019, 06:02:50 AM »
how do i check "check that the mylocale extension created by getlocale is loaded"

 service --status-all | grep mylocale
returns:
-sh: service: not found


Edited
/mnt/mmcblk0p1/cmdline3.txt

and backup and yes it is there after reboot..

nothing didn't help :-/

UPDATE1:
i did change both the cmdline.txt & cmdline3.txt on the /mnt/mmcblk0p1 via my windows pc so it is there for sure

now locale show de_DE@euro everywhere!!

Keyboard still wrong :-(
« Last Edit: February 28, 2019, 06:24:47 AM by ScaleThePoo »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6426
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #7 on: February 28, 2019, 06:29:11 AM »
Hi ScaleThePoo
how do i check "check that the mylocale extension created by getlocale is loaded" ...
If this finds the file then it is loaded:
Code: [Select]
ls -l /usr/local/tce.installed/mylocale

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #8 on: February 28, 2019, 06:33:09 AM »
If "locale show de_DE@euro everywhere", then mylocale is loaded.

For future use, to check if an extension is loaded:
Code: [Select]
$ tce-status -i | grep extension_name
I've never tried to change the keyboard, so I can't help with that, but there are many threads on it in these forums and several entries in the wiki.


Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #9 on: February 28, 2019, 06:35:39 AM »
Looks like it works now:

tc@box:~$ ls -l /usr/local/tce.installed/mylocale
-rwxrwxr-x    1 root     staff            0 Jan  1 00:00 /usr/local/tce.installed/mylocale
tc@box:~$


the Locale is now set to DE Germany but still i can type ÄÜÖ which is not so important, but my whole keyboard layout is chaos

@Juanito
Does the wiki also work for PiCore which is not TinyCorex86?

The FAQ lists how to change the keyboard which does nothing on piCore


I do have another slight problem now, as i followed the forums i created a file in
usr/local/share/X11/xorg.conf.d/10-keyboard.conf
it now blocks somehow the shutdown backup option on the x desktop as it is not there any more..

How can i remove it from the backup script?

« Last Edit: February 28, 2019, 06:40:21 AM by ScaleThePoo »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6426
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #10 on: February 28, 2019, 06:45:45 AM »
Hi ScaleThePoo
Quote
How can i remove it from the backup script?
Remove the line from  /opt/.filetool.lst.

Offline ScaleThePoo

  • WikiUser
  • *
  • Posts: 8
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #11 on: February 28, 2019, 06:51:54 AM »
OK thank you :-P

Now changing the keyboard to "loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys.kmap" magically works :-P

The FAQ should be edited that you NEED the locale thing, its not working they way it was documented atleast not on rpi3 piCore 9.0.3 currently

i edited /opt/bootlocal.sh with nano does work if you issue backup command like it should...


now a little time later i did several restarts just test installed dillo3 on my last xsession, without backup..keyboard is back to US again :-(
« Last Edit: February 28, 2019, 07:21:21 AM by ScaleThePoo »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9955
Re: piCore-9.0.3 How to change the Keyboard Layout to German? Pls help
« Reply #12 on: February 28, 2019, 09:54:36 AM »
loadkmap affects the console keymap. Xorg has its own keymaps. Neither keymap is affected by locales.
The only barriers that can stop you are the ones you create yourself.